aboutsummaryrefslogtreecommitdiff
path: root/games/tecnoballz
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-01-20 22:43:06 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-01-20 22:43:06 +0000
commit6359b9a527d2f5ef24b67f53b2ce4c0c1f0aa43a (patch)
treef4560cd6a787a610b5bfe38209dbbfaeb79bc8cc /games/tecnoballz
parent6dcceb837cb5bc86576b3fc3f403405d2496151c (diff)
downloadports-6359b9a527d2f5ef24b67f53b2ce4c0c1f0aa43a.tar.gz
ports-6359b9a527d2f5ef24b67f53b2ce4c0c1f0aa43a.zip
Notes
Diffstat (limited to 'games/tecnoballz')
-rw-r--r--games/tecnoballz/Makefile64
-rw-r--r--games/tecnoballz/distinfo2
-rw-r--r--games/tecnoballz/files/patch-src::Makefile25
-rw-r--r--games/tecnoballz/pkg-descr7
-rw-r--r--games/tecnoballz/pkg-install11
-rw-r--r--games/tecnoballz/pkg-plist156
6 files changed, 265 insertions, 0 deletions
diff --git a/games/tecnoballz/Makefile b/games/tecnoballz/Makefile
new file mode 100644
index 000000000000..6be22aae5d26
--- /dev/null
+++ b/games/tecnoballz/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for: tecnoballz
+# Date created: 19 Jan 2005
+# Whom: Jean-Yves Lefort <jylefort@brutele.be>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tecnoballz
+PORTVERSION= 0.90
+CATEGORIES= games
+MASTER_SITES= http://linux.tlk.fr/games/TecnoballZ/download/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= jylefort@brutele.be
+COMMENT= A brick breaker (Arkanoid-like game)
+
+LIB_DEPENDS= mikmod.2:${PORTSDIR}/audio/libmikmod
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+BUILD_WRKSRC= ${WRKSRC}/src
+
+USE_X_PREFIX= yes
+USE_SDL= sdl mixer
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+MAN6= tecnoballz.6
+
+MAKE_ENV+= LIBMIKMOD_CONFIG=${LOCALBASE}/bin/libmikmod-config
+
+post-extract:
+ @${RM} -f \
+ ${WRKSRC}/src/TecnoballZ/hires/.xvpics/*.bmp \
+ ${WRKSRC}/src/TecnoballZ/lores/.xvpics/*.bmp
+ @${RMDIR} \
+ ${WRKSRC}/src/TecnoballZ/hires/.xvpics \
+ ${WRKSRC}/src/TecnoballZ/lores/.xvpics \
+
+post-patch:
+ @${FIND} ${WRKSRC}/include -name '*.h' | ${XARGS} ${REINPLACE_CMD} \
+ -e 's|SDL/||'
+ @${REINPLACE_CMD} -e \
+ 's|/var/lib/games|/var/games|; \
+ s|TecnoballZ/|${DATADIR}/|' \
+ ${WRKSRC}/src/ressources.cc
+
+do-install:
+ ${MKDIR} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/tecnoballz ${PREFIX}/bin
+ ${CHGRP} games ${PREFIX}/bin/tecnoballz
+ ${CHMOD} g+s ${PREFIX}/bin/tecnoballz
+
+ ${MKDIR} ${DATADIR}
+ ${CP} -R ${WRKSRC}/src/TecnoballZ/* ${DATADIR}
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}
+ ${CHMOD} 0644 ${DATADIR}/textures/*
+
+ ${MKDIR} ${MAN6PREFIX}/man/man6
+ ${INSTALL_MAN} ${WRKSRC}/man/tecnoballz.1 ${MAN6PREFIX}/man/man6/tecnoballz.6
+
+post-install:
+ @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.mk>
diff --git a/games/tecnoballz/distinfo b/games/tecnoballz/distinfo
new file mode 100644
index 000000000000..bb090eb7b677
--- /dev/null
+++ b/games/tecnoballz/distinfo
@@ -0,0 +1,2 @@
+MD5 (tecnoballz-0.90.tgz) = d6c4f22dd2cdab7c6242b2455d65aa5b
+SIZE (tecnoballz-0.90.tgz) = 1761789
diff --git a/games/tecnoballz/files/patch-src::Makefile b/games/tecnoballz/files/patch-src::Makefile
new file mode 100644
index 000000000000..f2eb024e04ec
--- /dev/null
+++ b/games/tecnoballz/files/patch-src::Makefile
@@ -0,0 +1,25 @@
+--- src/Makefile.orig Wed Jan 19 23:37:51 2005
++++ src/Makefile Thu Jan 20 00:17:11 2005
+@@ -1,10 +1,9 @@
+ CC = gcc
+-CXX = g++
+ #CXXFLAGS = -O3 -Wall -s
+-CXXFLAGS = -O3 -Wall
++CXXFLAGS += -Wall `$(SDL_CONFIG) --cflags` `$(LIBMIKMOD_CONFIG) --cflags`
+ PROG = tecnoballz
+ PREFIX = /usr/local
+-LIBPATH = -L/usr/X11R6/lib -L.
++LIBPATH = `$(SDL_CONFIG) --libs` -lSDL_mixer `$(LIBMIKMOD_CONFIG) --libs`
+ TMPDIR = /var/tmp/tecnoballz.dist
+ ifeq ($(PREFIX),)
+ EXEDIR = $(HOME)/bin
+@@ -94,8 +93,7 @@
+
+
+ $(PROG): $(OBJ)
+- $(CXX) $(LIBPATH) $(OBJ) $(PROFLAG) -lm \
+- -lSDL -lSDL_mixer -lmikmod -o $@
++ $(CXX) $(LIBPATH) $(OBJ) $(PROFLAG) -o $@
+
+ clean:
+ rm -f $(OBJ) nomfichierscore.o
diff --git a/games/tecnoballz/pkg-descr b/games/tecnoballz/pkg-descr
new file mode 100644
index 000000000000..6223c4a348b5
--- /dev/null
+++ b/games/tecnoballz/pkg-descr
@@ -0,0 +1,7 @@
+TecnoballZs is a brick breaker (Arkanoid-like game) with 50 levels of
+game and 11 special levels.
+
+WWW: http://linux.tlk.fr/games/TecnoballZ/
+
+- Jean-Yves Lefort
+jylefort@brutele.be
diff --git a/games/tecnoballz/pkg-install b/games/tecnoballz/pkg-install
new file mode 100644
index 000000000000..c8de25f28eae
--- /dev/null
+++ b/games/tecnoballz/pkg-install
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+SCOREDIR="/var/games"
+SCOREFILE="/var/games/tecnoballz.hi"
+
+[ "$2" != "POST-INSTALL" -o -f "$SCOREFILE" ] && exit 0
+
+mkdir -p $SCOREDIR
+touch $SCOREFILE
+chown root:games $SCOREFILE
+chmod 664 $SCOREFILE
diff --git a/games/tecnoballz/pkg-plist b/games/tecnoballz/pkg-plist
new file mode 100644
index 000000000000..bcc3a2c973fa
--- /dev/null
+++ b/games/tecnoballz/pkg-plist
@@ -0,0 +1,156 @@
+bin/tecnoballz
+share/tecnoballz/cosinus128.list
+share/tecnoballz/edmap01.data
+share/tecnoballz/edmap02.data
+share/tecnoballz/edmap03.data
+share/tecnoballz/gard_lissa.list
+share/tecnoballz/hires/ani_head.bmp
+share/tecnoballz/hires/ba_score2.bmp
+share/tecnoballz/hires/bumper_1.bmp
+share/tecnoballz/hires/bumper_2.bmp
+share/tecnoballz/hires/font_messa.bmp
+share/tecnoballz/hires/font_score.bmp
+share/tecnoballz/hires/fontgame.bmp
+share/tecnoballz/hires/fontmenu.bmp
+share/tecnoballz/hires/gigablzt.bmp
+share/tecnoballz/hires/map_edit.bmp
+share/tecnoballz/hires/new_shop.bmp
+share/tecnoballz/hires/pagezbob.bmp
+share/tecnoballz/hires/zebricks.bmp
+share/tecnoballz/lores/ani_head.bmp
+share/tecnoballz/lores/ba_score2.bmp
+share/tecnoballz/lores/bumper_1.bmp
+share/tecnoballz/lores/bumper_2.bmp
+share/tecnoballz/lores/font_messa.bmp
+share/tecnoballz/lores/font_score.bmp
+share/tecnoballz/lores/fontgame.bmp
+share/tecnoballz/lores/fontmenu.bmp
+share/tecnoballz/lores/gigablzt.bmp
+share/tecnoballz/lores/map_edit.bmp
+share/tecnoballz/lores/new_shop.bmp
+share/tecnoballz/lores/pagezbob.bmp
+share/tecnoballz/lores/zebricks.bmp
+share/tecnoballz/min60map.bmp
+share/tecnoballz/musics/area1-game.mod
+share/tecnoballz/musics/area1-game2.mod
+share/tecnoballz/musics/area2-game.mod
+share/tecnoballz/musics/area3-game.mod
+share/tecnoballz/musics/area4-game.mod
+share/tecnoballz/musics/area5-game.mod
+share/tecnoballz/musics/gardien-go.mod
+share/tecnoballz/musics/high-score.mod
+share/tecnoballz/musics/over-theme.mod
+share/tecnoballz/musics/tecno-winn.mod
+share/tecnoballz/musics/tecnoballz.mod
+share/tecnoballz/sounds/ralarm.wav
+share/tecnoballz/sounds/rappar.wav
+share/tecnoballz/sounds/raspire.wav
+share/tecnoballz/sounds/ratom.wav
+share/tecnoballz/sounds/rbricote.wav
+share/tecnoballz/sounds/rbrique1.wav
+share/tecnoballz/sounds/rbrique2.wav
+share/tecnoballz/sounds/rbrique3.wav
+share/tecnoballz/sounds/rbrique4.wav
+share/tecnoballz/sounds/rbrique5.wav
+share/tecnoballz/sounds/rdetruit_indes.wav
+share/tecnoballz/sounds/reject.wav
+share/tecnoballz/sounds/rexeplo_atom.wav
+share/tecnoballz/sounds/rexplo_big.wav
+share/tecnoballz/sounds/rexplo_rak.wav
+share/tecnoballz/sounds/rgadget_sound.wav
+share/tecnoballz/sounds/rindes_1.wav
+share/tecnoballz/sounds/rindes_2.wav
+share/tecnoballz/sounds/rlife_moins.wav
+share/tecnoballz/sounds/rlife_plus.wav
+share/tecnoballz/sounds/rmoney.wav
+share/tecnoballz/sounds/rmontre_touche.wav
+share/tecnoballz/sounds/rraquette.wav
+share/tecnoballz/sounds/rtecno.wav
+share/tecnoballz/sounds/rtir_monstre.wav
+share/tecnoballz/sounds/rtir_rak.wav
+share/tecnoballz/sounds/rtransfo.wav
+share/tecnoballz/tableau.data
+share/tecnoballz/textures/map01.bmp
+share/tecnoballz/textures/map02.bmp
+share/tecnoballz/textures/map03.bmp
+share/tecnoballz/textures/map04.bmp
+share/tecnoballz/textures/map05.bmp
+share/tecnoballz/textures/map06.bmp
+share/tecnoballz/textures/map07.bmp
+share/tecnoballz/textures/map08.bmp
+share/tecnoballz/textures/map09.bmp
+share/tecnoballz/textures/map10.bmp
+share/tecnoballz/textures/map11.bmp
+share/tecnoballz/textures/map12.bmp
+share/tecnoballz/textures/map13.bmp
+share/tecnoballz/textures/map14.bmp
+share/tecnoballz/textures/map15.bmp
+share/tecnoballz/textures/map16.bmp
+share/tecnoballz/textures/map17.bmp
+share/tecnoballz/textures/map18.bmp
+share/tecnoballz/textures/map19.bmp
+share/tecnoballz/textures/map20.bmp
+share/tecnoballz/textures/map21.bmp
+share/tecnoballz/textures/map22.bmp
+share/tecnoballz/textures/map23.bmp
+share/tecnoballz/textures/map24.bmp
+share/tecnoballz/textures/map25.bmp
+share/tecnoballz/textures/map26.bmp
+share/tecnoballz/textures/map27.bmp
+share/tecnoballz/textures/map28.bmp
+share/tecnoballz/textures/map29.bmp
+share/tecnoballz/textures/map30.bmp
+share/tecnoballz/textures/map31.bmp
+share/tecnoballz/textures/map32.bmp
+share/tecnoballz/textures/map33.bmp
+share/tecnoballz/textures/map34.bmp
+share/tecnoballz/textures/map35.bmp
+share/tecnoballz/textures/map36.bmp
+share/tecnoballz/textures/map37.bmp
+share/tecnoballz/textures/map38.bmp
+share/tecnoballz/textures/map39.bmp
+share/tecnoballz/textures/map40.bmp
+share/tecnoballz/textures/map41.bmp
+share/tecnoballz/textures/map42.bmp
+share/tecnoballz/textures/map43.bmp
+share/tecnoballz/textures/map44.bmp
+share/tecnoballz/textures/map45.bmp
+share/tecnoballz/textures/map46.bmp
+share/tecnoballz/textures/map47.bmp
+share/tecnoballz/textures/map48.bmp
+share/tecnoballz/textures/map49.bmp
+share/tecnoballz/textures/map50.bmp
+share/tecnoballz/textures/map51.bmp
+share/tecnoballz/textures/map52.bmp
+share/tecnoballz/textures/map53.bmp
+share/tecnoballz/textures/map54.bmp
+share/tecnoballz/textures/map55.bmp
+share/tecnoballz/textures/map56.bmp
+share/tecnoballz/textures/map57.bmp
+share/tecnoballz/textures/map58.bmp
+share/tecnoballz/textures/map59.bmp
+share/tecnoballz/textures/map60.bmp
+share/tecnoballz/textures/map61.bmp
+share/tecnoballz/textures/map62.bmp
+share/tecnoballz/textures/map63.bmp
+share/tecnoballz/textures/map64.bmp
+share/tecnoballz/textures/map65.bmp
+share/tecnoballz/textures/map66.bmp
+share/tecnoballz/textures/map67.bmp
+share/tecnoballz/textures/map68.bmp
+share/tecnoballz/textures/map69.bmp
+share/tecnoballz/textures/map70.bmp
+share/tecnoballz/textures/map71.bmp
+share/tecnoballz/textures/map72.bmp
+share/tecnoballz/textures/map73.bmp
+share/tecnoballz/textures/map74.bmp
+share/tecnoballz/textures/map75.bmp
+share/tecnoballz/textures/map76.bmp
+share/tecnoballz/textures/map77.bmp
+share/tecnoballz/textures/map78.bmp
+@dirrm share/tecnoballz/hires
+@dirrm share/tecnoballz/lores
+@dirrm share/tecnoballz/musics
+@dirrm share/tecnoballz/sounds
+@dirrm share/tecnoballz/textures
+@dirrm share/tecnoballz