aboutsummaryrefslogtreecommitdiff
path: root/games/teeworlds
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-11-07 23:11:04 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-11-07 23:11:04 +0000
commitbfd936ae186cb639348687ed5c2da5d4ddf00a85 (patch)
treecf4a03cbce80bec28de040044dfdaddc20731526 /games/teeworlds
parentabd4961f469d0477fe6d26feae06cabdd609ede8 (diff)
downloadports-bfd936ae186cb639348687ed5c2da5d4ddf00a85.tar.gz
ports-bfd936ae186cb639348687ed5c2da5d4ddf00a85.zip
Notes
Diffstat (limited to 'games/teeworlds')
-rw-r--r--games/teeworlds/Makefile47
-rw-r--r--games/teeworlds/distinfo4
-rw-r--r--games/teeworlds/pkg-plist496
3 files changed, 21 insertions, 526 deletions
diff --git a/games/teeworlds/Makefile b/games/teeworlds/Makefile
index dad71369a03a..9a273fc36cd4 100644
--- a/games/teeworlds/Makefile
+++ b/games/teeworlds/Makefile
@@ -2,55 +2,52 @@
# $FreeBSD$
PORTNAME= teeworlds
-PORTVERSION= 0.6.1
-PORTREVISION= 2
+PORTVERSION= 0.6.2
CATEGORIES= games
-MASTER_SITES= http://www.teeworlds.com/files/ \
- http://mirror.amdmi3.ru/distfiles/ \
- http://github.com/downloads/matricks/bam/ \
- http://files.malikania.fr/distfiles/
+MASTER_SITES= https://www.teeworlds.com/files/ \
+ http://mirror.amdmi3.ru/distfiles/
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} bam-${BAM_VERSION}${EXTRACT_SUFX}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Platform game featuring buggers equipped with weapons
-LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
+LICENSE= ZLIB
+
+LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
USE_PYTHON_BUILD= yes
BAM_VERSION= 0.4.0
BAM_WRKSRC= ${WRKDIR}/bam-${BAM_VERSION}
BAM_TARGET= release
-WRKSRC= ${WRKDIR}/teeworlds-b177-r50edfd37-source
-PORTDOCS= readme.txt license.txt
+PLIST_FILES+= bin/${PORTNAME}_srv
+PORTDATA= *
-OPTIONS_DEFINE= SERVER
-SERVER_DESC= Build dedicated server only
+OPTIONS_DEFINE= SERVER_ONLY
+SERVER_ONLY_DESC=Build dedicated server only
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${ARCH} == "ia64"
BROKEN= Does not install on ia64: gets bus error
.endif
-.if ${PORT_OPTIONS:MSERVER}
+.if ${PORT_OPTIONS:MSERVER_ONLY}
BAM_TARGET= server_release
-PLIST_SUB+= CLIENT="@comment "
PKGNAMESUFFX= -server
.else
USE_XORG= x11
USE_GL= gl glu
USE_SDL= sdl
-PLIST_SUB+= CLIENT=""
+PLIST_FILES+= bin/${PORTNAME}
DESKTOP_ENTRIES="Teeworlds" \
"Platform game featuring buggers equipped with weapons" \
"${DATADIR}/Teeworlds.ico" \
- "teeworlds" \
+ "${PORTNAME}" \
"Game;ActionGame;" \
- false
+ ""
.endif
post-patch:
@@ -72,17 +69,11 @@ do-build:
${BAM_WRKSRC}/bam -n -a -v ${_MAKE_JOBS:C/-j/-j /} ${BAM_TARGET}
do-install:
-.if ! ${PORT_OPTIONS:MSERVER}
- ${INSTALL_PROGRAM} ${WRKSRC}/teeworlds ${PREFIX}/bin
-.endif
- ${INSTALL_PROGRAM} ${WRKSRC}/teeworlds_srv ${PREFIX}/bin
- ${MKDIR} ${DATADIR}
- @cd ${WRKSRC}/data && ${COPYTREE_SHARE} . ${DATADIR}/
- ${INSTALL_DATA} ${WRKSRC}/other/icons/Teeworlds.ico ${DATADIR}
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/license.txt ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}/
+.if ! ${PORT_OPTIONS:MSERVER_ONLY}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}_srv ${STAGEDIR}${PREFIX}/bin/
+ @cd ${WRKSRC}/data && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/other/icons/Teeworlds.ico ${STAGEDIR}${DATADIR}/
.include <bsd.port.mk>
diff --git a/games/teeworlds/distinfo b/games/teeworlds/distinfo
index 4a2b7f7ce507..cf7e6546c97f 100644
--- a/games/teeworlds/distinfo
+++ b/games/teeworlds/distinfo
@@ -1,4 +1,4 @@
-SHA256 (teeworlds-0.6.1-source.tar.gz) = 6328d48fb98d451af8e1dba0999190496e851842c84e4594d413b79aca67b908
-SIZE (teeworlds-0.6.1-source.tar.gz) = 8599538
+SHA256 (teeworlds-0.6.2-source.tar.gz) = 00061b30377597a61810eda3dc5de0caad439ca851cb8eebbe4152e4f861e2af
+SIZE (teeworlds-0.6.2-source.tar.gz) = 9179568
SHA256 (bam-0.4.0.tar.gz) = 5e4e4920b4d265da582f66774e9b1ec8ddfbe75ddc028fba86c12f686ea18db3
SIZE (bam-0.4.0.tar.gz) = 206780
diff --git a/games/teeworlds/pkg-plist b/games/teeworlds/pkg-plist
deleted file mode 100644
index 5c1db7250200..000000000000
--- a/games/teeworlds/pkg-plist
+++ /dev/null
@@ -1,496 +0,0 @@
-%%CLIENT%%bin/teeworlds
-bin/teeworlds_srv
-%%DATADIR%%/Teeworlds.ico
-%%DATADIR%%/audio/foley_body_impact-01.wv
-%%DATADIR%%/audio/foley_body_impact-02.wv
-%%DATADIR%%/audio/foley_body_impact-03.wv
-%%DATADIR%%/audio/foley_body_splat-01.wv
-%%DATADIR%%/audio/foley_body_splat-02.wv
-%%DATADIR%%/audio/foley_body_splat-03.wv
-%%DATADIR%%/audio/foley_body_splat-04.wv
-%%DATADIR%%/audio/foley_dbljump-01.wv
-%%DATADIR%%/audio/foley_dbljump-02.wv
-%%DATADIR%%/audio/foley_dbljump-03.wv
-%%DATADIR%%/audio/foley_foot_left-01.wv
-%%DATADIR%%/audio/foley_foot_left-02.wv
-%%DATADIR%%/audio/foley_foot_left-03.wv
-%%DATADIR%%/audio/foley_foot_left-04.wv
-%%DATADIR%%/audio/foley_foot_right-01.wv
-%%DATADIR%%/audio/foley_foot_right-02.wv
-%%DATADIR%%/audio/foley_foot_right-03.wv
-%%DATADIR%%/audio/foley_foot_right-04.wv
-%%DATADIR%%/audio/foley_land-01.wv
-%%DATADIR%%/audio/foley_land-02.wv
-%%DATADIR%%/audio/foley_land-03.wv
-%%DATADIR%%/audio/foley_land-04.wv
-%%DATADIR%%/audio/hook_attach-01.wv
-%%DATADIR%%/audio/hook_attach-02.wv
-%%DATADIR%%/audio/hook_attach-03.wv
-%%DATADIR%%/audio/hook_loop-01.wv
-%%DATADIR%%/audio/hook_loop-02.wv
-%%DATADIR%%/audio/hook_noattach-01.wv
-%%DATADIR%%/audio/hook_noattach-02.wv
-%%DATADIR%%/audio/hook_noattach-03.wv
-%%DATADIR%%/audio/music_menu.wv
-%%DATADIR%%/audio/sfx_ctf_cap_pl.wv
-%%DATADIR%%/audio/sfx_ctf_drop.wv
-%%DATADIR%%/audio/sfx_ctf_grab_en.wv
-%%DATADIR%%/audio/sfx_ctf_grab_pl.wv
-%%DATADIR%%/audio/sfx_ctf_rtn.wv
-%%DATADIR%%/audio/sfx_hit_strong-01.wv
-%%DATADIR%%/audio/sfx_hit_strong-02.wv
-%%DATADIR%%/audio/sfx_hit_weak-01.wv
-%%DATADIR%%/audio/sfx_hit_weak-02.wv
-%%DATADIR%%/audio/sfx_hit_weak-03.wv
-%%DATADIR%%/audio/sfx_msg-client.wv
-%%DATADIR%%/audio/sfx_msg-highlight.wv
-%%DATADIR%%/audio/sfx_msg-server.wv
-%%DATADIR%%/audio/sfx_pickup_arm-01.wv
-%%DATADIR%%/audio/sfx_pickup_arm-02.wv
-%%DATADIR%%/audio/sfx_pickup_arm-03.wv
-%%DATADIR%%/audio/sfx_pickup_arm-04.wv
-%%DATADIR%%/audio/sfx_pickup_gun.wv
-%%DATADIR%%/audio/sfx_pickup_hrt-01.wv
-%%DATADIR%%/audio/sfx_pickup_hrt-02.wv
-%%DATADIR%%/audio/sfx_pickup_launcher.wv
-%%DATADIR%%/audio/sfx_pickup_ninja.wv
-%%DATADIR%%/audio/sfx_pickup_sg.wv
-%%DATADIR%%/audio/sfx_skid-01.wv
-%%DATADIR%%/audio/sfx_skid-02.wv
-%%DATADIR%%/audio/sfx_skid-03.wv
-%%DATADIR%%/audio/sfx_skid-04.wv
-%%DATADIR%%/audio/sfx_spawn_wpn-01.wv
-%%DATADIR%%/audio/sfx_spawn_wpn-02.wv
-%%DATADIR%%/audio/sfx_spawn_wpn-03.wv
-%%DATADIR%%/audio/vo_teefault_cry-01.wv
-%%DATADIR%%/audio/vo_teefault_cry-02.wv
-%%DATADIR%%/audio/vo_teefault_ninja-01.wv
-%%DATADIR%%/audio/vo_teefault_ninja-02.wv
-%%DATADIR%%/audio/vo_teefault_ninja-03.wv
-%%DATADIR%%/audio/vo_teefault_ninja-04.wv
-%%DATADIR%%/audio/vo_teefault_pain_long-01.wv
-%%DATADIR%%/audio/vo_teefault_pain_long-02.wv
-%%DATADIR%%/audio/vo_teefault_pain_short-01.wv
-%%DATADIR%%/audio/vo_teefault_pain_short-02.wv
-%%DATADIR%%/audio/vo_teefault_pain_short-03.wv
-%%DATADIR%%/audio/vo_teefault_pain_short-04.wv
-%%DATADIR%%/audio/vo_teefault_pain_short-05.wv
-%%DATADIR%%/audio/vo_teefault_pain_short-06.wv
-%%DATADIR%%/audio/vo_teefault_pain_short-07.wv
-%%DATADIR%%/audio/vo_teefault_pain_short-08.wv
-%%DATADIR%%/audio/vo_teefault_pain_short-09.wv
-%%DATADIR%%/audio/vo_teefault_pain_short-10.wv
-%%DATADIR%%/audio/vo_teefault_pain_short-11.wv
-%%DATADIR%%/audio/vo_teefault_pain_short-12.wv
-%%DATADIR%%/audio/vo_teefault_sledge-01.wv
-%%DATADIR%%/audio/vo_teefault_sledge-02.wv
-%%DATADIR%%/audio/vo_teefault_sledge-03.wv
-%%DATADIR%%/audio/vo_teefault_spawn-01.wv
-%%DATADIR%%/audio/vo_teefault_spawn-02.wv
-%%DATADIR%%/audio/vo_teefault_spawn-03.wv
-%%DATADIR%%/audio/vo_teefault_spawn-04.wv
-%%DATADIR%%/audio/vo_teefault_spawn-05.wv
-%%DATADIR%%/audio/vo_teefault_spawn-06.wv
-%%DATADIR%%/audio/vo_teefault_spawn-07.wv
-%%DATADIR%%/audio/wp_flump_explo-01.wv
-%%DATADIR%%/audio/wp_flump_explo-02.wv
-%%DATADIR%%/audio/wp_flump_explo-03.wv
-%%DATADIR%%/audio/wp_flump_launch-01.wv
-%%DATADIR%%/audio/wp_flump_launch-02.wv
-%%DATADIR%%/audio/wp_flump_launch-03.wv
-%%DATADIR%%/audio/wp_gun_fire-01.wv
-%%DATADIR%%/audio/wp_gun_fire-02.wv
-%%DATADIR%%/audio/wp_gun_fire-03.wv
-%%DATADIR%%/audio/wp_hammer_hit-01.wv
-%%DATADIR%%/audio/wp_hammer_hit-02.wv
-%%DATADIR%%/audio/wp_hammer_hit-03.wv
-%%DATADIR%%/audio/wp_hammer_swing-01.wv
-%%DATADIR%%/audio/wp_hammer_swing-02.wv
-%%DATADIR%%/audio/wp_hammer_swing-03.wv
-%%DATADIR%%/audio/wp_ninja_attack-01.wv
-%%DATADIR%%/audio/wp_ninja_attack-02.wv
-%%DATADIR%%/audio/wp_ninja_attack-03.wv
-%%DATADIR%%/audio/wp_ninja_attack-04.wv
-%%DATADIR%%/audio/wp_ninja_hit-01.wv
-%%DATADIR%%/audio/wp_ninja_hit-02.wv
-%%DATADIR%%/audio/wp_ninja_hit-03.wv
-%%DATADIR%%/audio/wp_ninja_hit-04.wv
-%%DATADIR%%/audio/wp_noammo-01.wv
-%%DATADIR%%/audio/wp_noammo-02.wv
-%%DATADIR%%/audio/wp_noammo-03.wv
-%%DATADIR%%/audio/wp_noammo-04.wv
-%%DATADIR%%/audio/wp_noammo-05.wv
-%%DATADIR%%/audio/wp_rifle_bnce-01.wv
-%%DATADIR%%/audio/wp_rifle_bnce-02.wv
-%%DATADIR%%/audio/wp_rifle_bnce-03.wv
-%%DATADIR%%/audio/wp_rifle_fire-01.wv
-%%DATADIR%%/audio/wp_rifle_fire-02.wv
-%%DATADIR%%/audio/wp_rifle_fire-03.wv
-%%DATADIR%%/audio/wp_shotty_fire-01.wv
-%%DATADIR%%/audio/wp_shotty_fire-02.wv
-%%DATADIR%%/audio/wp_shotty_fire-03.wv
-%%DATADIR%%/audio/wp_switch-01.wv
-%%DATADIR%%/audio/wp_switch-02.wv
-%%DATADIR%%/audio/wp_switch-03.wv
-%%DATADIR%%/blob.png
-%%DATADIR%%/browse_icons.png
-%%DATADIR%%/console.png
-%%DATADIR%%/console_bar.png
-%%DATADIR%%/countryflags/AD.png
-%%DATADIR%%/countryflags/AE.png
-%%DATADIR%%/countryflags/AF.png
-%%DATADIR%%/countryflags/AG.png
-%%DATADIR%%/countryflags/AI.png
-%%DATADIR%%/countryflags/AL.png
-%%DATADIR%%/countryflags/AM.png
-%%DATADIR%%/countryflags/AO.png
-%%DATADIR%%/countryflags/AR.png
-%%DATADIR%%/countryflags/AS.png
-%%DATADIR%%/countryflags/AT.png
-%%DATADIR%%/countryflags/AU.png
-%%DATADIR%%/countryflags/AW.png
-%%DATADIR%%/countryflags/AX.png
-%%DATADIR%%/countryflags/AZ.png
-%%DATADIR%%/countryflags/BA.png
-%%DATADIR%%/countryflags/BB.png
-%%DATADIR%%/countryflags/BD.png
-%%DATADIR%%/countryflags/BE.png
-%%DATADIR%%/countryflags/BF.png
-%%DATADIR%%/countryflags/BG.png
-%%DATADIR%%/countryflags/BH.png
-%%DATADIR%%/countryflags/BI.png
-%%DATADIR%%/countryflags/BJ.png
-%%DATADIR%%/countryflags/BL.png
-%%DATADIR%%/countryflags/BM.png
-%%DATADIR%%/countryflags/BN.png
-%%DATADIR%%/countryflags/BO.png
-%%DATADIR%%/countryflags/BR.png
-%%DATADIR%%/countryflags/BS.png
-%%DATADIR%%/countryflags/BT.png
-%%DATADIR%%/countryflags/BW.png
-%%DATADIR%%/countryflags/BY.png
-%%DATADIR%%/countryflags/BZ.png
-%%DATADIR%%/countryflags/CA.png
-%%DATADIR%%/countryflags/CC.png
-%%DATADIR%%/countryflags/CD.png
-%%DATADIR%%/countryflags/CF.png
-%%DATADIR%%/countryflags/CG.png
-%%DATADIR%%/countryflags/CH.png
-%%DATADIR%%/countryflags/CI.png
-%%DATADIR%%/countryflags/CK.png
-%%DATADIR%%/countryflags/CL.png
-%%DATADIR%%/countryflags/CM.png
-%%DATADIR%%/countryflags/CN.png
-%%DATADIR%%/countryflags/CO.png
-%%DATADIR%%/countryflags/CR.png
-%%DATADIR%%/countryflags/CU.png
-%%DATADIR%%/countryflags/CV.png
-%%DATADIR%%/countryflags/CW.png
-%%DATADIR%%/countryflags/CX.png
-%%DATADIR%%/countryflags/CY.png
-%%DATADIR%%/countryflags/CZ.png
-%%DATADIR%%/countryflags/DE.png
-%%DATADIR%%/countryflags/DJ.png
-%%DATADIR%%/countryflags/DK.png
-%%DATADIR%%/countryflags/DM.png
-%%DATADIR%%/countryflags/DO.png
-%%DATADIR%%/countryflags/DZ.png
-%%DATADIR%%/countryflags/EC.png
-%%DATADIR%%/countryflags/EE.png
-%%DATADIR%%/countryflags/EG.png
-%%DATADIR%%/countryflags/EH.png
-%%DATADIR%%/countryflags/ER.png
-%%DATADIR%%/countryflags/ES.png
-%%DATADIR%%/countryflags/ET.png
-%%DATADIR%%/countryflags/FI.png
-%%DATADIR%%/countryflags/FJ.png
-%%DATADIR%%/countryflags/FK.png
-%%DATADIR%%/countryflags/FM.png
-%%DATADIR%%/countryflags/FO.png
-%%DATADIR%%/countryflags/FR.png
-%%DATADIR%%/countryflags/GA.png
-%%DATADIR%%/countryflags/GB.png
-%%DATADIR%%/countryflags/GD.png
-%%DATADIR%%/countryflags/GE.png
-%%DATADIR%%/countryflags/GF.png
-%%DATADIR%%/countryflags/GG.png
-%%DATADIR%%/countryflags/GH.png
-%%DATADIR%%/countryflags/GI.png
-%%DATADIR%%/countryflags/GL.png
-%%DATADIR%%/countryflags/GM.png
-%%DATADIR%%/countryflags/GN.png
-%%DATADIR%%/countryflags/GP.png
-%%DATADIR%%/countryflags/GQ.png
-%%DATADIR%%/countryflags/GR.png
-%%DATADIR%%/countryflags/GS.png
-%%DATADIR%%/countryflags/GT.png
-%%DATADIR%%/countryflags/GU.png
-%%DATADIR%%/countryflags/GW.png
-%%DATADIR%%/countryflags/GY.png
-%%DATADIR%%/countryflags/HK.png
-%%DATADIR%%/countryflags/HN.png
-%%DATADIR%%/countryflags/HR.png
-%%DATADIR%%/countryflags/HT.png
-%%DATADIR%%/countryflags/HU.png
-%%DATADIR%%/countryflags/ID.png
-%%DATADIR%%/countryflags/IE.png
-%%DATADIR%%/countryflags/IL.png
-%%DATADIR%%/countryflags/IM.png
-%%DATADIR%%/countryflags/IN.png
-%%DATADIR%%/countryflags/IO.png
-%%DATADIR%%/countryflags/IQ.png
-%%DATADIR%%/countryflags/IR.png
-%%DATADIR%%/countryflags/IS.png
-%%DATADIR%%/countryflags/IT.png
-%%DATADIR%%/countryflags/JE.png
-%%DATADIR%%/countryflags/JM.png
-%%DATADIR%%/countryflags/JO.png
-%%DATADIR%%/countryflags/JP.png
-%%DATADIR%%/countryflags/KE.png
-%%DATADIR%%/countryflags/KG.png
-%%DATADIR%%/countryflags/KH.png
-%%DATADIR%%/countryflags/KI.png
-%%DATADIR%%/countryflags/KM.png
-%%DATADIR%%/countryflags/KN.png
-%%DATADIR%%/countryflags/KP.png
-%%DATADIR%%/countryflags/KR.png
-%%DATADIR%%/countryflags/KW.png
-%%DATADIR%%/countryflags/KY.png
-%%DATADIR%%/countryflags/KZ.png
-%%DATADIR%%/countryflags/LA.png
-%%DATADIR%%/countryflags/LB.png
-%%DATADIR%%/countryflags/LC.png
-%%DATADIR%%/countryflags/LI.png
-%%DATADIR%%/countryflags/LK.png
-%%DATADIR%%/countryflags/LR.png
-%%DATADIR%%/countryflags/LS.png
-%%DATADIR%%/countryflags/LT.png
-%%DATADIR%%/countryflags/LU.png
-%%DATADIR%%/countryflags/LV.png
-%%DATADIR%%/countryflags/LY.png
-%%DATADIR%%/countryflags/MA.png
-%%DATADIR%%/countryflags/MC.png
-%%DATADIR%%/countryflags/MD.png
-%%DATADIR%%/countryflags/ME.png
-%%DATADIR%%/countryflags/MF.png
-%%DATADIR%%/countryflags/MG.png
-%%DATADIR%%/countryflags/MH.png
-%%DATADIR%%/countryflags/MK.png
-%%DATADIR%%/countryflags/ML.png
-%%DATADIR%%/countryflags/MM.png
-%%DATADIR%%/countryflags/MN.png
-%%DATADIR%%/countryflags/MO.png
-%%DATADIR%%/countryflags/MP.png
-%%DATADIR%%/countryflags/MQ.png
-%%DATADIR%%/countryflags/MR.png
-%%DATADIR%%/countryflags/MS.png
-%%DATADIR%%/countryflags/MT.png
-%%DATADIR%%/countryflags/MU.png
-%%DATADIR%%/countryflags/MV.png
-%%DATADIR%%/countryflags/MW.png
-%%DATADIR%%/countryflags/MX.png
-%%DATADIR%%/countryflags/MY.png
-%%DATADIR%%/countryflags/MZ.png
-%%DATADIR%%/countryflags/NA.png
-%%DATADIR%%/countryflags/NC.png
-%%DATADIR%%/countryflags/NE.png
-%%DATADIR%%/countryflags/NF.png
-%%DATADIR%%/countryflags/NG.png
-%%DATADIR%%/countryflags/NI.png
-%%DATADIR%%/countryflags/NL.png
-%%DATADIR%%/countryflags/NO.png
-%%DATADIR%%/countryflags/NP.png
-%%DATADIR%%/countryflags/NR.png
-%%DATADIR%%/countryflags/NU.png
-%%DATADIR%%/countryflags/NZ.png
-%%DATADIR%%/countryflags/OM.png
-%%DATADIR%%/countryflags/PA.png
-%%DATADIR%%/countryflags/PE.png
-%%DATADIR%%/countryflags/PF.png
-%%DATADIR%%/countryflags/PG.png
-%%DATADIR%%/countryflags/PH.png
-%%DATADIR%%/countryflags/PK.png
-%%DATADIR%%/countryflags/PL.png
-%%DATADIR%%/countryflags/PM.png
-%%DATADIR%%/countryflags/PN.png
-%%DATADIR%%/countryflags/PR.png
-%%DATADIR%%/countryflags/PT.png
-%%DATADIR%%/countryflags/PW.png
-%%DATADIR%%/countryflags/PY.png
-%%DATADIR%%/countryflags/QA.png
-%%DATADIR%%/countryflags/RE.png
-%%DATADIR%%/countryflags/RO.png
-%%DATADIR%%/countryflags/RS.png
-%%DATADIR%%/countryflags/RU.png
-%%DATADIR%%/countryflags/RW.png
-%%DATADIR%%/countryflags/SA.png
-%%DATADIR%%/countryflags/SB.png
-%%DATADIR%%/countryflags/SC.png
-%%DATADIR%%/countryflags/SD.png
-%%DATADIR%%/countryflags/SE.png
-%%DATADIR%%/countryflags/SG.png
-%%DATADIR%%/countryflags/SH.png
-%%DATADIR%%/countryflags/SI.png
-%%DATADIR%%/countryflags/SK.png
-%%DATADIR%%/countryflags/SL.png
-%%DATADIR%%/countryflags/SM.png
-%%DATADIR%%/countryflags/SN.png
-%%DATADIR%%/countryflags/SO.png
-%%DATADIR%%/countryflags/SR.png
-%%DATADIR%%/countryflags/SS.png
-%%DATADIR%%/countryflags/ST.png
-%%DATADIR%%/countryflags/SV.png
-%%DATADIR%%/countryflags/SX.png
-%%DATADIR%%/countryflags/SY.png
-%%DATADIR%%/countryflags/SZ.png
-%%DATADIR%%/countryflags/TC.png
-%%DATADIR%%/countryflags/TD.png
-%%DATADIR%%/countryflags/TF.png
-%%DATADIR%%/countryflags/TG.png
-%%DATADIR%%/countryflags/TH.png
-%%DATADIR%%/countryflags/TJ.png
-%%DATADIR%%/countryflags/TK.png
-%%DATADIR%%/countryflags/TL.png
-%%DATADIR%%/countryflags/TM.png
-%%DATADIR%%/countryflags/TN.png
-%%DATADIR%%/countryflags/TO.png
-%%DATADIR%%/countryflags/TR.png
-%%DATADIR%%/countryflags/TT.png
-%%DATADIR%%/countryflags/TV.png
-%%DATADIR%%/countryflags/TW.png
-%%DATADIR%%/countryflags/TZ.png
-%%DATADIR%%/countryflags/UA.png
-%%DATADIR%%/countryflags/UG.png
-%%DATADIR%%/countryflags/US.png
-%%DATADIR%%/countryflags/UY.png
-%%DATADIR%%/countryflags/UZ.png
-%%DATADIR%%/countryflags/VA.png
-%%DATADIR%%/countryflags/VC.png
-%%DATADIR%%/countryflags/VE.png
-%%DATADIR%%/countryflags/VG.png
-%%DATADIR%%/countryflags/VI.png
-%%DATADIR%%/countryflags/VN.png
-%%DATADIR%%/countryflags/VU.png
-%%DATADIR%%/countryflags/WF.png
-%%DATADIR%%/countryflags/WS.png
-%%DATADIR%%/countryflags/XEN.png
-%%DATADIR%%/countryflags/XNI.png
-%%DATADIR%%/countryflags/XSC.png
-%%DATADIR%%/countryflags/XWA.png
-%%DATADIR%%/countryflags/YE.png
-%%DATADIR%%/countryflags/ZA.png
-%%DATADIR%%/countryflags/ZM.png
-%%DATADIR%%/countryflags/ZW.png
-%%DATADIR%%/countryflags/default.png
-%%DATADIR%%/countryflags/index.txt
-%%DATADIR%%/debug_font.png
-%%DATADIR%%/demo_buttons.png
-%%DATADIR%%/editor/background.png
-%%DATADIR%%/editor/checker.png
-%%DATADIR%%/editor/cursor.png
-%%DATADIR%%/editor/desert_main.rules
-%%DATADIR%%/editor/entities.png
-%%DATADIR%%/editor/grass_main.rules
-%%DATADIR%%/editor/jungle_main.rules
-%%DATADIR%%/editor/winter_main.rules
-%%DATADIR%%/emoticons.png
-%%DATADIR%%/file_icons.png
-%%DATADIR%%/fonts/DejaVuSans.ttf
-%%DATADIR%%/fonts/LICENSE
-%%DATADIR%%/game.png
-%%DATADIR%%/gui_buttons.png
-%%DATADIR%%/gui_cursor.png
-%%DATADIR%%/gui_icons.png
-%%DATADIR%%/gui_logo.png
-%%DATADIR%%/languages/belarusian.txt
-%%DATADIR%%/languages/bosnian.txt
-%%DATADIR%%/languages/brazilian_portuguese.txt
-%%DATADIR%%/languages/bulgarian.txt
-%%DATADIR%%/languages/czech.txt
-%%DATADIR%%/languages/danish.txt
-%%DATADIR%%/languages/dutch.txt
-%%DATADIR%%/languages/finnish.txt
-%%DATADIR%%/languages/french.txt
-%%DATADIR%%/languages/german.txt
-%%DATADIR%%/languages/hungarian.txt
-%%DATADIR%%/languages/index.txt
-%%DATADIR%%/languages/italian.txt
-%%DATADIR%%/languages/norwegian.txt
-%%DATADIR%%/languages/polish.txt
-%%DATADIR%%/languages/portuguese.txt
-%%DATADIR%%/languages/romanian.txt
-%%DATADIR%%/languages/russian.txt
-%%DATADIR%%/languages/serbian.txt
-%%DATADIR%%/languages/slovak.txt
-%%DATADIR%%/languages/spanish.txt
-%%DATADIR%%/languages/swedish.txt
-%%DATADIR%%/languages/turkish.txt
-%%DATADIR%%/languages/ukrainian.txt
-%%DATADIR%%/mapres/bg_cloud1.png
-%%DATADIR%%/mapres/bg_cloud2.png
-%%DATADIR%%/mapres/bg_cloud3.png
-%%DATADIR%%/mapres/desert_doodads.png
-%%DATADIR%%/mapres/desert_main.png
-%%DATADIR%%/mapres/desert_mountains.png
-%%DATADIR%%/mapres/desert_mountains2.png
-%%DATADIR%%/mapres/desert_sun.png
-%%DATADIR%%/mapres/generic_deathtiles.png
-%%DATADIR%%/mapres/generic_unhookable.png
-%%DATADIR%%/mapres/grass_doodads.png
-%%DATADIR%%/mapres/grass_main.png
-%%DATADIR%%/mapres/jungle_background.png
-%%DATADIR%%/mapres/jungle_deathtiles.png
-%%DATADIR%%/mapres/jungle_doodads.png
-%%DATADIR%%/mapres/jungle_main.png
-%%DATADIR%%/mapres/jungle_midground.png
-%%DATADIR%%/mapres/jungle_unhookables.png
-%%DATADIR%%/mapres/moon.png
-%%DATADIR%%/mapres/mountains.png
-%%DATADIR%%/mapres/snow.png
-%%DATADIR%%/mapres/stars.png
-%%DATADIR%%/mapres/sun.png
-%%DATADIR%%/mapres/winter_doodads.png
-%%DATADIR%%/mapres/winter_main.png
-%%DATADIR%%/mapres/winter_mountains.png
-%%DATADIR%%/mapres/winter_mountains2.png
-%%DATADIR%%/mapres/winter_mountains3.png
-%%DATADIR%%/maps/ctf1.map
-%%DATADIR%%/maps/ctf2.map
-%%DATADIR%%/maps/ctf3.map
-%%DATADIR%%/maps/ctf4.map
-%%DATADIR%%/maps/ctf5.map
-%%DATADIR%%/maps/ctf6.map
-%%DATADIR%%/maps/ctf7.map
-%%DATADIR%%/maps/dm1.map
-%%DATADIR%%/maps/dm2.map
-%%DATADIR%%/maps/dm6.map
-%%DATADIR%%/maps/dm7.map
-%%DATADIR%%/maps/dm8.map
-%%DATADIR%%/maps/dm9.map
-%%DATADIR%%/particles.png
-%%DATADIR%%/skins/bluekitty.png
-%%DATADIR%%/skins/bluestripe.png
-%%DATADIR%%/skins/brownbear.png
-%%DATADIR%%/skins/cammo.png
-%%DATADIR%%/skins/cammostripes.png
-%%DATADIR%%/skins/coala.png
-%%DATADIR%%/skins/default.png
-%%DATADIR%%/skins/limekitty.png
-%%DATADIR%%/skins/pinky.png
-%%DATADIR%%/skins/redbopp.png
-%%DATADIR%%/skins/redstripe.png
-%%DATADIR%%/skins/saddo.png
-%%DATADIR%%/skins/toptri.png
-%%DATADIR%%/skins/twinbop.png
-%%DATADIR%%/skins/twintri.png
-%%DATADIR%%/skins/warpaint.png
-%%DATADIR%%/skins/x_ninja.png
-@dirrm %%DATADIR%%/skins
-@dirrm %%DATADIR%%/maps
-@dirrm %%DATADIR%%/mapres
-@dirrm %%DATADIR%%/languages
-@dirrm %%DATADIR%%/fonts
-@dirrm %%DATADIR%%/editor
-@dirrm %%DATADIR%%/countryflags
-@dirrm %%DATADIR%%/audio
-@dirrm %%DATADIR%%