aboutsummaryrefslogtreecommitdiff
path: root/games/teg/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-18 19:24:30 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-18 19:24:30 +0000
commit9a0f6dba4a0285069ec2e729dc3735fdd5289271 (patch)
tree89022657e350a8971ab9653f3ad8803930c674af /games/teg/Makefile
parent4cf0e0e736582ad2d84aadde47362087e9c6b63d (diff)
downloadports-9a0f6dba4a0285069ec2e729dc3735fdd5289271.tar.gz
ports-9a0f6dba4a0285069ec2e729dc3735fdd5289271.zip
Notes
Diffstat (limited to 'games/teg/Makefile')
-rw-r--r--games/teg/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/games/teg/Makefile b/games/teg/Makefile
index 2ffc7635a4d7..bd5e5b8e4d81 100644
--- a/games/teg/Makefile
+++ b/games/teg/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= teg
-PORTVERSION= 0.11.0
-PORTREVISION= 1
+PORTVERSION= 0.11.1
CATEGORIES= games gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,17 +14,15 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A turn-based strategy game for GNOME
-USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_REINPLACE= yes
+USE_GNOME= gnomehack gnomeprefix intlhack libgnomeui lthack
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack libgnomeui
USE_LIBTOOL= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LDFLAGS="-L${LOCALBASE}/lib -lintl ${PTHREAD_LIBS}"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
post-patch:
- @${FIND} ${WRKSRC} -name "*.[ch]" -type f | ${XARGS} \
- ${REINPLACE_CMD} -e 's|LIST_NEXT|TEG_LIST_NEXT|g'
+ @${GREP} -lR " LIST_NEXT" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's| LIST_NEXT| TEG_LIST_NEXT|g'
.include <bsd.port.mk>