aboutsummaryrefslogtreecommitdiff
path: root/games/tetrinet-x/Makefile
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>1999-05-01 02:19:08 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>1999-05-01 02:19:08 +0000
commitea5efaac8e7c4e0e4bd80673d044f791aba24d20 (patch)
tree94462557e1af5bd43cebc4420f9e5bd64ad09d44 /games/tetrinet-x/Makefile
parent059e7c47855eb0968e658aa367f389ad459e4b4d (diff)
downloadports-ea5efaac8e7c4e0e4bd80673d044f791aba24d20.tar.gz
ports-ea5efaac8e7c4e0e4bd80673d044f791aba24d20.zip
Notes
Diffstat (limited to 'games/tetrinet-x/Makefile')
-rw-r--r--games/tetrinet-x/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/games/tetrinet-x/Makefile b/games/tetrinet-x/Makefile
new file mode 100644
index 000000000000..ba73e535a5d4
--- /dev/null
+++ b/games/tetrinet-x/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: tetrinet-x-1.13.16
+# Version required: 1.13.16
+# Date created: 11 Apr 1999
+# Whom: gmarco@scotty.masternet.it
+#
+# $Id$
+#
+
+DISTNAME= tetrinet-x.1.13.16
+CATEGORIES= games
+MASTER_SITES= http://www.giovannelli.it/~gmarco/files/ \
+ ftp://ftp.dementia.nu/tetrinet/servers/tetrix/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= freebsd@scotty.masternet.it
+
+INSTALLDIR= ${PREFIX}/tetrinet-x
+
+do-build:
+ (cd ${WRKDIR}/tetrinetx-1.13.16/src && \
+ gcc -O2 -fno-strength-reduce -Wall main.c -o ../bin/tetrix.freebsd)
+ (cd ${WRKDIR}/tetrinetx-1.13.16/contrib/query/src && \
+ gcc -O2 -fno-strength-reduce -Wall query.c -o ../../../bin/server-query)
+
+do-install:
+ ${MKDIR} ${INSTALLDIR}
+ ${INSTALL_PROGRAM} ${WRKDIR}/tetrinetx-1.13.16/bin/tetrix.freebsd ${INSTALLDIR}
+ ${INSTALL_PROGRAM} ${WRKDIR}/tetrinetx-1.13.16/bin/server-query ${INSTALLDIR}
+ ${INSTALL_DATA} -m 644 ${WRKDIR}/tetrinetx-1.13.16/bin/game.conf ${INSTALLDIR}
+ ${INSTALL_DATA} -m 644 ${WRKDIR}/tetrinetx-1.13.16/bin/game.log ${INSTALLDIR}
+ ${INSTALL_DATA} -m 644 ${WRKDIR}/tetrinetx-1.13.16/bin/game.secure ${INSTALLDIR}
+ ${INSTALL_DATA} -m 644 ${WRKDIR}/tetrinetx-1.13.16/bin/game.winlist ${INSTALLDIR}
+
+post-install:
+ @${ECHO} ""
+ @${ECHO} "Installing ${PREFIX}/etc/rc.d/tetrinet-x.sh startup file."
+ @${INSTALL_SCRIPT} -m 751 ${FILESDIR}/tetrinet-x.sh ${PREFIX}/etc/rc.d
+ @${ECHO} ""
+ @${ECHO} "Please modify configuration files located in ${INSTALLDIR}"
+ @${ECHO} "before attempting to run Tetrinet server"
+ @${ECHO} ""
+ @${ECHO} ""
+
+.include <bsd.port.mk>