aboutsummaryrefslogtreecommitdiff
path: root/games/tetrinet-x
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-09-04 19:26:24 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-09-04 19:26:24 +0000
commit228ab588738952bd42427886fd5368181243ba6e (patch)
tree7fe589d0d1b0e6d00b7aa9cd05fc46ca15de7655 /games/tetrinet-x
parent7374b5a054d87d64914c6c36520e15fa14f3f31b (diff)
downloadports-228ab588738952bd42427886fd5368181243ba6e.tar.gz
ports-228ab588738952bd42427886fd5368181243ba6e.zip
Change INSTALL_DATA to install with mode 644
Remove patches and hacks that were used to work around the previous situation This allows to stage more ports as a regular user Differential Revision: https://reviews.freebsd.org/D703 Reviewed by and discussed with: bapt With hat: portmgr
Notes
Notes: svn path=/head/; revision=367307
Diffstat (limited to 'games/tetrinet-x')
-rw-r--r--games/tetrinet-x/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/games/tetrinet-x/Makefile b/games/tetrinet-x/Makefile
index 38b833890091..36b01e230626 100644
--- a/games/tetrinet-x/Makefile
+++ b/games/tetrinet-x/Makefile
@@ -27,10 +27,10 @@ do-install:
${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_PROGRAM} ${WRKSRC}/bin/tetrix.freebsd ${STAGEDIR}${DATADIR}
${INSTALL_PROGRAM} ${WRKSRC}/bin/server-query ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} -m 644 ${WRKSRC}/bin/game.conf ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} -m 644 ${WRKSRC}/bin/game.log ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} -m 644 ${WRKSRC}/bin/game.secure ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} -m 644 ${WRKSRC}/bin/game.winlist ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/bin/game.conf ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/bin/game.log ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/bin/game.secure ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/bin/game.winlist ${STAGEDIR}${DATADIR}
${INSTALL_SCRIPT} -m 751 ${WRKDIR}/tetrinetx ${STAGEDIR}${PREFIX}/etc/rc.d
.include <bsd.port.mk>