aboutsummaryrefslogtreecommitdiff
path: root/games/tetzle
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-18 23:26:50 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-18 23:26:50 +0000
commit9b5da4ef4f6b890ab1ca1a6615de177306f00111 (patch)
tree794a79b07200ae9bcbb3943de23ed0753f1bce08 /games/tetzle
parent9d915a19963f06ded87842d40a06cd5ee7c59c2c (diff)
downloadports-9b5da4ef4f6b890ab1ca1a6615de177306f00111.tar.gz
ports-9b5da4ef4f6b890ab1ca1a6615de177306f00111.zip
Notes
Diffstat (limited to 'games/tetzle')
-rw-r--r--games/tetzle/Makefile32
-rw-r--r--games/tetzle/distinfo3
-rw-r--r--games/tetzle/pkg-descr6
-rw-r--r--games/tetzle/pkg-plist8
4 files changed, 49 insertions, 0 deletions
diff --git a/games/tetzle/Makefile b/games/tetzle/Makefile
new file mode 100644
index 000000000000..8c8bcd30a858
--- /dev/null
+++ b/games/tetzle/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: tetzle
+# Date created: 12 Jun 2008
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tetzle
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= http://gottcode.org/tetzle/ \
+ http://www.amdmi3.ru/distfiles/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= Jigsaw puzzle with tetrominoes
+
+USE_BZIP2= yes
+USE_QT_VER= 4
+QT_COMPONENTS= corelib gui moc opengl qmake rcc xml
+INSTALLS_ICONS= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} \
+ PREFIX=${PREFIX} -spec ${QMAKESPEC} tetzle.pro
+
+post-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tetzle ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/games/tetzle/distinfo b/games/tetzle/distinfo
new file mode 100644
index 000000000000..4e3179192654
--- /dev/null
+++ b/games/tetzle/distinfo
@@ -0,0 +1,3 @@
+MD5 (tetzle-1.0-src.tar.bz2) = 5d0ef748657f450a4699c66dc92516c2
+SHA256 (tetzle-1.0-src.tar.bz2) = 63dc0899d317a93231e0a8ea5251b0b39c3dbe835b2b7b5358d9e5d8e4fd3307
+SIZE (tetzle-1.0-src.tar.bz2) = 97278
diff --git a/games/tetzle/pkg-descr b/games/tetzle/pkg-descr
new file mode 100644
index 000000000000..58c2ee547052
--- /dev/null
+++ b/games/tetzle/pkg-descr
@@ -0,0 +1,6 @@
+A jigsaw puzzle game that uses tetrominoes for the pieces. Any image
+can be imported and used to create puzzles with a wide range of
+sizes. Games are saved automatically, and you can select between
+currently in progress games.
+
+WWW: http://gottcode.org/tetzle/
diff --git a/games/tetzle/pkg-plist b/games/tetzle/pkg-plist
new file mode 100644
index 000000000000..b18019ec48d2
--- /dev/null
+++ b/games/tetzle/pkg-plist
@@ -0,0 +1,8 @@
+bin/tetzle
+share/applications/tetzle.desktop
+share/icons/hicolor/48x48/apps/tetzle.png
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry share/applications