aboutsummaryrefslogtreecommitdiff
path: root/games/tileworld
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-15 16:23:52 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-15 16:23:52 +0000
commite40b465fd30e8272e4472ec6ee2d3cafac3d7698 (patch)
treebf77baeb333833c87e15673e16ecb03acd8bab9a /games/tileworld
parent49915f4fbb25ec24a21264fc4d7c0729eaf9b07b (diff)
downloadports-e40b465fd30e8272e4472ec6ee2d3cafac3d7698.tar.gz
ports-e40b465fd30e8272e4472ec6ee2d3cafac3d7698.zip
Notes
Diffstat (limited to 'games/tileworld')
-rw-r--r--games/tileworld/Makefile3
-rw-r--r--games/tileworld/files/patch-Makefile.in35
-rw-r--r--games/tileworld/pkg-plist1
3 files changed, 36 insertions, 3 deletions
diff --git a/games/tileworld/Makefile b/games/tileworld/Makefile
index 9f659c4e3bc2..60c53dd3181b 100644
--- a/games/tileworld/Makefile
+++ b/games/tileworld/Makefile
@@ -17,9 +17,6 @@ USES= gmake
ALL_TARGET= tworld
DATADIR= share/tworld
-MAN6= tworld.6
-
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|make|$${MAKE}|g; s|cp -i|cp|' ${WRKSRC}/Makefile.in
diff --git a/games/tileworld/files/patch-Makefile.in b/games/tileworld/files/patch-Makefile.in
new file mode 100644
index 000000000000..00a47e9de6d9
--- /dev/null
+++ b/games/tileworld/files/patch-Makefile.in
@@ -0,0 +1,35 @@
+--- Makefile.in.orig 2014-06-16 00:21:51.143801006 +0800
++++ Makefile.in 2014-06-16 00:22:29.896816254 +0800
+@@ -92,19 +92,19 @@ tworldres.o: tworld.ico
+ #
+
+ install: tworld
+- mkdir -p $(bindir)
+- mkdir -p $(sharedir)/sets
+- mkdir -p $(sharedir)/data
+- mkdir -p $(sharedir)/res
+- mkdir -p $(mandir)/man6
+- cp -i ./tworld $(bindir)/.
+- cp -i sets/*.dac $(sharedir)/sets/.
+- cp -i data/*.dat $(sharedir)/data/.
+- cp -i res/rc $(sharedir)/res/.
+- cp -i res/*.bmp $(sharedir)/res/.
+- cp -i res/*.txt $(sharedir)/res/.
+- cp -i res/*.wav $(sharedir)/res/.
+- cp -i docs/tworld.6 $(mandir)/man6/.
++ mkdir -p $(DESTDIR)$(bindir)
++ mkdir -p $(DESTDIR)$(sharedir)/sets
++ mkdir -p $(DESTDIR)$(sharedir)/data
++ mkdir -p $(DESTDIR)$(sharedir)/res
++ mkdir -p $(DESTDIR)$(mandir)/man6
++ cp -i ./tworld $(DESTDIR)$(bindir)/.
++ cp -i sets/*.dac $(DESTDIR)$(sharedir)/sets/.
++ cp -i data/*.dat $(DESTDIR)$(sharedir)/data/.
++ cp -i res/rc $(DESTDIR)$(sharedir)/res/.
++ cp -i res/*.bmp $(DESTDIR)$(sharedir)/res/.
++ cp -i res/*.txt $(DESTDIR)$(sharedir)/res/.
++ cp -i res/*.wav $(DESTDIR)$(sharedir)/res/.
++ cp -i docs/tworld.6 $(DESTDIR)$(mandir)/man6/.
+
+ all: tworld mklynxcc
+
diff --git a/games/tileworld/pkg-plist b/games/tileworld/pkg-plist
index 9283819c2183..bf5b820a1150 100644
--- a/games/tileworld/pkg-plist
+++ b/games/tileworld/pkg-plist
@@ -1,4 +1,5 @@
bin/tworld
+man/man6/tworld.6.gz
%%DATADIR%%/data/intro.dat
%%DATADIR%%/res/atiles.bmp
%%DATADIR%%/res/block.wav