aboutsummaryrefslogtreecommitdiff
path: root/games/tomatoes/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2005-02-08 00:07:49 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2005-02-08 00:07:49 +0000
commit1437004df76e8d2646f174b6ad8a15f7106a1453 (patch)
treebe0bf3ce503f6b5eab790363f7ddf1c3383541d1 /games/tomatoes/Makefile
parentddfb449d820578e9262fd50b1aa2ee9f1305445e (diff)
downloadports-1437004df76e8d2646f174b6ad8a15f7106a1453.tar.gz
ports-1437004df76e8d2646f174b6ad8a15f7106a1453.zip
Notes
Diffstat (limited to 'games/tomatoes/Makefile')
-rw-r--r--games/tomatoes/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/games/tomatoes/Makefile b/games/tomatoes/Makefile
new file mode 100644
index 000000000000..3f298ec2367b
--- /dev/null
+++ b/games/tomatoes/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: tomatoes
+# Date created: 2005 07 Feb
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tomatoes
+PORTVERSION= 1.5
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTFILES= ${PORTNAME}-linux-src-${PORTVERSION}5${EXTRACT_SUFX} \
+ ${PORTNAME}-linux-${PORTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Tomato-smashing, Q-Bert style
+
+USE_BZIP2= yes
+WRKSRC= ${WRKDIR}/tomatoes-${PORTVERSION}5
+TDATA= ${WRKDIR}/tomatoes-${PORTVERSION}
+
+USE_X_PREFIX= yes
+MAKEFILE= makefile
+USE_GMAKE= yes
+USE_SDL= mixer image
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}/music
+ ${INSTALL_DATA} ${TDATA}/config.cfg ${DATADIR}
+ ${INSTALL_DATA} ${TDATA}/tomatoes.mpk ${DATADIR}
+
+.include <bsd.port.mk>