aboutsummaryrefslogtreecommitdiff
path: root/games/tomatoes/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2005-02-08 00:24:24 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2005-02-08 00:24:24 +0000
commite9e86b286f01bd1d98df3b77ce65557c0214b507 (patch)
treee13b3b15c33d7af7a6642636d0f6f7d82ded6f71 /games/tomatoes/Makefile
parent1437004df76e8d2646f174b6ad8a15f7106a1453 (diff)
downloadports-e9e86b286f01bd1d98df3b77ce65557c0214b507.tar.gz
ports-e9e86b286f01bd1d98df3b77ce65557c0214b507.zip
Notes
Diffstat (limited to 'games/tomatoes/Makefile')
-rw-r--r--games/tomatoes/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/games/tomatoes/Makefile b/games/tomatoes/Makefile
index 3f298ec2367b..9e02b9f9f132 100644
--- a/games/tomatoes/Makefile
+++ b/games/tomatoes/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tomatoes
PORTVERSION= 1.5
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,6 +17,8 @@ DISTFILES= ${PORTNAME}-linux-src-${PORTVERSION}5${EXTRACT_SUFX} \
MAINTAINER= ports@FreeBSD.org
COMMENT= Tomato-smashing, Q-Bert style
+LIB_DEPENDS= mikmod:${PORTSDIR}/audio/libmikmod
+
USE_BZIP2= yes
WRKSRC= ${WRKDIR}/tomatoes-${PORTVERSION}5
TDATA= ${WRKDIR}/tomatoes-${PORTVERSION}
@@ -23,12 +26,13 @@ TDATA= ${WRKDIR}/tomatoes-${PORTVERSION}
USE_X_PREFIX= yes
MAKEFILE= makefile
USE_GMAKE= yes
-USE_SDL= mixer image
+USE_SDL= mixer image sound
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
${MKDIR} ${DATADIR}/music
${INSTALL_DATA} ${TDATA}/config.cfg ${DATADIR}
${INSTALL_DATA} ${TDATA}/tomatoes.mpk ${DATADIR}
+ ${INSTALL_DATA} ${TDATA}/music/IHaveNoTomatoes.it ${DATADIR}/music
.include <bsd.port.mk>