aboutsummaryrefslogtreecommitdiff
path: root/games/tome/Makefile
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-01-17 02:25:52 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-01-17 02:25:52 +0000
commite3c8955dccbcd60c06187a72c3ae457c36431137 (patch)
treead3098f01c3cbf238baadba16b775823acb4b1c7 /games/tome/Makefile
parenteb7d93b03263232af8c911eba996dd4e1b464c0f (diff)
downloadports-e3c8955dccbcd60c06187a72c3ae457c36431137.tar.gz
ports-e3c8955dccbcd60c06187a72c3ae457c36431137.zip
Notes
Diffstat (limited to 'games/tome/Makefile')
-rw-r--r--games/tome/Makefile21
1 files changed, 17 insertions, 4 deletions
diff --git a/games/tome/Makefile b/games/tome/Makefile
index 38f53252791b..f354ebc0d021 100644
--- a/games/tome/Makefile
+++ b/games/tome/Makefile
@@ -6,18 +6,31 @@
#
PORTNAME= tome
-PORTVERSION= 2.0.0
+PORTVERSION= 2.1.1
CATEGORIES= games
MASTER_SITES= http://t-o-m-e.net/dl/src/
-DISTNAME= tome-200-src
+DISTNAME= tome-211-src
EXTRACT_SUFX= .tgz
MAINTAINER= kris@FreeBSD.org
ALL_TARGET= # empty
-MAKEFILE= makefile.org
+MAKEFILE= makefile.std
USE_GMAKE= yes
-USE_X_PREFIX= yes
+USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/src
+.if exists(${X11BASE}/lib/libX11.a) && !defined(WITHOUT_X11)
+USE_XLIB= yes
+.endif
+
+post-patch:
+.if !defined(USE_XLIB)
+ ${REINPLACE_CMD} -e 's/-DUSE_X11//g' ${WRKSRC}/${MAKEFILE}
+ ${REINPLACE_CMD} -e 's/-lX11//g' ${WRKSRC}/${MAKEFILE}
+ ${REINPLACE_CMD} -e 's@-L$$(X11BASE)/lib@@g' ${WRKSRC}/${MAKEFILE}
+ ${REINPLACE_CMD} -e 's@-I$$(X11BASE)/include@@g' ${WRKSRC}/${MAKEFILE}
+.endif
+
+
.include <bsd.port.mk>