aboutsummaryrefslogtreecommitdiff
path: root/games/torcs/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-01-05 20:36:33 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-01-05 20:36:33 +0000
commit41d8c3385c21ae51629c8997035eae8a9423ff6c (patch)
tree246d960cb714ce0095c452017819f6b1c64a7dfb /games/torcs/Makefile
parent5e3b0872db18497aacc353b3ef94ad8dac11183f (diff)
- Remove conditional checks for FreeBSD 5.x and older
Notes
Notes: svn path=/head/; revision=225297
Diffstat (limited to 'games/torcs/Makefile')
-rw-r--r--games/torcs/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/games/torcs/Makefile b/games/torcs/Makefile
index b8a0db575d12..2b6c86fe9573 100644
--- a/games/torcs/Makefile
+++ b/games/torcs/Makefile
@@ -26,6 +26,9 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
REINPLACE_ARGS= -i ""
CONFIGURE_ARGS= --x-includes=${LOCALBASE}/include --x-libraries=${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include -DHAVE_DECL_GETOPT" \
+ LIBS="${PTHREAD_LIBS}" LDFLAGS="${LDFLAGS}"
+
ALL_TARGET= default
INSTALL_TARGET= install datainstall
@@ -47,13 +50,6 @@ BASH2FIX= src/linux/torcs.in src/tools/accc/accc.in \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500041
-CPPFLAGS+= -I${LOCALBASE}/include
-.else
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include -DHAVE_DECL_GETOPT" \
- LIBS="${PTHREAD_LIBS}" LDFLAGS="${LDFLAGS}"
-.endif
-
.if defined(WITH_FREEGLUT)
LIB_DEPENDS+= glut.11:${PORTSDIR}/graphics/freeglut
.else