aboutsummaryrefslogtreecommitdiff
path: root/games/tornado
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-07-08 08:08:12 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-07-08 08:08:12 +0000
commit36af5fd0015e9e8cad390000c92b2501d13422b8 (patch)
treec29a8e1804483482c95137fc55b532e3ca3c5f72 /games/tornado
parentab23c9993d96b883239b7d531bf4c25625335e2c (diff)
downloadports-36af5fd0015e9e8cad390000c92b2501d13422b8.tar.gz
ports-36af5fd0015e9e8cad390000c92b2501d13422b8.zip
Notes
Diffstat (limited to 'games/tornado')
-rw-r--r--games/tornado/Makefile17
-rw-r--r--games/tornado/distinfo1
-rw-r--r--games/tornado/files/patch-aa41
-rw-r--r--games/tornado/files/patch-ab12
-rw-r--r--games/tornado/files/patch-ac12
-rw-r--r--games/tornado/pkg-comment1
-rw-r--r--games/tornado/pkg-descr9
-rw-r--r--games/tornado/pkg-plist2
8 files changed, 95 insertions, 0 deletions
diff --git a/games/tornado/Makefile b/games/tornado/Makefile
new file mode 100644
index 000000000000..f7737084d13b
--- /dev/null
+++ b/games/tornado/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: tornado
+# Date created: 1 July 2001
+# Whom: minter
+#
+# $FreeBSD$
+#
+
+PORTNAME= tornado
+PORTVERSION= 1.0.3
+CATEGORIES= games
+MASTER_SITES= http://www.lionking.org/~kiza/linux/tornado/
+
+MAINTAINER= minter@lunenburg.org
+
+MAN6= tornado.6
+
+.include <bsd.port.mk>
diff --git a/games/tornado/distinfo b/games/tornado/distinfo
new file mode 100644
index 000000000000..f59f62e1b5d8
--- /dev/null
+++ b/games/tornado/distinfo
@@ -0,0 +1 @@
+MD5 (tornado-1.0.3.tar.gz) = 72e302d87b54b2870ade48968842049a
diff --git a/games/tornado/files/patch-aa b/games/tornado/files/patch-aa
new file mode 100644
index 000000000000..105d584fb3e2
--- /dev/null
+++ b/games/tornado/files/patch-aa
@@ -0,0 +1,41 @@
+diff -ur ../tornado-1.0.3.orig/Makefile ./Makefile
+--- ../tornado-1.0.3.orig/Makefile Fri Dec 1 09:00:11 2000
++++ ./Makefile Sun Jul 1 17:29:21 2001
+@@ -30,26 +30,26 @@
+ if [ ! -d "$(PREFIX)/bin" ]; then \
+ mkdir -p $(PREFIX)/bin; \
+ fi
+- install -s tornado $(PREFIX)/bin
++ install -c -s tornado $(PREFIX)/bin
+ if [ ! -d "$(PREFIX)/man/man6" ]; then \
+ mkdir -p $(PREFIX)/man/man6; \
+ fi
+- install -m 0644 tornado.6 $(PREFIX)/man/man6
++ install -c -m 0644 tornado.6 $(PREFIX)/man/man6
+
+- if [ -f "/var/games/tornado.scores" ]; then \
++ if [ -f "${PREFIX}/share/games/tornado.scores" ]; then \
+ echo "Skipping install of the highscores file. File exists."; \
+- cat /var/games/tornado.scores | ./convert-highscorefile > score.tmp; \
+- mv -f score.tmp /var/games/tornado.scores; \
+- chmod a+rw-x "/var/games/tornado.scores"; \
++ cat ${PREFIX}/share/games/tornado.scores | ./convert-highscorefile > score.tmp; \
++ mv -f score.tmp ${PREFIX}/share/games/tornado.scores; \
++ chmod a+rw-x "${PREFIX}/share/games/tornado.scores"; \
+ else \
+- if [ ! -d "/var/games" ]; then \
+- mkdir /var/games; \
++ if [ ! -d "${PREFIX}/share/games" ]; then \
++ mkdir -p ${PREFIX}/share/games; \
+ fi; \
+- install tornado.scores /var/games; \
+- chmod a+w-x "/var/games/tornado.scores"; \
++ install -c tornado.scores ${PREFIX}/share/games; \
++ chmod a+w-x "${PREFIX}/share/games/tornado.scores"; \
+ fi
+
+ uninstall:
+ rm -f $(PREFIX)/bin/tornado
+ rm -f $(PREFIX)/man/man6/tornado.6
+- rm -f /var/games/tornado.scores
++ rm -f ${PREFIX}/share/games/tornado.scores
diff --git a/games/tornado/files/patch-ab b/games/tornado/files/patch-ab
new file mode 100644
index 000000000000..fda965d44fe2
--- /dev/null
+++ b/games/tornado/files/patch-ab
@@ -0,0 +1,12 @@
+diff -ur ../tornado-1.0.3.orig/scores.h ./scores.h
+--- ../tornado-1.0.3.orig/scores.h Fri Dec 1 08:59:55 2000
++++ ./scores.h Sun Jul 1 16:35:36 2001
+@@ -1,7 +1,7 @@
+ /* scores.h -- highscore functions */
+
+ /* score file name */
+-#define SCOREFILE_NAME "/var/games/tornado.scores"
++#define SCOREFILE_NAME "/usr/local/share/games/tornado.scores"
+
+ /* maximum length for a player name (includes \0) */
+ #define MAX_PLAYER_LEN 22
diff --git a/games/tornado/files/patch-ac b/games/tornado/files/patch-ac
new file mode 100644
index 000000000000..757e4c8f09ae
--- /dev/null
+++ b/games/tornado/files/patch-ac
@@ -0,0 +1,12 @@
+diff -ur ../tornado-1.0.3.orig/tornado.6.in ./tornado.6.in
+--- ../tornado-1.0.3.orig/tornado.6.in Fri Dec 1 08:59:55 2000
++++ ./tornado.6.in Sun Jul 1 16:35:53 2001
+@@ -90,7 +90,7 @@
+ .P
+ PREFIX/man/man6/tornado.6
+ .P
+-/var/games/tornado.scores
++/usr/local/share/games/tornado.scores
+ .SH NOTES
+ When you run the game in network mode you should have the same game versions
+ on client and server side. Versions prior 1.0pre4 won't work at all due to
diff --git a/games/tornado/pkg-comment b/games/tornado/pkg-comment
new file mode 100644
index 000000000000..d9a14f44cd70
--- /dev/null
+++ b/games/tornado/pkg-comment
@@ -0,0 +1 @@
+A curses-based game of weather destruction
diff --git a/games/tornado/pkg-descr b/games/tornado/pkg-descr
new file mode 100644
index 000000000000..3f7168b9cfb3
--- /dev/null
+++ b/games/tornado/pkg-descr
@@ -0,0 +1,9 @@
+A clone of an old C64 game. The object is to destroy your opponent's
+house with the power of weather, before they do the same to you. Play
+against the computer AI, or against another player locally or over the
+network.
+
+WWW: http://www.lionking.org/~kiza/linux/tornado/
+
+--Wade
+minter@lunenburg.org
diff --git a/games/tornado/pkg-plist b/games/tornado/pkg-plist
new file mode 100644
index 000000000000..128fa9d0e814
--- /dev/null
+++ b/games/tornado/pkg-plist
@@ -0,0 +1,2 @@
+bin/tornado
+share/games/tornado.scores