aboutsummaryrefslogtreecommitdiff
path: root/games/trackballs/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-11-05 19:23:35 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-11-05 19:23:35 +0000
commit72d9a247cfad9c5ae8a055b31cdf78c381265a29 (patch)
tree36317116f4e7f5c6a72c5fc694df9d0e9a47229a /games/trackballs/Makefile
parent6fde77975bf50feb8f325eea9216f9a2a905e508 (diff)
Notes
Diffstat (limited to 'games/trackballs/Makefile')
-rw-r--r--games/trackballs/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/games/trackballs/Makefile b/games/trackballs/Makefile
index 176c5ed618fe..47620fd43478 100644
--- a/games/trackballs/Makefile
+++ b/games/trackballs/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= trackballs
-PORTVERSION= 0.9.2
-PORTREVISION= 3
+PORTVERSION= 1.0.0
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,25 +15,25 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= SDL-based Marble Madness clone
LIB_DEPENDS= guile.15:${PORTSDIR}/lang/guile
-RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
USE_X_PREFIX= yes
-USE_GETOPT_LONG=yes
-USE_SDL= mixer image ttf sdl
-GNU_CONFIGURE= yes
+USE_SDL= image mixer sdl ttf
+USE_GETOPT_LONG= yes
USE_REINPLACE= yes
-USE_GNOME= gnometarget
USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+MAN6= ${PORTNAME}.6
+
CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include
LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib
-MAN6= ${PORTNAME}.6
-
post-patch:
@${FIND} ${WRKSRC} -name '*.h' -o -name '*.cc' | ${XARGS} \
- ${REINPLACE_CMD} -e "/^#include/s|SDL/SDL|SDL11/SDL|; \
+ ${REINPLACE_CMD} -e "/^#include/s|SDL/SDL|SDL|; \
/stdint.h/d"
@${REINPLACE_CMD} -e "s|/bin/bash|${LOCALBASE}/bin/bash|" \
${WRKSRC}/share/icons/installIcons