aboutsummaryrefslogtreecommitdiff
path: root/games/traindirector/Makefile
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-09-23 02:27:18 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-09-23 02:27:18 +0000
commitc910f2685859d8f550fca6dadeadc4712c65b1fc (patch)
treee9697896072b76680b2de53b7d75a99996cbb91b /games/traindirector/Makefile
parent16200506b5bf90a253271c8fb1fe6ed98c9d65ab (diff)
downloadports-c910f2685859d8f550fca6dadeadc4712c65b1fc.tar.gz
ports-c910f2685859d8f550fca6dadeadc4712c65b1fc.zip
Notes
Diffstat (limited to 'games/traindirector/Makefile')
-rw-r--r--games/traindirector/Makefile32
1 files changed, 18 insertions, 14 deletions
diff --git a/games/traindirector/Makefile b/games/traindirector/Makefile
index 86c903d9bc9f..07d1736a8a0e 100644
--- a/games/traindirector/Makefile
+++ b/games/traindirector/Makefile
@@ -6,28 +6,32 @@
#
PORTNAME= traindirector
-PORTVERSION= 1.19c
-PORTREVISION= 4
+PORTVERSION= 3.5
CATEGORIES= games
-MASTER_SITES= http://xtsl.free.fr/119c/
-DISTNAME= traindir-${PORTVERSION}-src
+MASTER_SITES= http://www.backerstreet.com/traindir/
+DISTNAME= tdir35src
MAINTAINER= mad@madpilot.net
COMMENT= Train controller simulation
-WRKSRC= ${WRKDIR}/traindir-${PORTVERSION}
+NO_WRKSUBDIR= yes
USE_GMAKE= yes
-USE_GNOME= gtk12
-USE_BZIP2= yes
+USE_GNOME= gtk20
+USE_ZIP= yes
-post-extract:
-.for file in Makefile field.c loadsave.c run.c setup_trdir.sh tgraph.c track.c track1.c trsim.c
- @${TR} -d '\015' < ${WRKSRC}/${file} > ${WRKDIR}/xxxx
- @${MV} ${WRKDIR}/xxxx ${WRKSRC}/${file}
-.endfor
+USE_WX= 2.8
+WX_COMPS= wx
+WX_UNICODE= yes
-post-patch:
- ${REINPLACE_CMD} -e 's#PREFIX#${PREFIX}#' ${WRKSRC}/setup_trdir.sh
+DESKTOP_ENTRIES="Train Director" "${COMMENT}" "" "traindir3" \
+ "Game;Simulation;StrategyGame;" false
+
+PLIST_FILES= bin/traindir3
+
+MAKEFILE= Makefile.fc9
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKDIR}/traindir3 ${PREFIX}/bin
.include <bsd.port.mk>