aboutsummaryrefslogtreecommitdiff
path: root/games/traindirector
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-09 23:48:28 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-09 23:48:28 +0000
commit132aab81228c918cb24e62bfc2cc10176e001606 (patch)
tree1921d9149c918e18808c0add3a23a03317ad637a /games/traindirector
parentfc5cb38672775d6ad5dcefce8c06e77d0f5a5456 (diff)
downloadports-132aab81228c918cb24e62bfc2cc10176e001606.tar.gz
ports-132aab81228c918cb24e62bfc2cc10176e001606.zip
Notes
Diffstat (limited to 'games/traindirector')
-rw-r--r--games/traindirector/Makefile6
-rw-r--r--games/traindirector/distinfo2
-rw-r--r--games/traindirector/files/patch-Makefile27
-rw-r--r--games/traindirector/files/patch-run.c18
4 files changed, 31 insertions, 22 deletions
diff --git a/games/traindirector/Makefile b/games/traindirector/Makefile
index 279bf87ab7a2..4015b861b5b0 100644
--- a/games/traindirector/Makefile
+++ b/games/traindirector/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= tdir
-PORTVERSION= 1.18e
+PORTVERSION= 1.18i
CATEGORIES= games
-MASTER_SITES= http://xtsl.free.fr/118e/
+MASTER_SITES= http://xtsl.free.fr/118i/
DISTNAME= traindir-${PORTVERSION}-src
WRKSRC= ${WRKDIR}/traindir-${PORTVERSION}
@@ -28,7 +28,7 @@ post-extract:
.endfor
post-patch:
- ${REINPLACE_CMD} -e 's#PREFIX#$(PREFIX)#' $(WRKSRC)/setup_trdir.sh
+ ${REINPLACE_CMD} -e 's#PREFIX#${PREFIX}#' ${WRKSRC}/setup_trdir.sh
post-configure:
${REINPLACE_CMD} -e 's,\#include \<malloc.h\>,/* include malloc.h */,' \
diff --git a/games/traindirector/distinfo b/games/traindirector/distinfo
index 3912b0381856..414bade43102 100644
--- a/games/traindirector/distinfo
+++ b/games/traindirector/distinfo
@@ -1 +1 @@
-MD5 (traindir-1.18e-src.tar.gz) = df82dee6e32ea9951916d900984e0cc6
+MD5 (traindir-1.18i-src.tar.gz) = c3f65b2a72a1e94d738f390685c18236
diff --git a/games/traindirector/files/patch-Makefile b/games/traindirector/files/patch-Makefile
index 5d656944eaa8..ffda58f655ac 100644
--- a/games/traindirector/files/patch-Makefile
+++ b/games/traindirector/files/patch-Makefile
@@ -1,8 +1,8 @@
---- Makefile.orig Tue Mar 25 20:50:38 2003
-+++ Makefile Mon Sep 8 12:31:58 2003
-@@ -4,8 +4,8 @@
+--- Makefile.orig Tue Dec 9 21:59:18 2003
++++ Makefile Tue Dec 9 22:00:42 2003
+@@ -4,21 +4,21 @@
#
- VERSION=1.18e
+ VERSION=1.18i
-BINDIR=/usr/local/bin
-SAMPLEDIR=/usr/local/share
@@ -11,15 +11,22 @@
SHELL = /bin/sh
INSTALL = install
-@@ -16,9 +16,9 @@
- GLIBINC=`glib-config --cflags`
- GLIBLIB=`glib-config --libs`
--CFLAGS = -g ${GLIBINC} ${GTKINC} -Dunix
-+CFLAGS += -g ${GLIBINC} ${GTKINC} -Dunix
+
+-GTKINC=`gtk-config --cflags`
+-GTKLIB=`gtk-config --libs`
+-GLIBINC=`glib-config --cflags`
+-GLIBLIB=`glib-config --libs`
++GTKINC=`gtk12-config --cflags`
++GTKLIB=`gtk12-config --libs`
++GLIBINC=`glib12-config --cflags`
++GLIBLIB=`glib12-config --libs`
+
+-CFLAGS = -g $(GLIBINC) $(GTKINC) -Dunix #-static
++CFLAGS += -g $(GLIBINC) $(GTKINC) -Dunix #-static
-CC = cc
+CC ?= cc
- LIBS = ${GLIBLIB} ${GTKLIB}
+ LIBS = $(GLIBLIB) $(GTKLIB)
diff --git a/games/traindirector/files/patch-run.c b/games/traindirector/files/patch-run.c
index b95d6fdaef17..50b16b104f5f 100644
--- a/games/traindirector/files/patch-run.c
+++ b/games/traindirector/files/patch-run.c
@@ -1,21 +1,23 @@
---- run.c.orig Fri Jul 18 15:53:36 2003
-+++ run.c Fri Jul 18 15:56:59 2003
-@@ -20,9 +20,13 @@
+--- run.c.orig Tue Dec 9 22:02:20 2003
++++ run.c Tue Dec 9 22:04:51 2003
+@@ -20,11 +20,15 @@
#include <stdio.h>
#include <string.h>
-#include <malloc.h>
+#include <stdlib.h>
+ #include <math.h>
#include "ask.h"
#include "trsim.h"
-+
+
+#if (defined(__unix__) || defined(unix)) && !defined(USG)
+#include <sys/param.h>
+#endif
++
+ #define HOMAN_030330
+ #define MERGE_TRAINS 1
- int assign_ok = 1;
-
-@@ -56,7 +60,11 @@
+@@ -60,7 +64,11 @@
{
if(i >= v->size) {
printf("Bad index %d: only %d elements in vector!\n", i, v->size);
@@ -27,7 +29,7 @@
}
return v->ptr[i];
}
-@@ -65,7 +73,11 @@
+@@ -69,7 +77,11 @@
{
if(i >= v->size) {
printf("Bad index %d: only %d elements in vector!\n", i, v->size);