aboutsummaryrefslogtreecommitdiff
path: root/games/trigger-rally
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2015-02-27 14:49:23 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2015-02-27 14:49:23 +0000
commit9031079c2daa8a7fa2d5038db324bc17d7acd595 (patch)
treec74b4e5a8764b146c778be8c6f9adfa9475bd12c /games/trigger-rally
parentc308de0164ec299c9914722e02f9e6176f6c5b89 (diff)
Notes
Diffstat (limited to 'games/trigger-rally')
-rw-r--r--games/trigger-rally/Makefile42
-rw-r--r--games/trigger-rally/distinfo2
-rw-r--r--games/trigger-rally/pkg-descr7
3 files changed, 51 insertions, 0 deletions
diff --git a/games/trigger-rally/Makefile b/games/trigger-rally/Makefile
new file mode 100644
index 000000000000..49e2edeaeee9
--- /dev/null
+++ b/games/trigger-rally/Makefile
@@ -0,0 +1,42 @@
+# Created by: Jean-Yves Lefort <jylefort@brutele.be>
+# $FreeBSD$
+
+PORTNAME= trigger-rally
+PORTVERSION= 0.6.0
+PORTREVISION= 4
+CATEGORIES= games
+MASTER_SITES= SF/trigger-rally/trigger-rally/trigger-${PORTVERSION}
+DISTVERSIONSUFFIX= -src
+
+MAINTAINER= makc@FreeBSD.org
+COMMENT= Rally car racing game
+
+BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam
+LIB_DEPENDS= libphysfs.so:${PORTSDIR}/devel/physfs
+RUN_DEPENDS= ${DATADIR}/trigger.config.defs:${PORTSDIR}/games/trigger-data
+
+USES= openal:al,alut tar:bzip2
+USE_SDL= sdl image
+USE_GL= glu
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --datadir=${DATADIR} \
+ --with-libAlut=${LOCALBASE} \
+ --with-libPhysFS=${LOCALBASE}
+
+DESKTOP_ENTRIES="Trigger" "" "" \
+ "trigger" "" false
+
+PLIST_FILES= bin/trigger
+PORTDOCS= README-stereo.txt README.txt
+
+OPTIONS_DEFINE= DOCS
+
+do-build:
+ @cd ${BUILD_WRKSRC} && ${LOCALBASE}/bin/jam
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/trigger ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/doc && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/games/trigger-rally/distinfo b/games/trigger-rally/distinfo
new file mode 100644
index 000000000000..40d261c58c86
--- /dev/null
+++ b/games/trigger-rally/distinfo
@@ -0,0 +1,2 @@
+SHA256 (trigger-rally-0.6.0-src.tar.bz2) = dc818f359fff71a8ba5e147886f233cca6478e5b007ef0a38a2974cca855a662
+SIZE (trigger-rally-0.6.0-src.tar.bz2) = 333977
diff --git a/games/trigger-rally/pkg-descr b/games/trigger-rally/pkg-descr
new file mode 100644
index 000000000000..d1526b283ce1
--- /dev/null
+++ b/games/trigger-rally/pkg-descr
@@ -0,0 +1,7 @@
+Trigger is a free rally car racing game. Fun for all the family! You
+race a sequence of 6 courses, with increasing levels of difficulty.
+
+Trigger is highly customisable, and it's easy to add new levels and
+vehicles.
+
+WWW: http://trigger-rally.sourceforge.net