aboutsummaryrefslogtreecommitdiff
path: root/games/trigger/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-12-30 19:24:03 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-12-30 19:24:03 +0000
commit8b0eb137e4e14eaa79da6c1f221cfe3df9f2827a (patch)
tree4cf7528a2fe5dabc4935603624885b596f03efd5 /games/trigger/Makefile
parente153e0cb61431960284078eaf79b1e5e3ccd6822 (diff)
Notes
Diffstat (limited to 'games/trigger/Makefile')
-rw-r--r--games/trigger/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/games/trigger/Makefile b/games/trigger/Makefile
index 46f698cb2071..0e2faccf8ff2 100644
--- a/games/trigger/Makefile
+++ b/games/trigger/Makefile
@@ -6,14 +6,14 @@
#
PORTNAME= trigger
-PORTVERSION= 0.5.1c
-PORTREVISION= 3
+PORTVERSION= 0.5.2.1
CATEGORIES= games
-MASTER_SITES= http://0day.icculus.org/mirrors/trigger/
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR=${PORTNAME}-rally
DISTFILES= trigger-${PORTVERSION}-src${EXTRACT_SUFX} \
- trigger-${PORTVERSION}-data${EXTRACT_SUFX}
+ trigger-${DATAVERSION}-data${EXTRACT_SUFX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= makc@issp.ac.ru
COMMENT= A rally car racing game
BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam
@@ -21,10 +21,7 @@ LIB_DEPENDS= openal:${PORTSDIR}/audio/openal \
physfs:${PORTSDIR}/devel/physfs \
alut.1:${PORTSDIR}/audio/freealut
-DEPRECATED= distfile and homepage disappeared
-EXPIRATION_DATE= 2007-01-17
-
-USE_X_PREFIX= yes
+USE_XLIB= yes
USE_SDL= sdl image
USE_GL= yes
USE_BZIP2= yes
@@ -33,9 +30,13 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
WRKSRC= ${WRKDIR}/trigger-${PORTVERSION}-src
-DATASRC= ${WRKDIR}/trigger-${PORTVERSION}-data
+DATASRC= ${WRKDIR}/trigger-${DATAVERSION}-data
+
+DESKTOP_ENTRIES="Trigger" "Car racing game" "" \
+ "trigger" "" false
.include <bsd.port.pre.mk>
+DATAVERSION= 0.5.2
.if ${OSVERSION} < 500000
USE_GCC= 3.4