aboutsummaryrefslogtreecommitdiff
path: root/games/trimines
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-05-07 23:17:01 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-05-07 23:17:01 +0000
commit032c438046dc927f478a7bb1f93ef1dcadfe5b81 (patch)
tree2843ee8478b54cf4cfc4e440e22dfbb59809d60e /games/trimines
parent263dcbf4cab2a210fab69161273d479c58b8f96e (diff)
downloadports-032c438046dc927f478a7bb1f93ef1dcadfe5b81.tar.gz
ports-032c438046dc927f478a7bb1f93ef1dcadfe5b81.zip
Notes
Diffstat (limited to 'games/trimines')
-rw-r--r--games/trimines/Makefile31
-rw-r--r--games/trimines/distinfo3
-rw-r--r--games/trimines/pkg-descr3
-rw-r--r--games/trimines/pkg-plist63
4 files changed, 100 insertions, 0 deletions
diff --git a/games/trimines/Makefile b/games/trimines/Makefile
new file mode 100644
index 000000000000..88359926f7bb
--- /dev/null
+++ b/games/trimines/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: trimines
+# Date created: 02 May 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= trimines
+PORTVERSION= 1.2.1
+CATEGORIES= games
+MASTER_SITES= http://www.freewebs.com/trimines/
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= Mine sweeper game that uses triangles instead of squares
+
+USE_SDL= sdl
+USE_GCC= 3.4+
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|data/|${DATADIR}/|' ${WRKSRC}/src/gfx.c
+
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} src/main.c -o ./trimines \
+ `${SDL_CONFIG} --cflags --libs`
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/trimines ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/data/* ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/games/trimines/distinfo b/games/trimines/distinfo
new file mode 100644
index 000000000000..0040a8e5083f
--- /dev/null
+++ b/games/trimines/distinfo
@@ -0,0 +1,3 @@
+MD5 (trimines-1.2.1.tar.gz) = db0fd9b06789fa202d22475170602f83
+SHA256 (trimines-1.2.1.tar.gz) = f140fcea9fc9579e4f2650ca136de5083305cd7a18d8456f47949e2a23001483
+SIZE (trimines-1.2.1.tar.gz) = 83707
diff --git a/games/trimines/pkg-descr b/games/trimines/pkg-descr
new file mode 100644
index 000000000000..b32c130ac3d5
--- /dev/null
+++ b/games/trimines/pkg-descr
@@ -0,0 +1,3 @@
+TriMines is a mine sweeper game that uses triangles instead of squares.
+
+WWW: http://www.freewebs.com/trimines/
diff --git a/games/trimines/pkg-plist b/games/trimines/pkg-plist
new file mode 100644
index 000000000000..19922c3b86d6
--- /dev/null
+++ b/games/trimines/pkg-plist
@@ -0,0 +1,63 @@
+bin/trimines
+%%DATADIR%%/1.bmp
+%%DATADIR%%/10.bmp
+%%DATADIR%%/10_2.bmp
+%%DATADIR%%/11.bmp
+%%DATADIR%%/11_2.bmp
+%%DATADIR%%/12.bmp
+%%DATADIR%%/12_2.bmp
+%%DATADIR%%/1_2.bmp
+%%DATADIR%%/2.bmp
+%%DATADIR%%/2_2.bmp
+%%DATADIR%%/3.bmp
+%%DATADIR%%/3_2.bmp
+%%DATADIR%%/4.bmp
+%%DATADIR%%/4_2.bmp
+%%DATADIR%%/5.bmp
+%%DATADIR%%/5_2.bmp
+%%DATADIR%%/6.bmp
+%%DATADIR%%/6_2.bmp
+%%DATADIR%%/7.bmp
+%%DATADIR%%/7_2.bmp
+%%DATADIR%%/8.bmp
+%%DATADIR%%/8_2.bmp
+%%DATADIR%%/9.bmp
+%%DATADIR%%/9_2.bmp
+%%DATADIR%%/bar.bmp
+%%DATADIR%%/bar2.bmp
+%%DATADIR%%/button.bmp
+%%DATADIR%%/button2.bmp
+%%DATADIR%%/clicked.bmp
+%%DATADIR%%/clicked2.bmp
+%%DATADIR%%/counter_0.bmp
+%%DATADIR%%/counter_1.bmp
+%%DATADIR%%/counter_2.bmp
+%%DATADIR%%/counter_3.bmp
+%%DATADIR%%/counter_4.bmp
+%%DATADIR%%/counter_5.bmp
+%%DATADIR%%/counter_6.bmp
+%%DATADIR%%/counter_7.bmp
+%%DATADIR%%/counter_8.bmp
+%%DATADIR%%/counter_9.bmp
+%%DATADIR%%/counter_clear.bmp
+%%DATADIR%%/counter_m.bmp
+%%DATADIR%%/false.bmp
+%%DATADIR%%/false2.bmp
+%%DATADIR%%/flag.bmp
+%%DATADIR%%/flag2.bmp
+%%DATADIR%%/menu.bmp
+%%DATADIR%%/menu_select.bmp
+%%DATADIR%%/menu_select_clear.bmp
+%%DATADIR%%/mine.bmp
+%%DATADIR%%/mine2.bmp
+%%DATADIR%%/pointer.bmp
+%%DATADIR%%/pointer2.bmp
+%%DATADIR%%/question.bmp
+%%DATADIR%%/question2.bmp
+%%DATADIR%%/redmine.bmp
+%%DATADIR%%/redmine2.bmp
+%%DATADIR%%/smile.bmp
+%%DATADIR%%/smile2.bmp
+%%DATADIR%%/smile3.bmp
+%%DATADIR%%/smile4.bmp
+@dirrm %%DATADIR%%