aboutsummaryrefslogtreecommitdiff
path: root/games/trophy/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-09-09 23:31:03 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-09-09 23:31:03 +0000
commitd8986754ee959151f65bddb2bb499fe93ac14d8d (patch)
tree6bbbff8362d303935ad2655e46fea0b19537a673 /games/trophy/Makefile
parentf57317e7400da1f652171311a436cd808c36af3d (diff)
[Update] devel/clanlib Update to 0.8.0
Update to 0.8.0 Take maintainership Update games/trophy update trophy to 1.1.4 and pass maintainership to me. Ignore games/clanbomber Set ignore on games/clanbomber, it will compile but not run. PR: ports/115139, ports/115141, ports/115142 Submitted by: Martin Tournoij <carpetsmoker@xs4all.nl>
Notes
Notes: svn path=/head/; revision=199223
Diffstat (limited to 'games/trophy/Makefile')
-rw-r--r--games/trophy/Makefile45
1 files changed, 25 insertions, 20 deletions
diff --git a/games/trophy/Makefile b/games/trophy/Makefile
index 4592234797f7..92927eb6501d 100644
--- a/games/trophy/Makefile
+++ b/games/trophy/Makefile
@@ -2,46 +2,51 @@
# Date created: 22 Jan 2004
# Whom: Jean-Yves Lefort <jylefort@brutele.be>
#
+# $Carpetsmoker: ports/games/trophy/Makefile,v 1.3 2007/08/04 03:36:57 carpetsmoker Exp $
# $FreeBSD$
#
-PORTNAME= trophy
-PORTVERSION= 1.1.3
-PORTREVISION= 2
-CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+PORTNAME= trophy
+PORTVERSION= 1.1.4
+CATEGORIES= games
+#MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+#MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= http://trophy.sourceforge.net/archives/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A single player racing game
+MAINTAINER= carpetsmoker@xs4all.nl
+COMMENT= A single player racing game
-LIB_DEPENDS= clanCore.2:${PORTSDIR}/devel/clanlib
+LIB_DEPENDS= clanCore-0.8:${PORTSDIR}/devel/clanlib
-USE_X_PREFIX= yes
-USE_GMAKE= yes
-BUILD_WRKSRC= ${WRKSRC}/trophy
+USE_GMAKE= yes
+MAKEFILE= Makefile.in
+BUILD_WRKSRC= ${WRKSRC}/trophy
+CXXFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-MAKE_ENV= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
- PTHREAD_LIBS=${PTHREAD_LIBS}
-
-post-extract:
- @${FIND} ${BUILD_WRKSRC}/resources -name .cvsignore -exec ${RM} -f {} \;
+post-patch:
@${REINPLACE_CMD} -e 's/std::sqrt/sqrt/' ${BUILD_WRKSRC}/caimagemanipulation.cpp \
${BUILD_WRKSRC}/catrophy.cpp ${BUILD_WRKSRC}/camath.cpp
+ @${REINPLACE_CMD} -e 's|resources.xml|${DATADIR}/resources.xml|' \
+ ${BUILD_WRKSRC}/caresources.cpp
+ @${REINPLACE_CMD} -e 's|@prefix@|${PREFIX}|; \
+ s|@exec_prefix@|$${PREFIX}/bin|; \
+ s|@datadir@|${DATADIR}|; \
+ s|@bindir@|$${PREFIX}/bin|; \
+ s|EXTERN_LIBS =|EXTERN_LIBS = ${PTHREAD_LIBS}|;' \
+ ${BUILD_WRKSRC}/Makefile.in
do-install:
${MKDIR} ${PREFIX}/bin
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/trophy ${PREFIX}/bin
${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${BUILD_WRKSRC}/resources.scr ${DATADIR}
+ ${INSTALL_DATA} ${BUILD_WRKSRC}/resources.xml ${DATADIR}
${CP} -R ${BUILD_WRKSRC}/resources ${DATADIR}
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} \
${WRKSRC}/AUTHORS \
+ ${WRKSRC}/COPYING \
${WRKSRC}/ChangeLog \
- ${WRKSRC}/ChangeLog.old \
${WRKSRC}/README \
${WRKSRC}/TODO \
${DOCSDIR}