aboutsummaryrefslogtreecommitdiff
path: root/games/ttraffic/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2001-11-14 12:33:08 +0000
committerAnton Berezin <tobez@FreeBSD.org>2001-11-14 12:33:08 +0000
commitdf8b29dab15bce38ba65f1d31bb4546898e6afab (patch)
treee43bd13ace09e50a3fc8e1148bf3fa5a741c4bf6 /games/ttraffic/Makefile
parentc60bca6ca66c01e202579970d941d21dc1cfb6d2 (diff)
Notes
Diffstat (limited to 'games/ttraffic/Makefile')
-rw-r--r--games/ttraffic/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/games/ttraffic/Makefile b/games/ttraffic/Makefile
new file mode 100644
index 000000000000..15e13bf4d726
--- /dev/null
+++ b/games/ttraffic/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: games/ttraffic
+# Date created: 14 November 2001
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ttraffic
+PORTVERSION= 0.8
+CATEGORIES= games
+MASTER_SITES= http://alpha.luc.ac.be/Research/Algebra/Members/Ttraffic/ \
+ http://www.tobez.org/download/port-mirrors/games/ttraffic/
+
+MAINTAINER= tobez@FreeBSD.org
+
+BUILD_DEPENDS= wish8.3:${PORTSDIR}/x11-toolkits/tk83
+RUN_DEPENDS= wish8.3:${PORTSDIR}/x11-toolkits/tk83
+
+NO_BUILD= yes
+
+post-patch:
+ ${PERL} -pi -e 's|/usr/local/share/ttraffic/|${DATADIR}/|g;' \
+ -e 's|#!/usr/bin/wish|#!${LOCALBASE}/bin/wish8.3|g' \
+ ${WRKSRC}/ttraffic.tcl
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/ttraffic.tcl ${PREFIX}/bin/ttraffic
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/ttraffic.levels ${DATADIR}
+
+.include <bsd.port.mk>