aboutsummaryrefslogtreecommitdiff
path: root/games/ttt
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-12-29 13:35:32 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-12-29 13:35:32 +0000
commit8be024fff9f7ea35709875baf5ad6347997908d3 (patch)
tree00ad67af039c1388e9a67d1bfd38dbe70f60da73 /games/ttt
parentb5d0c057274448c699cf6646606071aaae6f13c3 (diff)
downloadports-8be024fff9f7ea35709875baf5ad6347997908d3.tar.gz
ports-8be024fff9f7ea35709875baf5ad6347997908d3.zip
Notes
Diffstat (limited to 'games/ttt')
-rw-r--r--games/ttt/Makefile48
-rw-r--r--games/ttt/distinfo2
-rw-r--r--games/ttt/files/ttt.in4
-rw-r--r--games/ttt/pkg-plist24
4 files changed, 48 insertions, 30 deletions
diff --git a/games/ttt/Makefile b/games/ttt/Makefile
index 8af048152d38..0865a269fe7a 100644
--- a/games/ttt/Makefile
+++ b/games/ttt/Makefile
@@ -3,53 +3,45 @@
PORTNAME= ttt
PORTVERSION= 2011.04
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= ftp://ftp.tuxpaint.org/unix/x/ttt/ \
- ftp://ftp.billsgames.com/unix/x/ttt/
+ ftp://ftp.billsgames.com/unix/x/ttt/ \
+ SF/nemysisfreebsdp/${CATEGORIES}/:icons
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}.png:icons
+EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
MAINTAINER= nemysis@FreeBSD.org
COMMENT= Simple one or two player Tic Tac Toe game
LICENSE= GPLv2
-USE_AUTOTOOLS= aclocal automake autoheader autoconf
+USE_SDL= mixer sdl
+USE_AUTOTOOLS= aclocal automake autoheader autoconf libtoolize
AUTOMAKE_ARGS= --add-missing --force
ALL_TARGET= ${PORTNAME}
-USE_SDL= mixer sdl
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-PLIST_FILES= bin/${PORTNAME} \
- share/pixmaps/${PORTNAME}.bmp
-
-PORTDATA= *
PORTDOCS= README
+OPTIONS_DEFINE= DOCS
+
SUB_FILES= ${PORTNAME}
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+DESKTOP_ENTRIES="Tic-Tac-Toe" "" "${PORTNAME}" \
+ "${PORTNAME}" "Game;LogicGame;" ""
do-install:
-# Scripts
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
-
-# Executable
- ${MKDIR} ${DATADIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${DATADIR}
-
-# Data
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} "images sounds" ${DATADIR})
-
-# Pixmaps
- ${INSTALL_DATA} ${WRKSRC}/images/program_logo.bmp ${PREFIX}/share/pixmaps/${PORTNAME}.bmp
-
-# Documentation
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} "images sounds" ${STAGEDIR}${DATADIR})
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/games/ttt/distinfo b/games/ttt/distinfo
index 7f8232ec9ef5..e73c45369efd 100644
--- a/games/ttt/distinfo
+++ b/games/ttt/distinfo
@@ -1,2 +1,4 @@
SHA256 (ttt-2011.04.tar.gz) = 747e3ed66e37aae9ceb32599b209d36451e910899cdd36dbf44763e90213b81e
SIZE (ttt-2011.04.tar.gz) = 140666
+SHA256 (ttt.png) = 32dd4cf8a6d03ddbc2fc90709f4567c542c240020af629722cb6f2c1841c12bd
+SIZE (ttt.png) = 2361
diff --git a/games/ttt/files/ttt.in b/games/ttt/files/ttt.in
index 864232e7b98c..efb0bb4bd48c 100644
--- a/games/ttt/files/ttt.in
+++ b/games/ttt/files/ttt.in
@@ -1,7 +1,7 @@
#!/bin/sh
#
# $FreeBSD$
+#
-echo "Tic Tac Toe: Starting up..."
cd "%%DATADIR%%"
-./ttt
+exec ./ttt "${@}"
diff --git a/games/ttt/pkg-plist b/games/ttt/pkg-plist
new file mode 100644
index 000000000000..dca794e111b8
--- /dev/null
+++ b/games/ttt/pkg-plist
@@ -0,0 +1,24 @@
+bin/ttt
+share/pixmaps/ttt.png
+%%DATADIR%%/images/game_board.bmp
+%%DATADIR%%/images/human_vs_computer.bmp
+%%DATADIR%%/images/human_vs_human.bmp
+%%DATADIR%%/images/mark_o.bmp
+%%DATADIR%%/images/mark_x.bmp
+%%DATADIR%%/images/program_logo.bmp
+%%DATADIR%%/images/status_draw.bmp
+%%DATADIR%%/images/status_win_o.bmp
+%%DATADIR%%/images/status_win_x.bmp
+%%DATADIR%%/images/turn_o.bmp
+%%DATADIR%%/images/turn_x.bmp
+%%DATADIR%%/sounds/badspot.wav
+%%DATADIR%%/sounds/draw.wav
+%%DATADIR%%/sounds/intro.wav
+%%DATADIR%%/sounds/o.wav
+%%DATADIR%%/sounds/start.wav
+%%DATADIR%%/sounds/win.wav
+%%DATADIR%%/sounds/x.wav
+%%DATADIR%%/ttt
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%