aboutsummaryrefslogtreecommitdiff
path: root/games/tuxpaint-config/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-29 14:44:21 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-29 14:44:21 +0000
commit95d0ada3f364b932fb20cc3feb9430d64f9f2612 (patch)
tree56525414627a38cf792708d3356d96a985aec208 /games/tuxpaint-config/Makefile
parent73a62517e946ef632d20e80cac4bbe2dacfea548 (diff)
downloadports-95d0ada3f364b932fb20cc3feb9430d64f9f2612.tar.gz
ports-95d0ada3f364b932fb20cc3feb9430d64f9f2612.zip
Notes
Diffstat (limited to 'games/tuxpaint-config/Makefile')
-rw-r--r--games/tuxpaint-config/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/games/tuxpaint-config/Makefile b/games/tuxpaint-config/Makefile
new file mode 100644
index 000000000000..6ef36fb16885
--- /dev/null
+++ b/games/tuxpaint-config/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: tuxpaint-config
+# Date created: 28 Nov 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tuxpaint-config
+PORTVERSION= 0.0.6
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= tuxpaint
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Graphical tool to change TuxPaint settings
+
+LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+RUN_DEPENDS= tuxpaint:${PORTSDIR}/games/tuxpaint
+
+USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_REINPLACE= yes
+
+MAN1= tuxpaint-config.1
+MANCOMPRESSED= yes
+
+post-patch:
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's|install-doc\([^:]\)|\1|' ${WRKSRC}/${MAKEFILE}
+.endif
+
+.include <bsd.port.mk>