aboutsummaryrefslogtreecommitdiff
path: root/games/tuxpaint-fonts
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-06 15:53:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-06 15:53:05 +0000
commitb5ce5fadd01879f8c1dad2f5ffba815323e1fec6 (patch)
tree1096c4907ae0d6a953ac6ff34198f06e0a0703d8 /games/tuxpaint-fonts
parent1e87c851621a7d8342431b2ac0521c634060587b (diff)
downloadports-b5ce5fadd01879f8c1dad2f5ffba815323e1fec6.tar.gz
ports-b5ce5fadd01879f8c1dad2f5ffba815323e1fec6.zip
Notes
Diffstat (limited to 'games/tuxpaint-fonts')
-rw-r--r--games/tuxpaint-fonts/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/games/tuxpaint-fonts/Makefile b/games/tuxpaint-fonts/Makefile
index 8b042f473952..c9262008b7b4 100644
--- a/games/tuxpaint-fonts/Makefile
+++ b/games/tuxpaint-fonts/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tuxpaint-fonts
-# Date created: 15 Jul 2005
-# Whom: Alejandro Pulver <alejandro@varnet.biz>
-#
+# Created by: Alejandro Pulver <alejandro@varnet.biz>
# $FreeBSD$
-#
PORTNAME= tuxpaint
PORTVERSION= 2004.06.05
@@ -33,9 +29,14 @@ CHINESE_SIMPLIFIED_CODE= zh_cn
KOREAN_CODE= ko
VIETNAMESE_CODE= vi
+#Bmake compatibility
+.MAKE.FreeBSD_UL= yes
+
# Generate options menu.
.for l in ${LANGS}
-OPTIONS+= ${l:U} "${l:S/_/ /} fonts" on
+OPTIONS_DEFINE+= ${l:U}
+OPTIONS_DEFAULT+= ${l:U}
+${l:U}_DESC= ${l:S/_/ /} fonts
.endfor
# Set MASTER_SITES
@@ -46,11 +47,11 @@ MASTER_SITES+= SF/${PORTNAME}/${PORTNAME}-fonts/${${l:U}_DISTNAME}:${l:U}
# Do not use the same OPTIONS directory as "games/tuxpaint".
LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
# Set DISTFILES and PLIST_FILES according to OPTIONS.
.for l in ${LANGS}
-. if !defined(WITHOUT_${l:U})
+. if ${PORT_OPTIONS:M${l:U}}
DISTFILES+= ${PORTNAME}-ttf-${${l:U}_DISTNAME}${EXTRACT_SUFX}:${l:U}
PLIST_FILES+= %%DATADIR%%/fonts/locale/${${l:U}_CODE}.ttf
PLIST_FILES+= %%DATADIR%%/fonts/locale/${${l:U}_CODE}_docs/COPYING.txt
@@ -63,7 +64,7 @@ PLIST_DIRS+= %%DATADIR%%/fonts/locale/${${l:U}_CODE}_docs
do-install:
${MKDIR} ${DATADIR}/fonts/locale
.for l in ${LANGS}
-. if defined(WITH_${l:U})
+. if ${PORT_OPTIONS:M${l:U}}
${INSTALL_DATA} \
${WRKSRC}/${PORTNAME}-ttf-${${l:U}_DISTNAME}/${${l:U}_CODE}.ttf \
${DATADIR}/fonts/locale
@@ -74,4 +75,4 @@ do-install:
. endif
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>