aboutsummaryrefslogtreecommitdiff
path: root/games/tuxpaint/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-07-25 21:13:59 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-07-25 21:13:59 +0000
commitd2515d35521121c98243147d774c50fefe6f4421 (patch)
tree462cd77a43deda0142b0abcaa126e584a5dcd6f2 /games/tuxpaint/Makefile
parentf57aabd96a1e6df9ed13c0efc557ef2a6dc07846 (diff)
downloadports-d2515d35521121c98243147d774c50fefe6f4421.tar.gz
ports-d2515d35521121c98243147d774c50fefe6f4421.zip
Fix build with linker that does not copy the dt_need from libraries it links
with like recent binutils. [1] While here: - trim headers - convert to new options framework - remove shlib version - convert USE_GMAKE -> USES=gmake Obtained from: DPorts [1]
Notes
Notes: svn path=/head/; revision=323669
Diffstat (limited to 'games/tuxpaint/Makefile')
-rw-r--r--games/tuxpaint/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/games/tuxpaint/Makefile b/games/tuxpaint/Makefile
index 173158ec1c40..fa07063b1ba7 100644
--- a/games/tuxpaint/Makefile
+++ b/games/tuxpaint/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tuxpaint
-# Date created: 14 Jul 2005
-# Whom: Alejandro Pulver <alejandro@varnet.biz>
-#
+# Created by: Alejandro Pulver <alejandro@varnet.biz>
# $FreeBSD$
-#
PORTNAME= tuxpaint
PORTVERSION= 0.9.21
@@ -14,13 +10,14 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Drawing program designed for young children
-LIB_DEPENDS= fribidi.3:${PORTSDIR}/converters/fribidi \
- paper.2:${PORTSDIR}/print/libpaper
+LIB_DEPENDS= fribidi:${PORTSDIR}/converters/fribidi \
+ paper:${PORTSDIR}/print/libpaper
+
+OPTIONS_DEFINE= DOCS
USE_GNOME= librsvg2
USE_SDL= image mixer sdl ttf pango
-USES= gettext
-USE_GMAKE= yes
+USES= gettext gmake
MAKE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
PREFIX="${PREFIX}" \
@@ -37,7 +34,9 @@ MAKE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
MANCOMPRESSED= yes
MAN1= tp-magic-config.1 tuxpaint.1 tuxpaint-import.1
-.if defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
INSTALL_TARGET= install-bin install-data install-man install-magic-plugins \
install-magic-plugin-dev install-icon install-gettext \
install-im install-importscript install-default-config \