aboutsummaryrefslogtreecommitdiff
path: root/games/tuxpaint/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-19 21:34:19 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-19 21:34:19 +0000
commitfcbde40ade3346f8f35d6e0e661793050ed979d0 (patch)
tree2ae203b05a06cd024cc1643eadf8f87b196573bb /games/tuxpaint/Makefile
parentc2a92f9f6811904f61a2deb1913c1a43dfe83f70 (diff)
downloadports-fcbde40ade3346f8f35d6e0e661793050ed979d0.tar.gz
ports-fcbde40ade3346f8f35d6e0e661793050ed979d0.zip
Notes
Diffstat (limited to 'games/tuxpaint/Makefile')
-rw-r--r--games/tuxpaint/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/games/tuxpaint/Makefile b/games/tuxpaint/Makefile
new file mode 100644
index 000000000000..afc4b7eb4e0c
--- /dev/null
+++ b/games/tuxpaint/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: tuxpaint
+# Date created: 14 Jul 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tuxpaint
+PORTVERSION= 0.9.14
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Drawing program designed for young children
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+USE_GMAKE= yes
+USE_SDL= image mixer sdl ttf
+USE_GNOME= intltool
+USE_REINPLACE= yes
+
+MAN1= tuxpaint.1 tuxpaint-import.1
+MANCOMPRESSED= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= needs wide character string functions in libc
+.endif
+
+post-extract:
+# Remove CVS directories
+ @${FIND} ${WRKSRC} -type d -name CVS -print0 | \
+ ${XARGS} -0 ${RM} -rf
+
+post-patch:
+# Fix Makefile
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}| ; \
+ s|$$(PREFIX)/share/tuxpaint|${DATADIR}| ; \
+ s|$$(PREFIX)/share/doc/tuxpaint|${DOCSDIR}|; \
+ s|sdl-config|${SDL_CONFIG}|' \
+ ${WRKSRC}/${MAKEFILE}
+
+# Documentation (optional)
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's|install-doc\([^:]\)|\1|' ${WRKSRC}/${MAKEFILE}
+.endif
+
+# Fix SDL include statement and remove "#error" statement
+ @${REINPLACE_CMD} -e 's|\(#include.*\)SDL/\(SDL.*\)|\1\2| ; \
+ s|#error.*||' \
+ ${WRKSRC}/src/${PORTNAME}.c
+
+.include <bsd.port.post.mk>