aboutsummaryrefslogtreecommitdiff
path: root/games/tuxpaint
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2018-09-17 02:43:14 +0000
committerWen Heping <wen@FreeBSD.org>2018-09-17 02:43:14 +0000
commit6941f343a629011fd31bae9e9e3b3678d536620c (patch)
tree7bad779627731b24799a0dfdfa2182dea04f0f60 /games/tuxpaint
parentdaab012e750a5c5287c3a03d34ee0ce181b295b3 (diff)
downloadports-6941f343a629011fd31bae9e9e3b3678d536620c.tar.gz
ports-6941f343a629011fd31bae9e9e3b3678d536620c.zip
Notes
Diffstat (limited to 'games/tuxpaint')
-rw-r--r--games/tuxpaint/Makefile7
-rw-r--r--games/tuxpaint/distinfo5
-rw-r--r--games/tuxpaint/files/patch-Makefile30
-rw-r--r--games/tuxpaint/pkg-plist16
4 files changed, 34 insertions, 24 deletions
diff --git a/games/tuxpaint/Makefile b/games/tuxpaint/Makefile
index 60e819edd08c..9d28069ebd25 100644
--- a/games/tuxpaint/Makefile
+++ b/games/tuxpaint/Makefile
@@ -2,12 +2,11 @@
# $FreeBSD$
PORTNAME= tuxpaint
-PORTVERSION= 0.9.22
-PORTREVISION= 1
+PORTVERSION= 0.9.23
CATEGORIES= games
MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= wen@FreeBSD.org
COMMENT= Drawing program designed for young children
LICENSE= GPLv2+
@@ -39,7 +38,7 @@ MAKE_JOBS_UNSAFE= yes
INSTALL_TARGET= install-gettext install-im install-magic-plugins \
install-magic-plugin-dev install-default-config \
install-example-stamps install-example-starters \
- install-gnome install-icon install-bin install-importscript \
+ install-icon install-bin install-importscript \
install-data install-doc install-man
PORTDOCS= *
diff --git a/games/tuxpaint/distinfo b/games/tuxpaint/distinfo
index 60f7832daf61..fa55c470f4e1 100644
--- a/games/tuxpaint/distinfo
+++ b/games/tuxpaint/distinfo
@@ -1,2 +1,3 @@
-SHA256 (tuxpaint-0.9.22.tar.gz) = 8abd932f8e36fad795bba0290c094c9c221e424c4b9aa8c763b7fb3459cb2be3
-SIZE (tuxpaint-0.9.22.tar.gz) = 13301628
+TIMESTAMP = 1537102028
+SHA256 (tuxpaint-0.9.23.tar.gz) = 349919c44e0fa252581be6e3242251fb62d20a82c971e99be96d648462bf6926
+SIZE (tuxpaint-0.9.23.tar.gz) = 15500449
diff --git a/games/tuxpaint/files/patch-Makefile b/games/tuxpaint/files/patch-Makefile
index b5fd7935e031..96feeb33cd4f 100644
--- a/games/tuxpaint/files/patch-Makefile
+++ b/games/tuxpaint/files/patch-Makefile
@@ -1,19 +1,21 @@
---- Makefile.orig 2014-08-19 07:28:33 UTC
+--- Makefile.orig 2018-08-30 09:05:19 UTC
+++ Makefile
-@@ -143,9 +143,9 @@ MAGIC_PREFIX:=$(DESTDIR)$(LIBDIR)/lib/tu
+@@ -167,10 +167,10 @@ INCLUDE_PREFIX:=$(DESTDIR)$(PREFIX)/include
+ MAGIC_PREFIX:=$(DESTDIR)$(LIBDIR)/lib$(LIBDIRSUFFIX)/tuxpaint/plugins
# Docs and man page:
- DOC_PREFIX:=$(DESTDIR)$(PREFIX)/share/doc/tuxpaint
--DEVDOC_PREFIX:=$(DESTDIR)$(PREFIX)/share/doc/tuxpaint-dev
+-DOC_PREFIX:=$(DESTDIR)$(PREFIX)/share/doc/tuxpaint-$(VER_VERSION)
+-DEVDOC_PREFIX:=$(DESTDIR)$(PREFIX)/share/doc/tuxpaint-$(VER_VERSION)/tuxpaint-dev
-MAN_PREFIX:=$(DESTDIR)$(PREFIX)/share/man
-DEVMAN_PREFIX:=$(DESTDIR)$(PREFIX)/share/man
-+DEVDOC_PREFIX:=$(DESTDIR)$(PREFIX)/share/doc/tuxpaint/dev
++DOC_PREFIX:=$(DESTDIR)$(PREFIX)/share/doc/tuxpaint
++DEVDOC_PREFIX:=$(DESTDIR)$(PREFIX)/share/doc/tuxpaint/tuxpaint/dev
+MAN_PREFIX:=$(DESTDIR)$(PREFIX)/man
+DEVMAN_PREFIX:=$(DESTDIR)$(PREFIX)/man
# BASH tab-completion file:
COMPLETIONDIR:=$(DESTDIR)/etc/bash_completion.d
-@@ -610,8 +610,8 @@ install-default-config:
+@@ -646,8 +646,8 @@ install-default-config:
@echo
@echo "...Installing default config file..."
@install -d $(CONFDIR)
@@ -24,7 +26,7 @@
# Install BASH completion file:
.PHONY: install-bash-completion
-@@ -1152,10 +1152,10 @@ tp-magic-config: src/tp-magic-config.sh.
+@@ -1201,10 +1201,10 @@ tp-magic-config: src/tp-magic-config.sh.in Makefile
@echo "...Generating 'Magic' tool API configuration script..."
@sed -e s/__VERSION__/$(VER_VERSION)/ \
-e s/__APIVERSION__/$(MAGIC_API_VERSION)/ \
@@ -33,18 +35,18 @@
- -e s=__PLUGINPREFIX__=$(MAGIC_PREFIX)= \
- -e s=__PLUGINDOCPREFIX__=$(DOC_PREFIX)/magic-docs= \
+ -e s=__INCLUDE__=$(patsubst $(DESTDIR)%,%,$(INCLUDE_PREFIX))/tuxpaint= \
-+ -e s=__DATAPREFIX__=$(patsubst $(DESTDIR)%,%,$(DATA_PREFIX))= \
-+ -e s=__PLUGINPREFIX__=$(patsubst $(DESTDIR)%,%,$(MAGIC_PREFIX))= \
-+ -e s=__PLUGINDOCPREFIX__=$(patsubst $(DESTDIR)%,%,$(DOC_PREFIX))/magic-docs= \
++ -e s=__DATAPREFIX__=$(patsubst $(DESTDIR)%,%,DATA_PREFIX)= \
++ -e s=__PLUGINPREFIX__=$(patsubst $(DESTDIR)%,%,MAGIC_PREFIX)= \
++ -e s=__PLUGINDOCPREFIX__=$(patsubst $(DESTDIR)%,%,DOC_PREFIX)/magic-docs= \
src/tp-magic-config.sh.in \
> tp-magic-config
-@@ -1178,7 +1178,7 @@ linux_PLUGIN_LIBS:=
+@@ -1227,7 +1227,7 @@ linux_PLUGIN_LIBS:=
PLUGIN_LIBS:=$($(OS)_PLUGIN_LIBS)
#MAGIC_CFLAGS:=-g3 -O2 -fvisibility=hidden -fno-common -W -Wstrict-prototypes -Wmissing-prototypes -Wall $(MAGIC_SDL_CPPFLAGS) -Isrc/
--MAGIC_CFLAGS:=-g3 -O2 -fno-common -W -Wstrict-prototypes -Wmissing-prototypes -Wall $(MAGIC_SDL_CPPFLAGS) -Isrc/
-+MAGIC_CFLAGS:=$(OPTFLAGS) -fno-common -W -Wstrict-prototypes -Wmissing-prototypes -Wall $(MAGIC_SDL_CPPFLAGS) -Isrc/
- SHARED_FLAGS:=-shared -fpic -Wl,--warn-shared-textrel
+-MAGIC_CFLAGS:=-g3 -O2 -fno-common -W -Wstrict-prototypes -Wmissing-prototypes -Wall $(MAGIC_SDL_CPPFLAGS) -Isrc/ $(ARCH_CFLAGS)
++MAGIC_CFLAGS:=$(OPTFLAGS) -fno-common -W -Wstrict-prototypes -Wmissing-prototypes -Wall $(MAGIC_SDL_CPPFLAGS) -Isrc/ $(ARCH_CFLAGS)
+ SHARED_FLAGS:=-shared -fpic
MAGIC_C:=$(wildcard magic/src/*.c)
diff --git a/games/tuxpaint/pkg-plist b/games/tuxpaint/pkg-plist
index b746f1e3bf09..dfc6a9181e7c 100644
--- a/games/tuxpaint/pkg-plist
+++ b/games/tuxpaint/pkg-plist
@@ -27,15 +27,15 @@ lib/tuxpaint/plugins/kalidescope.so
lib/tuxpaint/plugins/light.so
lib/tuxpaint/plugins/metalpaint.so
lib/tuxpaint/plugins/mirror_flip.so
-lib/tuxpaint/plugins/mosaic.so
lib/tuxpaint/plugins/mosaic_shaped.so
+lib/tuxpaint/plugins/mosaic.so
lib/tuxpaint/plugins/negative.so
lib/tuxpaint/plugins/noise.so
lib/tuxpaint/plugins/perspective.so
lib/tuxpaint/plugins/puzzle.so
lib/tuxpaint/plugins/rails.so
-lib/tuxpaint/plugins/rain.so
lib/tuxpaint/plugins/rainbow.so
+lib/tuxpaint/plugins/rain.so
lib/tuxpaint/plugins/realrainbow.so
lib/tuxpaint/plugins/ripples.so
lib/tuxpaint/plugins/rosette.so
@@ -54,7 +54,6 @@ man/man1/tp-magic-config.1.gz
man/man1/tuxpaint.1.gz
man/man1/tuxpaint-import.1.gz
man/pl/man1/tuxpaint.1.gz
-share/applications/tuxpaint.desktop
share/locale/ach/LC_MESSAGES/tuxpaint.mo
share/locale/af/LC_MESSAGES/tuxpaint.mo
share/locale/ak/LC_MESSAGES/tuxpaint.mo
@@ -67,8 +66,10 @@ share/locale/az/LC_MESSAGES/tuxpaint.mo
share/locale/be/LC_MESSAGES/tuxpaint.mo
share/locale/bg/LC_MESSAGES/tuxpaint.mo
share/locale/bm/LC_MESSAGES/tuxpaint.mo
+share/locale/bn/LC_MESSAGES/tuxpaint.mo
share/locale/bo/LC_MESSAGES/tuxpaint.mo
share/locale/br/LC_MESSAGES/tuxpaint.mo
+share/locale/brx/LC_MESSAGES/tuxpaint.mo
share/locale/bs/LC_MESSAGES/tuxpaint.mo
share/locale/ca/LC_MESSAGES/tuxpaint.mo
share/locale/ca@valencia/LC_MESSAGES/tuxpaint.mo
@@ -77,6 +78,7 @@ share/locale/cs/LC_MESSAGES/tuxpaint.mo
share/locale/cy/LC_MESSAGES/tuxpaint.mo
share/locale/da/LC_MESSAGES/tuxpaint.mo
share/locale/de/LC_MESSAGES/tuxpaint.mo
+share/locale/doi/LC_MESSAGES/tuxpaint.mo
share/locale/el/LC_MESSAGES/tuxpaint.mo
share/locale/en_AU/LC_MESSAGES/tuxpaint.mo
share/locale/en_CA/LC_MESSAGES/tuxpaint.mo
@@ -108,11 +110,14 @@ share/locale/it/LC_MESSAGES/tuxpaint.mo
share/locale/iu/LC_MESSAGES/tuxpaint.mo
share/locale/ja/LC_MESSAGES/tuxpaint.mo
share/locale/ka/LC_MESSAGES/tuxpaint.mo
+share/locale/kab/LC_MESSAGES/tuxpaint.mo
share/locale/km/LC_MESSAGES/tuxpaint.mo
share/locale/kn/LC_MESSAGES/tuxpaint.mo
share/locale/ko/LC_MESSAGES/tuxpaint.mo
share/locale/kok/LC_MESSAGES/tuxpaint.mo
share/locale/kok@roman/LC_MESSAGES/tuxpaint.mo
+share/locale/ks/LC_MESSAGES/tuxpaint.mo
+share/locale/ks@devanagari/LC_MESSAGES/tuxpaint.mo
share/locale/ku/LC_MESSAGES/tuxpaint.mo
share/locale/lb/LC_MESSAGES/tuxpaint.mo
share/locale/lg/LC_MESSAGES/tuxpaint.mo
@@ -137,14 +142,16 @@ share/locale/oj/LC_MESSAGES/tuxpaint.mo
share/locale/or/LC_MESSAGES/tuxpaint.mo
share/locale/pa/LC_MESSAGES/tuxpaint.mo
share/locale/pl/LC_MESSAGES/tuxpaint.mo
-share/locale/pt/LC_MESSAGES/tuxpaint.mo
share/locale/pt_BR/LC_MESSAGES/tuxpaint.mo
+share/locale/pt/LC_MESSAGES/tuxpaint.mo
share/locale/ro/LC_MESSAGES/tuxpaint.mo
share/locale/ru/LC_MESSAGES/tuxpaint.mo
share/locale/rw/LC_MESSAGES/tuxpaint.mo
share/locale/sa/LC_MESSAGES/tuxpaint.mo
share/locale/sat/LC_MESSAGES/tuxpaint.mo
share/locale/sat@olchiki/LC_MESSAGES/tuxpaint.mo
+share/locale/sd/LC_MESSAGES/tuxpaint.mo
+share/locale/sd@devanagari/LC_MESSAGES/tuxpaint.mo
share/locale/shs/LC_MESSAGES/tuxpaint.mo
share/locale/si/LC_MESSAGES/tuxpaint.mo
share/locale/sk/LC_MESSAGES/tuxpaint.mo
@@ -164,6 +171,7 @@ share/locale/tlh/LC_MESSAGES/tuxpaint.mo
share/locale/tr/LC_MESSAGES/tuxpaint.mo
share/locale/tw/LC_MESSAGES/tuxpaint.mo
share/locale/uk/LC_MESSAGES/tuxpaint.mo
+share/locale/ur/LC_MESSAGES/tuxpaint.mo
share/locale/ve/LC_MESSAGES/tuxpaint.mo
share/locale/vec/LC_MESSAGES/tuxpaint.mo
share/locale/vi/LC_MESSAGES/tuxpaint.mo