aboutsummaryrefslogtreecommitdiff
path: root/games/tuxracer
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2010-09-15 18:35:24 +0000
committerAde Lovett <ade@FreeBSD.org>2010-09-15 18:35:24 +0000
commit8262a7b51d413e11ef8f67c56e862ebbc6f182de (patch)
tree1e9812bc2638933184cae2b226809eb69253bb9f /games/tuxracer
parentbe8126109fa13097c8a0f9337fa9dfb68cf5d4c2 (diff)
downloadports-8262a7b51d413e11ef8f67c56e862ebbc6f182de.tar.gz
ports-8262a7b51d413e11ef8f67c56e862ebbc6f182de.zip
Notes
Diffstat (limited to 'games/tuxracer')
-rw-r--r--games/tuxracer/Makefile4
-rw-r--r--games/tuxracer/files/patch-configure.in63
2 files changed, 26 insertions, 41 deletions
diff --git a/games/tuxracer/Makefile b/games/tuxracer/Makefile
index b280c8345883..f19dd3ea0954 100644
--- a/games/tuxracer/Makefile
+++ b/games/tuxracer/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tuxracer
PORTVERSION= 0.61
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= games
MASTER_SITES= SF
DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz \
@@ -22,7 +22,7 @@ USE_SDL= mixer sdl
USE_GL= gl
USE_XORG= x11 xt xmu xi
USE_GMAKE= yes
-USE_AUTOTOOLS= automake:14 autoconf:262
+USE_AUTOTOOLS= automake:14 autoconf:267
AUTOMAKE_ARGS= -a
CONFIGURE_ENV= THREAD_LIB="${PTHREAD_LIBS}"
MAKE_ENV= ${CONFIGURE_ENV}
diff --git a/games/tuxracer/files/patch-configure.in b/games/tuxracer/files/patch-configure.in
index caf2953a8959..57138f28db91 100644
--- a/games/tuxracer/files/patch-configure.in
+++ b/games/tuxracer/files/patch-configure.in
@@ -1,8 +1,6 @@
---- configure.in.orig 2001-01-16 16:26:29.000000000 +0100
-+++ configure.in 2009-04-27 03:06:12.000000000 +0200
-@@ -43,16 +43,10 @@
- dnl General options
- dnl --------------------------------------------------------------------------
+--- configure.in.orig 2001-01-16 15:26:29.000000000 +0000
++++ configure.in 2010-06-14 11:51:45.000000000 +0000
+@@ -45,12 +45,6 @@
TR_CPPFLAGS=""
-TR_CFLAGS="-O2 -Wall -fomit-frame-pointer -ffast-math -fexpensive-optimizations"
-TR_CXXFLAGS="-O2 -Wall -fomit-frame-pointer -ffast-math -fexpensive-optimizations"
@@ -17,54 +15,34 @@
-esac
-
AC_ARG_ENABLE(debug, [ --enable-debug Produce an executable with debugging symbols],
- [TR_CFLAGS="-g -Wall"; TR_CXXFLAGS="-g -Wall"],
- [TR_CPPFLAGS="$TR_CPPFLAGS -DTUXRACER_NO_ASSERT=1"])
-@@ -137,6 +131,10 @@
- if test "x$have_tcl_lib" = "xno" -a "x$with_tcl_lib_name" = "x" ; then
-
+@@ -139,2 +133,6 @@
TCL_LIB_LIST=`grep -v -E "^$TCL_LIB_NAME\$" <<EOF
+tcl8.5
+tcl85
+tcl8.4
+tcl84
tcl8.3
- tcl83
- tcl8.2
-@@ -191,6 +189,10 @@
-
- TCL_HEADER_LIST=`grep -v -E "^$TCL_HEADER\$" <<EOF
+@@ -193,2 +191,6 @@
tcl.h
+tcl8.5.h
+tcl85.h
+tcl8.4.h
+tcl84.h
tcl8.3.h
- tcl83.h
- tcl8.2.h
-@@ -219,7 +221,8 @@
- FIND_TCL_H
-
+@@ -221,3 +223,4 @@
if test "x$have_tcl_h" = "xno" -a "x$with_tcl_inc" = "x"; then
- TCL_INC_LIST="/usr/include/tcl8.3 /usr/include/tcl8.2 \
+ TCL_INC_LIST="/usr/include/tcl8.5 /usr/include/tcl8.4 \
+ /usr/include/tcl8.3 /usr/include/tcl8.2 \
/usr/include/tcl8.0 /usr/include/tcl"
-
- for TCL_INC in $TCL_INC_LIST ; do
-@@ -303,6 +306,10 @@
-
- saved_LIBS="$LIBS"
+@@ -305,2 +308,6 @@
+if test "x$THREAD_LIB" = "x" ; then
+ THREAD_LIB="-lpthread"
+fi
+
AC_DEFUN( CHECK_FOR_GL_LIB, [
- AC_MSG_CHECKING([for $GL_LIB_NAME library])
- LIBS="$saved_LIBS $TR_LIBS $GL_LDOPTS -l$GL_LIB_NAME"
-@@ -313,15 +320,15 @@
- TR_LIBS="$TR_LIBS $GL_LDOPTS -l$GL_LIB_NAME"
-
+@@ -315,6 +322,6 @@
else
- dnl Try with -lpthread
+ dnl Try with pthreads
@@ -73,20 +51,27 @@
- LIBS="$saved_LIBS $TR_LIBS $GL_LDOPTS -l$GL_LIB_NAME -lpthread"
+ LIBS="$saved_LIBS $TR_LIBS $GL_LDOPTS -l$GL_LIB_NAME $THREAD_LIB"
AC_TRY_LINK( , , have_GL=yes, have_GL=no)
- AC_MSG_RESULT([$have_GL])
-
+@@ -323,3 +330,3 @@
if test "x$have_GL" = "xyes" ; then
- TR_LIBS="$TR_LIBS $GL_LDOPTS -l$GL_LIB_NAME -lpthread"
+ TR_LIBS="$TR_LIBS $GL_LDOPTS -l$GL_LIB_NAME $THREAD_LIB"
fi
- fi
- ])
-@@ -466,7 +473,7 @@
- if test "x$have_glx_h" = "xno" ; then
- AC_MSG_ERROR([Cannot find GL/glx.h])
+@@ -468,3 +475,3 @@
fi
-
+ CFLAGS="$CFLAGS -DGLX_GLXEXT_LEGACY"
dnl Check that glXGetProcAddressARB is defined in glx.h
- AC_MSG_CHECKING([whether glx.h defines glXGetProcAddressARB]);
- AC_TRY_COMPILE( [#include <GL/glx.h>], [ char *foo = (char*) glXGetProcAddressARB; ],
+@@ -480,4 +487,7 @@
+
+-dnl Check for glext.h
+-AC_CHECK_HEADERS( "GL/glext.h", have_glext_h=yes, have_glext_h=no )
++dnl Check for glext.h
++dnl XXX: which requires GL/gl.h, and autoconf > 2.64 is barfing on this
++dnl XXX: use following check to cover the bases
++dnl AC_CHECK_HEADERS( "GL/glext.h", have_glext_h=yes, have_glext_h=no )
++have_glext_h=yes
+
+@@ -497,2 +507,3 @@
+ [
++#include <GL/gl.h>
+ #include <GL/glext.h>