aboutsummaryrefslogtreecommitdiff
path: root/games/twind
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2012-08-17 17:46:32 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2012-08-17 17:46:32 +0000
commite4a44105fed810df97725f873414cb083a04661a (patch)
tree821ab685e9ed4febb40e0d8f7853d0904141bfbf /games/twind
parent95b65cd5f58ec59cbd581707d4ad1eaf964aeeaf (diff)
downloadports-e4a44105fed810df97725f873414cb083a04661a.tar.gz
ports-e4a44105fed810df97725f873414cb083a04661a.zip
Notes
Diffstat (limited to 'games/twind')
-rw-r--r--games/twind/Makefile22
1 files changed, 16 insertions, 6 deletions
diff --git a/games/twind/Makefile b/games/twind/Makefile
index 0946c541d4a4..84a42ae79f6b 100644
--- a/games/twind/Makefile
+++ b/games/twind/Makefile
@@ -15,15 +15,20 @@ COMMENT= Match and remove all of the blocks before time runs out
LICENSE= GPLv2
+OPTIONS_DEFINE= DATA
+OPTIONS_DEFAULT= DATA
+
USE_SDL= sdl image mixer
MAKE_JOBS_SAFE= yes
-PLIST_FILES= bin/twind \
+PLIST_FILES= bin/${PORTNAME} \
share/pixmaps/${PORTNAME}.png
PORTDATA= *
PORTDOCS= AUTHORS CREDITS ChangeLog NEWS README TODO
+.include <bsd.port.options.mk>
+
do-build:
cd ${WRKSRC} && ${CC} -o ${PORTNAME} ${CFLAGS} \
-DDATA_PREFIX=\"${DATADIR}/\" -DAUDIO -DLINUX \
@@ -31,17 +36,22 @@ do-build:
do-install:
# Executable
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-# Pixmaps
- ${INSTALL_DATA} ${WRKSRC}/graphics/twind.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
+
# Data
+.if ${PORT_OPTIONS:MDATA}
${MKDIR} ${DATADIR}
@(cd ${WRKSRC} && ${COPYTREE_SHARE} "graphics music sound" ${DATADIR})
+.endif
+
+# Pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/graphics/${PORTNAME}.png ${PREFIX}/share/pixmaps/
+
# Documentation
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
-.for f in ${PORTDOCS}
+. for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
+. endfor
.endif
.include <bsd.port.mk>