aboutsummaryrefslogtreecommitdiff
path: root/games/twind
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2012-12-18 13:09:11 +0000
committerLars Engels <lme@FreeBSD.org>2012-12-18 13:09:11 +0000
commite25988554c63744161c2c1f20662475662caeab4 (patch)
treef95291c0eafe1538022fdd8cda7ecb4515ede00f /games/twind
parent33bd5eb62c6095e0df68ee36a442651c1202bc17 (diff)
downloadports-e25988554c63744161c2c1f20662475662caeab4.tar.gz
ports-e25988554c63744161c2c1f20662475662caeab4.zip
Notes
Diffstat (limited to 'games/twind')
-rw-r--r--games/twind/Makefile20
-rw-r--r--games/twind/pkg-plist57
2 files changed, 63 insertions, 14 deletions
diff --git a/games/twind/Makefile b/games/twind/Makefile
index 2c3f23336895..23af2672d395 100644
--- a/games/twind/Makefile
+++ b/games/twind/Makefile
@@ -7,7 +7,7 @@
PORTNAME= twind
PORTVERSION= 1.1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
@@ -19,12 +19,11 @@ LICENSE= GPLv2
USE_SDL= sdl image mixer
MAKE_JOBS_SAFE= yes
-PLIST_FILES= bin/${PORTNAME} \
- share/pixmaps/${PORTNAME}.png
-
-PORTDATA= *
PORTDOCS= AUTHORS CREDITS ChangeLog NEWS README TODO
+DESKTOP_ENTRIES="Twin Distress" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" ${FALSE}
+
.include <bsd.port.options.mk>
do-build:
@@ -32,22 +31,15 @@ do-build:
-DDATA_PREFIX=\"${DATADIR}/\" -DAUDIO -DLINUX \
-lm `${SDL_CONFIG} --cflags --libs` -lSDL_mixer -lSDL_image twind.c
do-install:
-# Executable
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-
-# Data
${MKDIR} ${DATADIR}
@(cd ${WRKSRC} && ${COPYTREE_SHARE} "graphics music sound" ${DATADIR})
-# Pixmaps
- ${INSTALL_DATA} ${WRKSRC}/graphics/${PORTNAME}.png ${PREFIX}/share/pixmaps/
+ ${INSTALL_DATA} ${WRKSRC}/graphics/${PORTNAME}.png ${PREFIX}/share/pixmaps
-# Documentation
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
-. for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-. endfor
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/games/twind/pkg-plist b/games/twind/pkg-plist
new file mode 100644
index 000000000000..40ec013397df
--- /dev/null
+++ b/games/twind/pkg-plist
@@ -0,0 +1,57 @@
+bin/twind
+share/pixmaps/twind.png
+%%DATADIR%%/graphics/background.png
+%%DATADIR%%/graphics/beveled.png
+%%DATADIR%%/graphics/black_l.png
+%%DATADIR%%/graphics/black_r.png
+%%DATADIR%%/graphics/bricks.png
+%%DATADIR%%/graphics/brushed_metal.png
+%%DATADIR%%/graphics/circles.png
+%%DATADIR%%/graphics/freeserif_green_20.png
+%%DATADIR%%/graphics/freeserif_green_24.png
+%%DATADIR%%/graphics/freeserif_white_20.png
+%%DATADIR%%/graphics/freeserif_white_24.png
+%%DATADIR%%/graphics/highlight1.png
+%%DATADIR%%/graphics/highlight2.png
+%%DATADIR%%/graphics/highlight3.png
+%%DATADIR%%/graphics/highlight4.png
+%%DATADIR%%/graphics/left_mouse_highlight.png
+%%DATADIR%%/graphics/path_blocks.png
+%%DATADIR%%/graphics/pyramids.png
+%%DATADIR%%/graphics/right_mouse_highlight.png
+%%DATADIR%%/graphics/snake_skin.png
+%%DATADIR%%/graphics/timer_empty.png
+%%DATADIR%%/graphics/timer_empty_white.png
+%%DATADIR%%/graphics/timer_full.png
+%%DATADIR%%/graphics/timer_full_white.png
+%%DATADIR%%/graphics/title_big.png
+%%DATADIR%%/graphics/title_small.png
+%%DATADIR%%/graphics/twind.png
+%%DATADIR%%/graphics/volume_bar.png
+%%DATADIR%%/graphics/volume_slider.png
+%%DATADIR%%/graphics/white_l.png
+%%DATADIR%%/graphics/white_r.png
+%%DATADIR%%/music/0-0.ogg
+%%DATADIR%%/music/0-1.ogg
+%%DATADIR%%/music/1-1.ogg
+%%DATADIR%%/music/1-2.ogg
+%%DATADIR%%/music/2-1.ogg
+%%DATADIR%%/music/2-2.ogg
+%%DATADIR%%/music/3-1.ogg
+%%DATADIR%%/music/3-2.ogg
+%%DATADIR%%/music/4-1.ogg
+%%DATADIR%%/music/4-2.ogg
+%%DATADIR%%/music/5-1.ogg
+%%DATADIR%%/music/5-2.ogg
+%%DATADIR%%/music/6-1.ogg
+%%DATADIR%%/music/6-2.ogg
+%%DATADIR%%/sound/apply_bonus.wav
+%%DATADIR%%/sound/eliminate_blocks.wav
+%%DATADIR%%/sound/keyboard_click.wav
+%%DATADIR%%/sound/menu_option.wav
+%%DATADIR%%/sound/option_choice.wav
+%%DATADIR%%/sound/wrong_move.wav
+@dirrm %%DATADIR%%/sound
+@dirrm %%DATADIR%%/music
+@dirrm %%DATADIR%%/graphics
+@dirrm %%DATADIR%%