aboutsummaryrefslogtreecommitdiff
path: root/games/twitch
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-04-12 19:17:41 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-04-12 19:17:41 +0000
commitdaa1e570e6810477966f3a9e0cf445d3d3035b61 (patch)
tree52f879912b5c179a207da658b93cb50b7fbe0d4c /games/twitch
parent973f9061f3d0744d6f5c4e292d1bd22f39b2ed56 (diff)
Notes
Diffstat (limited to 'games/twitch')
-rw-r--r--games/twitch/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/games/twitch/Makefile b/games/twitch/Makefile
index 7e4ec2c36e6d..bd5083506d84 100644
--- a/games/twitch/Makefile
+++ b/games/twitch/Makefile
@@ -8,22 +8,21 @@ CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Twitch/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= An overhead 2-d shooter, reminiscent of games like Robotron
+COMMENT= Overhead 2-d shooter, reminiscent of games like Robotron
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pygame/__init__.py:${PORTSDIR}/devel/py-game
+RUN_DEPENDS= ${PYGAME}
USE_PYTHON= yes
-NO_STAGE= yes
do-build:
${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -l ${WRKSRC}
do-install:
- @${MKDIR} ${PREFIX}/share/twitch
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/twitch
(cd ${WRKSRC}; ${TAR} cf - images sound levels twitch.*) | \
- (cd ${PREFIX}/share/twitch; ${TAR} xf -)
+ (cd ${STAGEDIR}${PREFIX}/share/twitch; ${TAR} xf -)
@printf "#!/bin/sh\ncd ${PREFIX}/share/twitch && \
${PYTHON_CMD} ${PREFIX}/share/twitch/twitch.py\n" > ${WRKDIR}/twitch.sh
- @${INSTALL_SCRIPT} ${WRKDIR}/twitch.sh ${PREFIX}/bin/twitch
+ ${INSTALL_SCRIPT} ${WRKDIR}/twitch.sh ${STAGEDIR}${PREFIX}/bin/twitch
.include <bsd.port.mk>