aboutsummaryrefslogtreecommitdiff
path: root/games/ufoai/Makefile
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2012-12-13 18:14:50 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2012-12-13 18:14:50 +0000
commit25aad2ab02b42efd579c6cc63ea71c1616a095de (patch)
tree42d6023e4adedaabfda19d775296e60c29322442 /games/ufoai/Makefile
parent8551a2f82396e4b8feb7b53b752ab9a23d193e8c (diff)
downloadports-25aad2ab02b42efd579c6cc63ea71c1616a095de.tar.gz
ports-25aad2ab02b42efd579c6cc63ea71c1616a095de.zip
Notes
Diffstat (limited to 'games/ufoai/Makefile')
-rw-r--r--games/ufoai/Makefile47
1 files changed, 21 insertions, 26 deletions
diff --git a/games/ufoai/Makefile b/games/ufoai/Makefile
index 93fd66a27d53..924e3d2c8e22 100644
--- a/games/ufoai/Makefile
+++ b/games/ufoai/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: ufoai
-# Date created: 2006-09-03
-# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
-#
+# Created by: Alonso Cardenas Marquez <acm@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= ufoai
-PORTVERSION= 2.3.1
-PORTREVISION= 3
+PORTVERSION= 2.4
+PORTREVISION= 0
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/UFO_AI%202.x/${PORTVERSION}
DISTNAME= ${PORTNAME:S/$/-/}${PORTVERSION}-source
@@ -23,9 +19,9 @@ LIB_DEPENDS= vorbis:${PORTSDIR}/audio/libvorbis \
execinfo:${PORTSDIR}/devel/libexecinfo \
theora.0:${PORTSDIR}/multimedia/libtheora \
xvidcore.4:${PORTSDIR}/multimedia/xvid
+BUILD_DEPENDS= ${LOCALBASE}/include/mxml.h:${PORTSDIR}/textproc/mxml
RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/base/default.cfg:${PORTSDIR}/games/ufoai-data
-USE_AUTOTOOLS= aclocal autoconf
USE_BZIP2= yes
USE_GL= yes
USE_SDL= sdl image mixer ttf
@@ -33,10 +29,10 @@ USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= pkgconfig
USE_OPENAL= soft
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --enable-release=yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS+= --enable-release
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lexecinfo
CFLAGS+= -I${LOCALBASE}/include
DATADIR= share/${PORTNAME}
@@ -45,22 +41,25 @@ WRKSRC= ${WRKDIR}/${PORTNAME:S/$/-/}${PORTVERSION}-source
UFO_DIR= ${PREFIX}/lib/${PORTNAME}
UFO_FILES= ufo ufomodel
-OPTIONS= SERVER "Install dedicated server" on \
- UFO2MAP "Install UFO tools" on \
- UFORADIANT "Install UFO map editor" off
+OPTIONS_DEFINE= SERVER UFO2MAP UFORADIANT
+OPTIONS_DEFAULT= SERVER UFO2MAP
+
+SERVER_DESC= Install dedicated server
+UFO2MAP_DESC= Install UFO tools
+UFORADIANT_DESC= Install UFO map editor
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_SERVER)
-CONFIGURE_ARGS+= --enable-dedicated
+.if $(PORT_OPTIONS:MSERVER)
+CONFIGURE_ARGS+= --enable-ufoded
UFO_FILES+= ufoded
PLIST_SUB+= UFOSERVER=""
.else
-CONFIGURE_ARGS+= --disable-dedicated
+CONFIGURE_ARGS+= --disable-ufoded
PLIST_SUB+= UFOSERVER="@comment "
.endif
-.if !defined(WITHOUT_UFO2MAP)
+.if $(PORT_OPTIONS:MUFO2MAP)
CONFIGURE_ARGS+= --enable-ufo2map
UFO_FILES+= ufo2map
PLIST_SUB+= UFO2MAP=""
@@ -69,12 +68,12 @@ CONFIGURE_ARGS+= --disable-ufo2map
PLIST_SUB+= UFO2MAP="@comment "
.endif
-.if !defined(WITHOUT_UFORADIANT)
+.if $(PORT_OPTIONS:MUFORADIANT)
CONFIGURE_ARGS+=--enable-uforadiant
USE_GNOME+= gtk20 glib20 gtksourceview2 libxml2
LIB_DEPENDS+= gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext
RADIANT_FILE= uforadiant
-RADIANT_DIRS= bitmaps games i18n plugins prefabs shaders sourceviewer
+RADIANT_DIRS= bitmaps i18n prefabs sourceviewer
PLIST_SUB+= UFORADIANT=""
.else
CONFIGURE_ARGS+=--disable-uforadiant
@@ -84,16 +83,12 @@ PLIST_SUB+= UFORADIANT="@comment "
post-extract:
@${MKDIR} ${WRKSRC}/base/maps ${WRKSRC}/base/models
-# Resolve name collision with jpeg-8 amd API png
+# Resolve name collision with jpeg-8 and API png
post-patch:
${REINPLACE_CMD} -e 's|jpeg_mem_src|local_jpeg_mem_src|' \
-e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
-e 's|png_check_sig(PngFileBuffer.buffer, 8)|!png_sig_cmp(PngFileBuffer.buffer, 0, 8)|' \
- ${WRKSRC}/src/client/renderer/r_image.c \
- ${WRKSRC}/src/tools/ufo2map/common/imagelib.c
-
-pre-configure:
- @cd ${WRKSRC} && ${ACLOCAL} && ${AUTOCONF}
+ ${WRKSRC}/src/client/renderer/r_image.c
post-build:
@cd ${WRKSRC} && ${GMAKE} lang