aboutsummaryrefslogtreecommitdiff
path: root/games/ufoai
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2010-03-30 18:32:01 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2010-03-30 18:32:01 +0000
commitff203d57257af0c81561994466bb2f7f5d982ed6 (patch)
tree2ccf7b95c6d40e6c25910b443c504665caded6d3 /games/ufoai
parent0b0f936de4ede3a65915123d836c4ae0dd91760b (diff)
Notes
Diffstat (limited to 'games/ufoai')
-rw-r--r--games/ufoai/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/games/ufoai/Makefile b/games/ufoai/Makefile
index 5413b7771afe..82cce66915ab 100644
--- a/games/ufoai/Makefile
+++ b/games/ufoai/Makefile
@@ -63,6 +63,14 @@ CONFIGURE_ARGS+= --disable-ufo2map
PLIST_SUB+= UFO2MAP="@comment "
.endif
+# Resolve name collision with jpeg-8 amd API png
+post-patch:
+ ${REINPLACE_CMD} -e 's|jpeg_mem_src|local_jpeg_mem_src|' \
+ -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
+ -e 's|png_check_sig(PngFileBuffer.buffer, 8)|!png_sig_cmp(PngFileBuffer.buffer, 0, 8)|' \
+ ${WRKSRC}/src/renderer/r_image.c \
+ ${WRKSRC}/src/tools/ufo2map/common/imagelib.c
+
pre-install:
. for FILE in ${UFO_FILES}
@${ECHO} "#!/bin/sh" > ${WRKDIR}/${FILE}