aboutsummaryrefslogtreecommitdiff
path: root/games/uhexen2
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 16:35:45 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 16:35:45 +0000
commit3a283e24f296371e9b753c09e3e62a92ef3d8703 (patch)
tree88e0a2bbddafb5c9bdc18e8e02c5e59fb9f9d471 /games/uhexen2
parent7a0a8929bea1c510b4f30261d294a78b556b49d7 (diff)
downloadports-3a283e24f296371e9b753c09e3e62a92ef3d8703.tar.gz
ports-3a283e24f296371e9b753c09e3e62a92ef3d8703.zip
Notes
Diffstat (limited to 'games/uhexen2')
-rw-r--r--games/uhexen2/Makefile46
1 files changed, 23 insertions, 23 deletions
diff --git a/games/uhexen2/Makefile b/games/uhexen2/Makefile
index cb188a59efca..ac83fdca4a98 100644
--- a/games/uhexen2/Makefile
+++ b/games/uhexen2/Makefile
@@ -29,22 +29,22 @@ USE_SDL= sdl mixer
WANT_GNOME= yes
MAKE_JOBS_UNSAFE= yes
-OPTIONS= DEMO "Install demo version of the game data" off \
- HEXEN2 "Build Hexen II clients and servers" on \
- HW "Build HexenWorld clients and servers" on \
- LAUNCHER_GTK1 "Build graphical (GTK1) game launcher" on \
- LAUNCHER_GTK2 "Build graphical (GTK2) game launcher" off \
- X86_ASM "Enable use of optimized x86 assembly code" on
+OPTIONS_MULTI= BIN
+OPTIONS_MULTI_BIN= HEXEN2 HW
+OPTIONS_DEFINE= DEMO LAUNCHER_GTK1 LAUNCHER_GTK2 X86_ASM DOCS
+OPTIONS_DEFALT= HEXEN2 HW LAUNCHER_GTK1 X86_ASM
+DEMO_DESC= Install demo version of the game data
+HEXEN2_DESC= Build Hexen II clients and servers
+HW_DESC= Build HexenWorld clients and servers
+LAUNCHER_GTK1_DESC= Build graphical (GTK1) game launcher
+LAUNCHER_GTK2_DESC= Build graphical (GTK2) game launcher
+X86_ASM_DESC= Enable use of optimized x86 assembly code
PORTSCOUT= skipb:yes
.include <bsd.port.pre.mk>
-.if defined(WITHOUT_HEXEN2) && defined(WITHOUT_HW)
-IGNORE= needs at least one group of binaries (HEXEN2 and HW)
-.endif
-
-.if defined(WITH_DEMO)
+.if ${PORT_OPTIONS:MDEMO}
MASTER_SITES+= SF/${PORTNAME}/Hammer%20of%20Thyrion/${PORTVERSION}/Linux-demo-version:demo
DISTFILES+= hexen2demo-${PORTVERSION}-linux-i586${EXTRACT_SUFX}:demo
MAKE_ENV+= DEMO=yes
@@ -62,7 +62,7 @@ UH2_DATA= default.cfg hexen.rc progs.dat progs2.dat strings.txt
UH2_DATADIR= ${WRKDIR}
.endif
-.if defined(WITH_HEXEN2)
+.if ${PORT_OPTIONS:MHEXEN2}
MAKE_ENV+= BUILD_HEXEN2=yes
PLIST_SUB+= HEXEN2=""
UH2_BIN+= engine/hexen2/glhexen2 \
@@ -71,8 +71,8 @@ UH2_BIN+= engine/hexen2/glhexen2 \
PLIST_SUB+= HEXEN2="@comment "
.endif
-.if defined(WITH_HW)
-. if !defined(WITH_DEMO)
+.if ${PORT_OPTIONS:MHW}
+. if empty(PORT_OPTIONS:MDEMO)
MASTER_SITES+= SF/${PORTNAME}/Hexen2%20GameData/hexenworld-pakfiles:hw
DISTFILES+= hexenworld-pakfiles-0.15${EXTRACT_SUFX}:hw
. endif
@@ -85,7 +85,7 @@ UH2_BIN+= engine/hexenworld/client/glhwcl \
PLIST_SUB+= HW="@comment "
.endif
-.if defined(WITH_LAUNCHER_GTK1)
+.if ${PORT_OPTIONS:MLAUNCHER_GTK1}
USE_GNOME+= gtk12
MAKE_ENV+= BUILD_LAUNCHER_GTK1=yes
PLIST_SUB+= LAUNCHER_GTK1=""
@@ -93,7 +93,7 @@ PLIST_SUB+= LAUNCHER_GTK1=""
PLIST_SUB+= LAUNCHER_GTK1="@comment "
.endif
-.if defined(WITH_LAUNCHER_GTK2)
+.if ${PORT_OPTIONS:MLAUNCHER_GTK2}
USE_GNOME+= gtk20
MAKE_ENV+= BUILD_LAUNCHER_GTK2=yes
PLIST_SUB+= LAUNCHER_GTK2=""
@@ -101,7 +101,7 @@ PLIST_SUB+= LAUNCHER_GTK2=""
PLIST_SUB+= LAUNCHER_GTK2="@comment "
.endif
-.if defined(WITH_X86_ASM) && ${ARCH} == "i386"
+.if ${PORT_OPTIONS:MX86_ASM} && ${ARCH} == "i386"
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
MAKE_ENV+= USE_X86_ASM=yes
.endif
@@ -117,26 +117,26 @@ do-install:
.for f in ${UH2_DATA}
${INSTALL_DATA} ${UH2_DATADIR}/data1/${f} ${DATADIR}/data1
.endfor
-.if !defined(WITH_DEMO)
+.if empty(PORT_OPTIONS:MDEMO)
${INSTALL_DATA} ${WRKDIR}/patchdat/data1/* ${DATADIR}/data1
${CP} -R ${WRKDIR}/portals ${DATADIR}
.endif
-.if defined(WITH_HW)
+.if ${PORT_OPTIONS:MHW}
${MKDIR} ${DATADIR}/hw
${INSTALL_DATA} ${UH2_DATADIR}/hw/* ${DATADIR}/hw
.endif
-.if defined(WITH_LAUNCHER_GTK1)
+.if ${PORT_OPTIONS:MLAUNCHER_GTK1}
${INSTALL_PROGRAM} ${WRKSRC}/launcher/h2launcher.gtk1 ${PREFIX}/bin
.endif
-.if defined(WITH_LAUNCHER_GTK2)
+.if ${PORT_OPTIONS:MLAUNCHER_GTK2}
${INSTALL_PROGRAM} ${WRKSRC}/launcher/h2launcher.gtk2 ${PREFIX}/bin
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCSDIR}
.endif
-.if !defined(WITH_DEMO)
+.if empty(PORT_OPTIONS:MDEMO)
post-install:
@${ECHO_CMD}
@${CAT} ${PKGMESSAGE}