aboutsummaryrefslogtreecommitdiff
path: root/games/uhexen
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-02-23 21:13:26 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-02-23 21:13:26 +0000
commitdfab67693fda780672553182b37c7eaccfca1da1 (patch)
tree048ad2ba5b34a3176ada4018a09711e9d1866441 /games/uhexen
parent0e41d871c0ce5bfd66c985400e01269f88c3a133 (diff)
Notes
Diffstat (limited to 'games/uhexen')
-rw-r--r--games/uhexen/Makefile29
-rw-r--r--games/uhexen/pkg-plist4
2 files changed, 19 insertions, 14 deletions
diff --git a/games/uhexen/Makefile b/games/uhexen/Makefile
index 6b4785616641..f35f4638be85 100644
--- a/games/uhexen/Makefile
+++ b/games/uhexen/Makefile
@@ -19,29 +19,38 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Yet another port of Hexen, popular game from Raven Softrware
+OPTIONS= NOWAD "Don't install WAD file" off
+
+USE_SDL= mixer sdl
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_NOWAD)
+WITHOUT_WAD= yes
+.endif
+
.if !defined(WITHOUT_WAD)
EXTRACT_DEPENDS=unzip:${PORTSDIR}/archivers/unzip
.endif
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+PLIST_FILES= bin/uhexen %%DATADIR%%/.keep_me %%WAD%%%%DATADIR%%/hexen.wad
+PLIST_DIRS= %%DATADIR%%
-USE_SDL= mixer sdl
-USE_X_PREFIX= yes
-USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
.if defined(WITHOUT_WAD)
-PLIST_SUB= WAD:="@comment "
+PLIST_SUB= WAD="@comment "
.else
-PLIST_SUB= WAD:=""
+PLIST_SUB= WAD=""
.endif
-BROKEN= "Broken pkg-plist"
-
pre-everything::
@${ECHO} ""
@${ECHO} "You may use the following build options:"
@${ECHO} ""
- @${ECHO} " WITHOUT_WAD=yes Don't install the wad file."
+ @${ECHO} " WITH_NOWAD=yes Don't install the wad file."
@${ECHO} ""
post-extract:
@@ -58,4 +67,4 @@ do-install:
.endif
${TOUCH} ${DATADIR}/.keep_me
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/uhexen/pkg-plist b/games/uhexen/pkg-plist
deleted file mode 100644
index c4b4999ec93f..000000000000
--- a/games/uhexen/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-bin/uhexen
-%%DATADIR%%/.keep_me
-%%WAD%%%%DATADIR%%/hexen.wad
-@dirrm %%DATADIR%%