aboutsummaryrefslogtreecommitdiff
path: root/games/utserver
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-10-17 18:15:53 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-10-17 18:15:53 +0000
commita20bc68a3c5c0f307c0ce5a394628c41f2f21702 (patch)
treeb907fd05e637a0eebb77823a740ebf5d10cd16ab /games/utserver
parent3012f71783a195f72a743621b6fba160582057b0 (diff)
downloadports-a20bc68a3c5c0f307c0ce5a394628c41f2f21702.tar.gz
ports-a20bc68a3c5c0f307c0ce5a394628c41f2f21702.zip
Notes
Diffstat (limited to 'games/utserver')
-rw-r--r--games/utserver/Makefile21
1 files changed, 19 insertions, 2 deletions
diff --git a/games/utserver/Makefile b/games/utserver/Makefile
index 0488a2e24201..e3d369ffc3a6 100644
--- a/games/utserver/Makefile
+++ b/games/utserver/Makefile
@@ -7,10 +7,17 @@
PORTNAME= utserver
PORTVERSION= 436
+PORTREVISION= 1
CATEGORIES= games linux
MASTER_SITES= ftp://utservers:idspispopd@ftp.lokigames.com/ \
- http://arcadia.inf.udec.cl/ftp/pub/linux/ut-server/
-DISTNAME= ut-server-${PORTVERSION}
+ http://arcadia.inf.udec.cl/ftp/pub/linux/ut-server/ \
+ http://ucc.sobservers.com/ \
+ http://game.dkm.cz/downloads/files/Unreal%20Tournament/ucc/
+DISTFILES= ut-server-${PORTVERSION}${EXTRACT_SUFX} \
+ DM-Curse%5D%5B.unr.uz \
+ DM-Deck16%5D%5B.unr.uz \
+ DM-Morbias%5D%5B.unr.uz
+EXTRACT_ONLY= ut-server-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= matuska@wu-wien.ac.at
@@ -31,6 +38,16 @@ SORT?= /usr/bin/sort
# files which should be installed with executable perms
EXECUTABLES= ucc ucc-bin
+post-extract:
+.for file in ${DISTFILES:S/${EXTRACT_ONLY}//}
+ @${SETENV} HOME=${WRKDIR} ${WRKSRC}/ucc decompress \
+ ${DISTDIR}/${file} >/dev/null
+.endfor
+.for file in ${DISTFILES:S/${EXTRACT_ONLY}//}
+ @${CP} -f "${WRKDIR}/.loki/ut/System/${file:R:S/%5D/]/:S/%5B/[/}" \
+ ${WRKSRC}/Maps
+.endfor
+
pre-patch:
# remove trailing ^M
@find -E ${WRKSRC} -type f \