aboutsummaryrefslogtreecommitdiff
path: root/games/vamos
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-06-18 12:20:16 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-06-18 12:20:16 +0000
commit113c8a18857ba28b28109cdbf6aa86ad2676e7eb (patch)
tree8bdeee7872590819b5d0b0fd0df213caba667b3e /games/vamos
parent562b10cf6a3a4fd259fd38e283b6049bfba913af (diff)
downloadports-113c8a18857ba28b28109cdbf6aa86ad2676e7eb.tar.gz
ports-113c8a18857ba28b28109cdbf6aa86ad2676e7eb.zip
Notes
Diffstat (limited to 'games/vamos')
-rw-r--r--games/vamos/Makefile24
-rw-r--r--games/vamos/distinfo6
-rw-r--r--games/vamos/pkg-plist9
3 files changed, 15 insertions, 24 deletions
diff --git a/games/vamos/Makefile b/games/vamos/Makefile
index ebb5b2df508e..f7bd717ac07c 100644
--- a/games/vamos/Makefile
+++ b/games/vamos/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= vamos
-PORTVERSION= 0.6.1
-PORTREVISION= 1
+PORTVERSION= 0.6.2
CATEGORIES= games
MASTER_SITES= SF
@@ -18,31 +17,22 @@ LIB_DEPENDS= alut.1:${PORTSDIR}/audio/freealut \
openal.0:${PORTSDIR}/audio/openal \
png.5:${PORTSDIR}/graphics/png
-USE_GNOME= gnometarget
USE_GL= glut
USE_SDL= sdl
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
- MAKEINFO="makeinfo --no-split"
-CONFIGURE_ARGS= ac_cv_header_boost_test_unit_test_hpp=no
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= ac_cv_header_boost_test_unit_test_hpp=no \
+ ac_cv_lib_freeglut_glutGetModifiers=no
USE_LDCONFIG= yes
INFO= vamos
-CPPFLAGS+= `pkg-config --cflags-only-I sdl freealut libpng12` \
- ${PTHREAD_CFLAGS}
-LDFLAGS= `pkg-config --libs-only-L sdl freealut libpng12` \
- ${PTHREAD_LIBS}
-
-post-extract:
- @${RM} -f ${WRKSRC}/doc/*.info*
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|-pedantic -O2 -g||g ; \
- s|libpng`|libpng12`|g'
- @${REINPLACE_CMD} -e 's|freeglut|glut|g ; \
- s|FREEGLUT|GLUT|g' ${WRKSRC}/configure
+ 's|-pedantic -O2 -g||g'
.include <bsd.port.mk>
diff --git a/games/vamos/distinfo b/games/vamos/distinfo
index 9700fca6472f..300d116f0ba3 100644
--- a/games/vamos/distinfo
+++ b/games/vamos/distinfo
@@ -1,3 +1,3 @@
-MD5 (vamos-0.6.1.tar.gz) = e5b4096f2b39d4e6ea89ac614b777166
-SHA256 (vamos-0.6.1.tar.gz) = 4fd15022e54a8ba136ba0957501a20f9e3a8fcbc418ae8ff414f35592655a51e
-SIZE (vamos-0.6.1.tar.gz) = 1545026
+MD5 (vamos-0.6.2.tar.gz) = 2935e5366c3f8e4ac311d113b3e93396
+SHA256 (vamos-0.6.2.tar.gz) = 75f539bcdd6fa6f0cf7cb4014d27f0cd8f581f8ff690b3054eb644e573bc3646
+SIZE (vamos-0.6.2.tar.gz) = 1555156
diff --git a/games/vamos/pkg-plist b/games/vamos/pkg-plist
index 700863142829..fc254196cfd6 100644
--- a/games/vamos/pkg-plist
+++ b/games/vamos/pkg-plist
@@ -17,6 +17,7 @@ include/vamos/body/Suspension.h
include/vamos/body/Tire.h
include/vamos/body/Transmission.h
include/vamos/body/Wheel.h
+include/vamos/geometry/Circular_Buffer.h
include/vamos/geometry/Constants.h
include/vamos/geometry/Contact_Info.h
include/vamos/geometry/Conversions.h
@@ -25,8 +26,8 @@ include/vamos/geometry/Interpolator.h
include/vamos/geometry/Linear_Interpolator.h
include/vamos/geometry/Material.h
include/vamos/geometry/Numeric.h
-include/vamos/geometry/Rectangle.h
include/vamos/geometry/PID.h
+include/vamos/geometry/Rectangle.h
include/vamos/geometry/Spline.h
include/vamos/geometry/Three_Matrix.h
include/vamos/geometry/Three_Vector.h
@@ -41,12 +42,12 @@ include/vamos/track/Strip_Track.h
include/vamos/track/Track.h
include/vamos/world/Atmosphere.h
include/vamos/world/Controls.h
-include/vamos/world/Gl_World.h
-include/vamos/world/Sounds.h
-include/vamos/world/World.h
include/vamos/world/Driver.h
+include/vamos/world/Gl_World.h
include/vamos/world/Interactive_Driver.h
include/vamos/world/Robot_Driver.h
+include/vamos/world/Sounds.h
+include/vamos/world/World.h
lib/libvamos-body.a
lib/libvamos-body.la
lib/libvamos-body.so