aboutsummaryrefslogtreecommitdiff
path: root/games/vavoom/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-05-04 12:42:28 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-05-04 12:42:28 +0000
commit79e81fd27d4f69d6b2f8b5fa7be8903fc353c582 (patch)
tree5123c638d70883e39beacd62e4d38476e94af8f8 /games/vavoom/Makefile
parent40b78f69510308becadcda1402addd6fc64828c2 (diff)
downloadports-79e81fd27d4f69d6b2f8b5fa7be8903fc353c582.tar.gz
ports-79e81fd27d4f69d6b2f8b5fa7be8903fc353c582.zip
Notes
Diffstat (limited to 'games/vavoom/Makefile')
-rw-r--r--games/vavoom/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/games/vavoom/Makefile b/games/vavoom/Makefile
index 5c9021183745..572f30179734 100644
--- a/games/vavoom/Makefile
+++ b/games/vavoom/Makefile
@@ -6,15 +6,17 @@
#
PORTNAME= vavoom
-PORTVERSION= 1.15.3
+PORTVERSION= 1.17
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= v115_${PORTVERSION:E}_src
+DISTNAME= v${PORTVERSION:S/.//}_src
MAINTAINER= ip@doom.homeunix.org
COMMENT= Doom, Doom II, Heretic, Hexen and Strife source port
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
.ifdef (WITH_OPENAL)
LIB_DEPENDS+= openal.0:${PORTSDIR}/audio/openal
.endif
@@ -28,17 +30,14 @@ ALL_TARGET= all sv
ONLY_FOR_ARCHS= i386
EXTRACT_AFTER_ARGS= -d ${WRKSRC}
+MAKE_ARGS= "USE_SDL=1"
.ifdef (WITH_OPENAL)
-MAKE_ARGS= "USE_AL=1"
+MAKE_ARGS+= "USE_AL=1"
.endif
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
.ifndef (WITH_OPENAL)
pre-everything::
@${ECHO_CMD} "********************************************************************"
@@ -47,8 +46,11 @@ pre-everything::
.endif
post-patch:
- cd ${WRKSRC} && ${TR} -d '\r' <${WRKSRC}/fixunix.sh | ${SH}
- @${REINPLACE_CMD} -e 's|SDL\/||g' ${WRKSRC}/source/*.cpp
+ @${REINPLACE_CMD} -i '' -e 's|SDL\/||g' ${WRKSRC}/source/*.cpp
+.if ${OSVERSION} >= 502126
+ @${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|' ${WRKSRC}/utils/acc/parse.c \
+ ${WRKSRC}/utils/acc/strlist.c
+.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/Vavoom ${PREFIX}/bin