aboutsummaryrefslogtreecommitdiff
path: root/games/vavoom
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2006-01-02 09:26:41 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2006-01-02 09:26:41 +0000
commit9bb9b86420472d4836ea392eeb93c439fdfb06f3 (patch)
treea7dab706ae2532031f4165eba84eb5fe07d17299 /games/vavoom
parent924135a88e94d98699f490ef3ffcfb95399f7acc (diff)
downloadports-9bb9b86420472d4836ea392eeb93c439fdfb06f3.tar.gz
ports-9bb9b86420472d4836ea392eeb93c439fdfb06f3.zip
Notes
Diffstat (limited to 'games/vavoom')
-rw-r--r--games/vavoom/Makefile67
-rw-r--r--games/vavoom/distinfo5
-rw-r--r--games/vavoom/files/patch-configure.ac50
3 files changed, 90 insertions, 32 deletions
diff --git a/games/vavoom/Makefile b/games/vavoom/Makefile
index 0b06342dbd3d..2f8527a8aaf3 100644
--- a/games/vavoom/Makefile
+++ b/games/vavoom/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= vavoom
-PORTVERSION= 1.18
+PORTVERSION= 1.19
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -22,8 +22,11 @@ USE_REINPLACE= yes
USE_GMAKE= yes
USE_AUTOTOOLS= autoconf:259
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --with-sdl --with-opengl --without-openal
-CONFIGURE_ENV= "CXXFLAGS=${CXXFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
+CONFIGURE_ARGS= --with-sdl --with-opengl --without-openal --without-vorbis \
+ --without-libmad --without-mikmod --without-flac
+CONFIGURE_ENV= "CFLAGS=${CFLAGS} -I${LOCALBASE}/include" \
+ "CPPFLAGS=${CPPFLAGS} -I${LOCALBASE}/include" \
+ "CXXFLAGS=${CXXFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
"LDFLAGS=-L${LOCALBASE}/lib -L${X11BASE}/lib"
ALL_TARGET= all sv
USE_SDL= mixer sdl
@@ -46,11 +49,48 @@ OPENAL_CONFIG?= ${LOCALBASE}/bin/openal-config
WITH_OPENAL= yes
.endif
+.if exists(${LOCALBASE}/lib/libvorbis.so.3)
+WITH_VORBIS= yes
+.endif
+
+.if exists(${LOCALBASE}/lib/libmad.so.2)
+WITH_LIBMAD= yes
+.endif
+
+MIKMOD_CONFIG?= ${LOCALBASE}/bin/libmikmod-config
+.if exists(${MIKMOD_CONFIG})
+WITH_MIKMOD= yes
+.endif
+
+.if exists(${LOCALBASE}/lib/libFLAC.so.7)
+WITH_FLAC= yes
+.endif
+
.ifdef (WITH_OPENAL)
CONFIGURE_ARGS+= --with-openal
LIB_DEPENDS+= openal.0:${PORTSDIR}/audio/openal
.endif
+.ifdef (WITH_VORBIS)
+CONFIGURE_ARGS+= --with-vorbis
+LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
+.endif
+
+.ifdef (WITH_LIBMAD)
+CONFIGURE_ARGS+= --with-libmad
+LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
+.endif
+
+.ifdef (WITH_MIKMOD)
+CONFIGURE_ARGS+= --with-mikmod
+LIB_DEPENDS+= mikmod.2:${PORTSDIR}/audio/libmikmod
+.endif
+
+.ifdef (WITH_FLAC)
+CONFIGURE_ARGS+= --with-flac
+LIB_DEPENDS+= FLAC.7:${PORTSDIR}/audio/flac
+.endif
+
# -fno-strict-aliasing (default on FreeBSD 6.0+) produces run-working
# code for `vcc', so use a more conservative setting here
.if (${OSVERSION} >= 600000)
@@ -61,7 +101,19 @@ CXXFLAGS= -O -pipe
pre-everything::
@${ECHO_CMD} ""
.ifndef (WITH_OPENAL)
- @${ECHO_CMD} "Define WITH_OPENAL=yes to build Vavoom with 3D sound support"
+ @${ECHO_CMD} "Define WITH_OPENAL=yes to build with 3D sound support"
+.endif
+.ifndef (WITH_VORBIS)
+ @${ECHO_CMD} "Define WITH_VORBIS=yes to build with Vorbis support"
+.endif
+.ifndef (WITH_LIBMAD)
+ @${ECHO_CMD} "Define WITH_LIBMAD=yes to build MP3 music support"
+.endif
+.ifndef (WITH_MIKMOD)
+ @${ECHO_CMD} "Define WITH_MIKMOD=yes to build with MikMod support"
+.endif
+.ifndef (WITH_FLAC)
+ @${ECHO_CMD} "Define WITH_FLAC=yes to build with FLAC support"
.endif
.ifndef (WITH_OPTIMIZED_CFLAGS)
@${ECHO_CMD} "Define WITH_OPTIMIZED_CFLAGS=yes to build Vavoom optimized for speed"
@@ -73,7 +125,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|' \
${WRKSRC}/utils/acc/parse.c ${WRKSRC}/utils/acc/strlist.c
@${REINPLACE_CMD} -e 's|%%SDL_CONFIG%%|${SDL_CONFIG}|g; \
- s|%%OPENAL_CONFIG%%|${OPENAL_CONFIG}|g' ${WRKSRC}/configure.ac
+ s|%%OPENAL_CONFIG%%|${OPENAL_CONFIG}|g; \
+ s|%%MIKMOD_CONFIG%%|${MIKMOD_CONFIG}|g' ${WRKSRC}/configure.ac
@(cd ${WRKSRC} && ${SH} ./fixunix.sh)
do-install:
@@ -109,11 +162,11 @@ do-install:
# required symlinks in users home directory. This should be done only once.
installuser:
cd ${DATADIR} && \
- ${FIND} . -type d -exec ${MKDIR} -p ~/.${PORTNAME}/{} \; && \
+ ${FIND} . -type d -exec ${MKDIR} ~/.${PORTNAME}/{} \; && \
${FIND} . -type f -exec ${LN} -sf ${DATADIR}/{} ~/.${PORTNAME}/{} \;
.if exists(${DMDIR})
cd ${DMDIR} && \
- ${FIND} . -type d -exec ${MKDIR} -p ~/.${PORTNAME}/{} \; && \
+ ${FIND} . -type d -exec ${MKDIR} ~/.${PORTNAME}/{} \; && \
${FIND} . -type f -exec ${LN} -sf ${DMDIR}/{} ~/.${PORTNAME}/{} \;
.endif
diff --git a/games/vavoom/distinfo b/games/vavoom/distinfo
index 7f7f4e735315..0b26c44d9aa1 100644
--- a/games/vavoom/distinfo
+++ b/games/vavoom/distinfo
@@ -1,2 +1,3 @@
-MD5 (vavoom-1.18.tar.bz2) = 6b00ee3deebb0fb1f02a97dc344fc941
-SIZE (vavoom-1.18.tar.bz2) = 1816179
+MD5 (vavoom-1.19.tar.bz2) = 87aefcf5b7871461017f8c0999c9c45e
+SHA256 (vavoom-1.19.tar.bz2) = 98a205e4371f8acd9cecf73e26349e61157431d7bdb5a06c74bfc35490bd19eb
+SIZE (vavoom-1.19.tar.bz2) = 1896168
diff --git a/games/vavoom/files/patch-configure.ac b/games/vavoom/files/patch-configure.ac
index ab5b29c761b0..409fe22afdf3 100644
--- a/games/vavoom/files/patch-configure.ac
+++ b/games/vavoom/files/patch-configure.ac
@@ -1,6 +1,13 @@
---- configure.ac.orig Fri Apr 29 02:07:06 2005
-+++ configure.ac Mon Dec 12 15:00:03 2005
-@@ -82,7 +82,7 @@
+--- configure.ac.orig
++++ configure.ac
+@@ -77,13 +77,13 @@
+ MAIN_EXE='Vavoom$(EXEEXT)'
+
+ if test "x$with_allegro" = "xyes"; then
+- AC_PATH_PROG([allegro_config], [allegro-config])
++ AC_PATH_PROG([allegro_config], [allegro-config], [%%ALLEGRO_CONFIG%%])
+ if test "x$allegro_config" = "x"; then
+ AC_MSG_ERROR(['cannot find Allegro instalation'])
fi
else
if test "x$with_sdl" = "xyes"; then
@@ -9,12 +16,18 @@
if test "x$sdl_config" = "x"; then
AC_MSG_ERROR(['cannot find SDL instalation'])
fi
-@@ -104,14 +104,14 @@
+@@ -100,19 +100,19 @@
+ if test "x$allegro_config" != "x"; then
+ MAIN_PLATFORM='UNIX_ALLEGRO'
+ MAIN_CFLAGS="`${allegro_config} --cflags`"
+- MAIN_LIBS="`${allegro_config} --libs` -lpng -lz -lm -lstdc++"
++ MAIN_LIBS="`${allegro_config} --libs` -lpng -lz -lm -lstdc++ -liconv"
+ else
if test "x$sdl_config" != "x"; then
MAIN_PLATFORM='UNIX_SDL'
MAIN_CFLAGS="`${sdl_config} --cflags`"
- MAIN_LIBS="-lSDL_mixer `${sdl_config} --libs` -lpng -lz -lm -lstdc++"
-+ MAIN_LIBS="-lSDL_mixer `${sdl_config} --libs` -lpng -liconv -lz -lm -lstdc++"
++ MAIN_LIBS="-lSDL_mixer `${sdl_config} --libs` -lpng -lz -lm -lstdc++ -liconv"
fi
fi
OBJ_FILES="$OBJ_FILES \$(SYS_OBJS_${MAIN_PLATFORM})"
@@ -24,23 +37,14 @@
- ], [AC_CHECK_HEADER([sys/cdrom.h], [
+ ], [AC_CHECK_HEADER([sys/cdio.h], [
OBJ_FILES="$OBJ_FILES \$(CDAUDIO_OBJ_BSD)"
- ], [
- OBJ_FILES="$OBJ_FILES \$(CDAUDIO_OBJ_NONE)"
-@@ -126,7 +126,7 @@
- fi
-
- if test "x$with_openal" != "xno"; then
-- AC_PATH_PROG([openal_config], [openal-config])
-+ AC_PATH_PROG([openal_config], [openal-config], [%%OPENAL_CONFIG%%])
- if test "x$openal_config" != "x"; then
- OBJ_FILES="$OBJ_FILES \$(AL_OBJS)"
- MAIN_CFLAGS="$MAIN_CFLAGS `$openal_config --cflags`"
-@@ -136,7 +136,7 @@
+ ])])
- SERVER_EXE='VavoomSV$(EXEEXT)'
- SV_OBJ_FILES='$(SV_COMMON_OBJ_FILES) $(SV_SYS_OBJS_UNIX)'
-- SV_LIBS='-lm -lstdc++'
-+ SV_LIBS='-lm -lstdc++ -lz'
- ;;
- esac
+@@ -166,7 +166,7 @@
+ AC_ARG_WITH([mikmod], AS_HELP_STRING([--with-mikmod], [Enable MikMod support]))
+ if test "x$with_mikmod" != "xno"; then
+- AC_PATH_PROG([LIBMIKMOD_CONFIG], [libmikmod-config])
++ AC_PATH_PROG([LIBMIKMOD_CONFIG], [libmikmod-config], [%%MIKMOD_CONFIG%%])
+ if test "x$LIBMIKMOD_CONFIG" != "x"; then
+ OBJ_FILES="$OBJ_FILES \$(MIKMOD_OBJS)"
+ MAIN_CFLAGS="$MAIN_CFLAGS `$LIBMIKMOD_CONFIG --cflags`"