aboutsummaryrefslogtreecommitdiff
path: root/games/vavoom
diff options
context:
space:
mode:
authorBarbara Guida <bar@FreeBSD.org>2017-06-04 15:10:58 +0000
committerBarbara Guida <bar@FreeBSD.org>2017-06-04 15:10:58 +0000
commit4b34374da4bff79300841b222e8f693ac76cc2d6 (patch)
treea2db3be58a1d0766031bf8b20763ac3f360242c8 /games/vavoom
parent85ee08557394395cf4ae8cd8afbaabd679b331f0 (diff)
downloadports-4b34374da4bff79300841b222e8f693ac76cc2d6.tar.gz
ports-4b34374da4bff79300841b222e8f693ac76cc2d6.zip
Notes
Diffstat (limited to 'games/vavoom')
-rw-r--r--games/vavoom/Makefile22
-rw-r--r--games/vavoom/files/patch-libs_core_zone.cpp16
-rw-r--r--games/vavoom/files/patch-libs_core_zone.h98
-rw-r--r--games/vavoom/files/patch-source_host.cpp9
-rw-r--r--games/vavoom/files/patch-source_misc.cpp20
-rw-r--r--games/vavoom/files/patch-source_pr__exec.cpp11
-rw-r--r--games/vavoom/files/patch-source_r__sky.cpp53
-rw-r--r--games/vavoom/files/patch-source_sys__sdl.cpp11
-rw-r--r--games/vavoom/files/patch-source_timidity_readmidi.cpp11
-rw-r--r--games/vavoom/files/patch-source_vc__dehacked.cpp22
-rw-r--r--games/vavoom/files/patch-source_vc__object.cpp17
-rw-r--r--games/vavoom/files/patch-utils_glbsp_CMakeLists.txt11
-rw-r--r--games/vavoom/files/patch-utils_vcc_vcc.cpp11
-rw-r--r--games/vavoom/files/pkg-message.in2
-rw-r--r--games/vavoom/pkg-plist2
15 files changed, 300 insertions, 16 deletions
diff --git a/games/vavoom/Makefile b/games/vavoom/Makefile
index ec00f85839cf..593a867e2c68 100644
--- a/games/vavoom/Makefile
+++ b/games/vavoom/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vavoom
PORTVERSION= 1.33
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Vavoom-source/${PORTVERSION}
@@ -15,16 +15,11 @@ LICENSE= GPLv2
LIB_DEPENDS= libpng.so:graphics/png
USES= cmake dos2unix jpeg tar:bzip2
-# Force GCC because llvm (starting from 4.0) generates
-# non working binary for vcc
-USE_GCC= yes
DOS2UNIX_REGEX= ((.*\.(c|cpp|h|s|asm|inc|vc|ls|acs|cfg|txt|vs|mak|mgw"))$$|\/(makefile\..*|makefile|Makefile)$$)
-# Removed LAUNCHER because it segfaults
-#OPTIONS_DEFINE= FLAC LAUNCHER MAD MIKMOD OPENAL OPTIMIZED_CFLAGS VORBIS SDL DOCS
-OPTIONS_DEFINE= FLAC MAD MIKMOD OPENAL OPTIMIZED_CFLAGS VORBIS SDL DOCS
+OPTIONS_DEFINE= FLAC LAUNCHER MAD MIKMOD OPENAL OPTIMIZED_CFLAGS VORBIS SDL DOCS
OPTIONS_DEFAULT= OPENGL SDL
-#LAUNCHER_DESC= Build GUI launcher
+LAUNCHER_DESC= Build GUI launcher
OPENAL_DESC= Enable OpenAL support
SDL_DESC= Use SDL for OpenGL support
@@ -41,13 +36,10 @@ FLAC_LIB_DEPENDS= libFLAC.so:audio/flac
FLAC_CMAKE_ON= -DWITH_FLAC:BOOL=ON
FLAC_CMAKE_OFF= -DWITH_FLAC:BOOL=OFF
-# Removed LAUNCHER because it segfaults - check also pkg-plist
-#LAUNCHER_USE= WX=2.8+
-#LAUNCHER_CMAKE_ON= -DENABLE_LAUNCHER:BOOL=ON \
-# -DwxWidgets_CONFIG_EXECUTABLE="${WX_CONFIG}"
-#LAUNCHER_CMAKE_OFF= -DENABLE_LAUNCHER:BOOL=OFF
-# Force disable LAUNCHER
-CMAKE_ARGS+= -DENABLE_LAUNCHER:BOOL=OFF
+LAUNCHER_USE= WX=2.8+
+LAUNCHER_CMAKE_ON= -DENABLE_LAUNCHER:BOOL=ON \
+ -DwxWidgets_CONFIG_EXECUTABLE="${WX_CONFIG}"
+LAUNCHER_CMAKE_OFF= -DENABLE_LAUNCHER:BOOL=OFF
MAD_LIB_DEPENDS= libmad.so:audio/libmad
MAD_CMAKE_ON= -DWITH_LIBMAD:BOOL=ON
diff --git a/games/vavoom/files/patch-libs_core_zone.cpp b/games/vavoom/files/patch-libs_core_zone.cpp
new file mode 100644
index 000000000000..4b537a9c6fb0
--- /dev/null
+++ b/games/vavoom/files/patch-libs_core_zone.cpp
@@ -0,0 +1,16 @@
+--- libs/core/zone.cpp.orig 2017-06-04 12:56:34.206304000 +0200
++++ libs/core/zone.cpp 2017-06-04 13:02:53.920038000 +0200
+@@ -33,6 +33,8 @@
+
+ #include "core.h"
+
++#if 0
++
+ // MACROS ------------------------------------------------------------------
+
+ #define SMALLID 0x22
+@@ -516,3 +518,4 @@
+ }
+
+ #endif
++#endif
diff --git a/games/vavoom/files/patch-libs_core_zone.h b/games/vavoom/files/patch-libs_core_zone.h
new file mode 100644
index 000000000000..c4a9a46cafb8
--- /dev/null
+++ b/games/vavoom/files/patch-libs_core_zone.h
@@ -0,0 +1,98 @@
+--- libs/core/zone.h.orig 2017-06-04 12:56:34.206722000 +0200
++++ libs/core/zone.h 2017-06-04 13:08:27.959596000 +0200
+@@ -27,88 +27,21 @@
+ //**
+ //**************************************************************************
+
+-//#define ZONE_DEBUG 1
+-
+ void Z_Shutdown();
+
+-#ifdef ZONE_DEBUG
+-
+-void* Z_Malloc(int size, const char* FileName, int LineNumber);
+-void* Z_Calloc(int size, const char* FileName, int LineNumber);
+-void Z_Free(void* ptr, const char* FileName, int LineNumber);
+-
+-inline void* operator new(size_t Size, const char* FileName, int LineNumber)
+-{
+- return Z_Malloc(Size, FileName, LineNumber);
+-}
+-
+-inline void operator delete(void* Ptr, const char* FileName, int LineNumber)
+-{
+- Z_Free(Ptr, FileName, LineNumber);
+-}
+-
+-inline void* operator new[](size_t Size, const char* FileName, int LineNumber)
+-{
+- return Z_Malloc(Size, FileName, LineNumber);
+-}
+-
+-inline void operator delete[](void* Ptr, const char* FileName, int LineNumber)
+-{
+- Z_Free(Ptr, FileName, LineNumber);
+-}
+-
+-inline void* operator new(size_t Size)
+-{
+- return Z_Malloc(Size, "", 0);
+-}
+-
+-inline void operator delete(void* Ptr)
+-{
+- Z_Free(Ptr, "", 0);
+-}
+-
+-inline void* operator new[](size_t Size)
+-{
+- return Z_Malloc(Size, "", 0);
+-}
+-
+-inline void operator delete[](void* Ptr)
+-{
+- Z_Free(Ptr, "", 0);
+-}
+-
+-#define Z_Malloc(size) Z_Malloc(size, __FILE__, __LINE__)
+-#define Z_Calloc(size) Z_Calloc(size, __FILE__, __LINE__)
+-#define Z_Free(ptr) Z_Free(ptr, __FILE__, __LINE__)
+-
+-#define ZONE_DEBUG_NEW new(__FILE__, __LINE__)
+-#undef new
+-#define new ZONE_DEBUG_NEW
+-
+-#else
+-
+-void* Z_Malloc(int size);
+-void* Z_Calloc(int size);
+-void Z_Free(void* ptr);
+-
+-inline void* operator new(size_t Size)
+-{
+- return Z_Malloc(int(Size));
+-}
+-
+-inline void operator delete(void* Ptr)
++static inline void* Z_Malloc(int size)
+ {
+- Z_Free(Ptr);
++ return static_cast<void *>(operator new(size));
+ }
+
+-inline void* operator new[](size_t Size)
++static inline void* Z_Calloc(int size)
+ {
+- return Z_Malloc(int(Size));
++ return memset(Z_Malloc(size), 0, size);
+ }
+
+-inline void operator delete[](void* Ptr)
++static inline void Z_Free(void* ptr)
+ {
+- Z_Free(Ptr);
++ char *p = (char *)ptr;
++ delete p;
+ }
+
+-#endif
diff --git a/games/vavoom/files/patch-source_host.cpp b/games/vavoom/files/patch-source_host.cpp
new file mode 100644
index 000000000000..eeae0251bba0
--- /dev/null
+++ b/games/vavoom/files/patch-source_host.cpp
@@ -0,0 +1,9 @@
+--- source/host.cpp.orig 2017-06-04 12:56:34.440473000 +0200
++++ source/host.cpp 2017-06-04 13:10:16.524114000 +0200
+@@ -706,5 +706,5 @@
+
+ SAFE_SHUTDOWN(VObject::StaticExit, ())
+ SAFE_SHUTDOWN(VName::StaticExit, ())
+- SAFE_SHUTDOWN(Z_Shutdown, ())
++// SAFE_SHUTDOWN(Z_Shutdown, ())
+ }
diff --git a/games/vavoom/files/patch-source_misc.cpp b/games/vavoom/files/patch-source_misc.cpp
new file mode 100644
index 000000000000..339813351dac
--- /dev/null
+++ b/games/vavoom/files/patch-source_misc.cpp
@@ -0,0 +1,20 @@
+--- source/misc.cpp.orig 2010-09-01 20:26:05.000000000 +0200
++++ source/misc.cpp 2017-06-04 09:42:27.118366000 +0200
+@@ -119,7 +119,7 @@
+
+ void VLogSysError::Serialise(const char* V, EName)
+ {
+- Sys_Error(V);
++ Sys_Error("%s", V);
+ }
+
+ //==========================================================================
+@@ -130,7 +130,7 @@
+
+ void VLogHostError::Serialise(const char* V, EName)
+ {
+- Host_Error(V);
++ Host_Error("%s", V);
+ }
+
+ //==========================================================================
diff --git a/games/vavoom/files/patch-source_pr__exec.cpp b/games/vavoom/files/patch-source_pr__exec.cpp
new file mode 100644
index 000000000000..99564ee4cce0
--- /dev/null
+++ b/games/vavoom/files/patch-source_pr__exec.cpp
@@ -0,0 +1,11 @@
+--- source/pr_exec.cpp.orig 2010-06-04 23:20:21.000000000 +0200
++++ source/pr_exec.cpp 2017-06-04 10:26:40.272597000 +0200
+@@ -1112,7 +1112,7 @@
+ {
+ Sys_Error("Division by 0");
+ }
+- BINOP(i, /=);
++ BINOP_Q(i, /=);
+ PR_VM_BREAK;
+
+ PR_VM_CASE(OPC_Modulus)
diff --git a/games/vavoom/files/patch-source_r__sky.cpp b/games/vavoom/files/patch-source_r__sky.cpp
new file mode 100644
index 000000000000..f63da1bc152e
--- /dev/null
+++ b/games/vavoom/files/patch-source_r__sky.cpp
@@ -0,0 +1,53 @@
+--- source/r_sky.cpp.orig 2017-06-04 15:57:26.347510000 +0200
++++ source/r_sky.cpp 2017-06-04 16:05:26.710124000 +0200
+@@ -223,9 +223,9 @@
+ s.surf.verts[0] = TVec(cosa0 * vradius, sina0 * vradius, bheight);
+ s.surf.verts[1] = TVec(cosa0 * tradius, sina0 * tradius, theight);
+ s.surf.verts[2] = TVec(cosa1 * tradius, sina1 * tradius, theight);
+- s.surf.verts[3] = TVec(cosa1 * vradius, sina1 * vradius, bheight);
++ s.plane.normal = TVec(cosa1 * vradius, sina1 * vradius, bheight);
+
+- TVec hdir = j < VDIVS / 2 ? s.surf.verts[3] - s.surf.verts[0] :
++ TVec hdir = j < VDIVS / 2 ? s.plane.normal - s.surf.verts[0] :
+ s.surf.verts[2] - s.surf.verts[1];
+ TVec vdir = s.surf.verts[0] - s.surf.verts[1];
+ TVec normal = Normalise(CrossProduct(vdir, hdir));
+@@ -336,32 +336,32 @@
+ sky[0].surf.verts[0] = TVec(128, 128, -128);
+ sky[0].surf.verts[1] = TVec(128, 128, 128);
+ sky[0].surf.verts[2] = TVec(128, -128, 128);
+- sky[0].surf.verts[3] = TVec(128, -128, -128);
++ sky[0].plane.normal = TVec(128, -128, -128);
+
+ sky[1].surf.verts[0] = TVec(128, -128, -128);
+ sky[1].surf.verts[1] = TVec(128, -128, 128);
+ sky[1].surf.verts[2] = TVec(-128, -128, 128);
+- sky[1].surf.verts[3] = TVec(-128, -128, -128);
++ sky[1].plane.normal = TVec(-128, -128, -128);
+
+ sky[2].surf.verts[0] = TVec(-128, -128, -128);
+ sky[2].surf.verts[1] = TVec(-128, -128, 128);
+ sky[2].surf.verts[2] = TVec(-128, 128, 128);
+- sky[2].surf.verts[3] = TVec(-128, 128, -128);
++ sky[2].plane.normal = TVec(-128, 128, -128);
+
+ sky[3].surf.verts[0] = TVec(-128, 128, -128);
+ sky[3].surf.verts[1] = TVec(-128, 128, 128);
+ sky[3].surf.verts[2] = TVec(128, 128, 128);
+- sky[3].surf.verts[3] = TVec(128, 128, -128);
++ sky[3].plane.normal = TVec(128, 128, -128);
+
+ sky[4].surf.verts[0] = TVec(128.0, 128.0, 128);
+ sky[4].surf.verts[1] = TVec(-128.0, 128.0, 128);
+ sky[4].surf.verts[2] = TVec(-128.0, -128.0, 128);
+- sky[4].surf.verts[3] = TVec(128.0, -128.0, 128);
++ sky[4].plane.normal = TVec(128.0, -128.0, 128);
+
+ sky[5].surf.verts[0] = TVec(128, 128, -128);
+ sky[5].surf.verts[1] = TVec(128, -128, -128);
+ sky[5].surf.verts[2] = TVec(-128, -128, -128);
+- sky[5].surf.verts[3] = TVec(-128, 128, -128);
++ sky[5].plane.normal = TVec(-128, 128, -128);
+
+ sky[0].plane.Set(TVec(-1, 0, 0), -128);
+ sky[0].texinfo.saxis = TVec(0, -1.0, 0);
diff --git a/games/vavoom/files/patch-source_sys__sdl.cpp b/games/vavoom/files/patch-source_sys__sdl.cpp
new file mode 100644
index 000000000000..6df0163ae6c3
--- /dev/null
+++ b/games/vavoom/files/patch-source_sys__sdl.cpp
@@ -0,0 +1,11 @@
+--- source/sys_sdl.cpp.orig 2017-06-04 12:56:34.438609000 +0200
++++ source/sys_sdl.cpp 2017-06-04 13:11:31.567597000 +0200
+@@ -530,7 +530,7 @@
+ catch (VavoomError &e)
+ {
+ Host_Shutdown();
+- stack_trace();
++// stack_trace();
+
+ printf("\n%s\n", e.message);
+ dprintf("\n\nERROR: %s\n", e.message);
diff --git a/games/vavoom/files/patch-source_timidity_readmidi.cpp b/games/vavoom/files/patch-source_timidity_readmidi.cpp
new file mode 100644
index 000000000000..ec52733effa4
--- /dev/null
+++ b/games/vavoom/files/patch-source_timidity_readmidi.cpp
@@ -0,0 +1,11 @@
+--- source/timidity/readmidi.cpp.orig 2017-06-04 15:57:26.317968000 +0200
++++ source/timidity/readmidi.cpp 2017-06-04 16:07:48.260735000 +0200
+@@ -569,7 +569,7 @@
+ int32 len, divisions;
+ int16 format, tracks, divisions_tmp;
+ int i;
+- char tmp[4];
++ char tmp[12];
+
+ song->midi_image = (uint8*)mimage;
+ song->image_left = msize;
diff --git a/games/vavoom/files/patch-source_vc__dehacked.cpp b/games/vavoom/files/patch-source_vc__dehacked.cpp
new file mode 100644
index 000000000000..5a953910111d
--- /dev/null
+++ b/games/vavoom/files/patch-source_vc__dehacked.cpp
@@ -0,0 +1,22 @@
+--- source/vc_dehacked.cpp.orig 2017-06-04 08:35:41.777968000 +0200
++++ source/vc_dehacked.cpp 2017-06-04 09:13:52.864992000 +0200
+@@ -128,8 +128,8 @@
+ { 0, "TRANSLUC75", 0x20000000 },
+ { 0, "STEALTH", 0x40000000 },
+ { 0, "UNUSED4", 0x40000000 },
+- { 0, "TRANSLUCENT", 0x80000000 },
+- { 0, "TRANSLUC50", 0x80000000 },
++ { 0, "TRANSLUCENT", (int)0x80000000 },
++ { 0, "TRANSLUC50", (int)0x80000000 },
+ { 1, "LOGRAV", 0x00000001 },
+ { 1, "WINDTHRUST", 0x00000002 },
+ { 1, "FLOORBOUNCE", 0x00000004 },
+@@ -161,7 +161,7 @@
+ { 1, "DORMANT", 0x10000000 },
+ { 1, "ICEDAMAGE", 0x20000000 },
+ { 1, "SEEKERMISSILE", 0x40000000 },
+- { 1, "REFLECTIVE", 0x80000000 },
++ { 1, "REFLECTIVE", (int)0x80000000 },
+ // Ignored flags
+ { 0, "SLIDE", 0 },
+ { 0, "UNUSED2", 0 },
diff --git a/games/vavoom/files/patch-source_vc__object.cpp b/games/vavoom/files/patch-source_vc__object.cpp
new file mode 100644
index 000000000000..51695fd1584d
--- /dev/null
+++ b/games/vavoom/files/patch-source_vc__object.cpp
@@ -0,0 +1,17 @@
+--- source/vc_object.cpp.orig 2010-06-04 23:20:21.000000000 +0200
++++ source/vc_object.cpp 2017-06-04 09:43:20.120992000 +0200
+@@ -477,12 +477,12 @@
+
+ IMPLEMENT_FUNCTION(VObject, Error)
+ {
+- Host_Error(*PF_FormatString());
++ Host_Error("%s", *PF_FormatString());
+ }
+
+ IMPLEMENT_FUNCTION(VObject, FatalError)
+ {
+- Sys_Error(*PF_FormatString());
++ Sys_Error("%s", *PF_FormatString());
+ }
+
+ //**************************************************************************
diff --git a/games/vavoom/files/patch-utils_glbsp_CMakeLists.txt b/games/vavoom/files/patch-utils_glbsp_CMakeLists.txt
new file mode 100644
index 000000000000..57ffcf93fa6b
--- /dev/null
+++ b/games/vavoom/files/patch-utils_glbsp_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- utils/glbsp/CMakeLists.txt.orig 2017-06-04 12:56:34.555084000 +0200
++++ utils/glbsp/CMakeLists.txt 2017-06-04 13:15:12.279215000 +0200
+@@ -1,7 +1,7 @@
+ include_directories(${ZLIB_INCLUDE_DIR})
+ add_definitions(-DGLBSP_PLUGIN -DUNIX -DINLINE_G=inline)
+
+-add_library(glbsp
++add_library(glbsp STATIC
+ analyze.c
+ analyze.h
+ blockmap.c
diff --git a/games/vavoom/files/patch-utils_vcc_vcc.cpp b/games/vavoom/files/patch-utils_vcc_vcc.cpp
new file mode 100644
index 000000000000..1b63d5f0f8d7
--- /dev/null
+++ b/games/vavoom/files/patch-utils_vcc_vcc.cpp
@@ -0,0 +1,11 @@
+--- utils/vcc/vcc.cpp.orig 2017-06-04 09:44:06.817573000 +0200
++++ utils/vcc/vcc.cpp 2017-06-04 10:05:59.278454000 +0200
+@@ -122,7 +122,7 @@
+ }
+ catch (VException& e)
+ {
+- FatalError(e.What());
++ FatalError("%s", e.What());
+ }
+ return 0;
+ }
diff --git a/games/vavoom/files/pkg-message.in b/games/vavoom/files/pkg-message.in
index dae4d5f59f8b..0106dd7266b4 100644
--- a/games/vavoom/files/pkg-message.in
+++ b/games/vavoom/files/pkg-message.in
@@ -17,4 +17,6 @@ need VORBIS (build options).
Refer to %%DOCSDIR%%/vavoom.txt for other options such as
game selection, network options and so on.
+If you enabled LAUNCHER (build option), run "vlaunch" for a launcher GUI.
+
==============================================================================
diff --git a/games/vavoom/pkg-plist b/games/vavoom/pkg-plist
index 7f4b7c82ef1e..e5dc8faeec68 100644
--- a/games/vavoom/pkg-plist
+++ b/games/vavoom/pkg-plist
@@ -2,7 +2,7 @@ bin/vavoom
bin/vavoom.bin
bin/vavoom-dedicated
bin/vavoom-dedicated.bin
-@comment %%LAUNCHER%%bin/vlaunch
+%%LAUNCHER%%bin/vlaunch
%%PORTDOCS%%%%DOCSDIR%%/vavoom.txt
%%DATADIR%%/basev/common/basepak.pk3
%%DATADIR%%/basev/doom/basepak.pk3