aboutsummaryrefslogtreecommitdiff
path: root/games/vdrift
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-26 16:39:14 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-26 16:39:14 +0000
commitbc62127a69294fd3340ea793685953d98ff835dc (patch)
treed124c4d6f965d5152806ebfbf40e1b5a25860ddb /games/vdrift
parente8dd5f52410bdf2a989023706699373d47296008 (diff)
Notes
Diffstat (limited to 'games/vdrift')
-rw-r--r--games/vdrift/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/games/vdrift/Makefile b/games/vdrift/Makefile
index 40f9a00ebdb9..5e3a36bc9cf7 100644
--- a/games/vdrift/Makefile
+++ b/games/vdrift/Makefile
@@ -33,19 +33,18 @@ DATE_VERSION= 2010-06-30
SUB_FILES= pkg-message
-OPTIONS= DEBUG "Additional debug information" off \
- NLS "Internationalization support " on
+OPTIONS_DEFINE= DEBUG NLS DOCS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
SCONS_ARGS+= release=0
.else
SCONS_ARGS+= release=1
.endif
-.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
PLIST_SUB+= NLS=""
FLAG_NLS= true
.else
@@ -74,7 +73,7 @@ do-install:
${FIND} * -type f -name "*.po" -exec ${INSTALL_DATA} "{}" "${DATADIR}/po/{}" \;
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for FILE in docs/AUTHORS docs/README
${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
@@ -84,4 +83,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>