aboutsummaryrefslogtreecommitdiff
path: root/games/vectoroids
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-12-23 10:01:16 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-12-23 10:01:16 +0000
commitf5c3d25ee3d539dc0c1dcc408a5fba7c9ae0a552 (patch)
tree1ef8f19bbfec4f91962f58b539c9f3334daa23b3 /games/vectoroids
parenta3609ff41ad8891cf973b0c12a6661507ee73dda (diff)
downloadports-f5c3d25ee3d539dc0c1dcc408a5fba7c9ae0a552.tar.gz
ports-f5c3d25ee3d539dc0c1dcc408a5fba7c9ae0a552.zip
Notes
Diffstat (limited to 'games/vectoroids')
-rw-r--r--games/vectoroids/Makefile44
-rw-r--r--games/vectoroids/pkg-plist21
2 files changed, 39 insertions, 26 deletions
diff --git a/games/vectoroids/Makefile b/games/vectoroids/Makefile
index 1d5bc5b4a1e4..4ef522441cf1 100644
--- a/games/vectoroids/Makefile
+++ b/games/vectoroids/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vectoroids
PORTVERSION= 1.1.0
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= games
MASTER_SITES= ftp://ftp.tuxpaint.org/unix/x/vectoroids/src/ \
ftp://ftp.billsgames.com/unix/x/vectoroids/src/
@@ -13,37 +13,29 @@ COMMENT= Vector-based rock-shooting game similar to Asteroids
LICENSE= GPLv2
-USE_GMAKE= yes
+USES= gmake
USE_SDL= image mixer sdl
-PLIST_FILES= bin/${PORTNAME} \
- share/pixmaps/${PORTNAME}.png
+PORTDOCS= CHANGES.txt README.txt
-MAN6= ${PORTNAME}.6
+OPTIONS_DEFINE= DOCS
-PORTDATA= *
-PORTDOCS= CHANGES.txt README.txt
+DESKTOP_ENTRIES="Vectoroids" "" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" ""
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+post-patch:
+ @${FIND} ${WRKDIR} -name .xvpics | ${XARGS} ${RM} -rf
do-install:
-# Executable
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-
-# Data
- (cd ${WRKSRC}/data && ${COPYTREE_SHARE} "images music sounds" ${DATADIR})
-
-# Pixmaps
- ${INSTALL_DATA} ${WRKSRC}/data/images/icon.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
-
-# Documentation
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
-. for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-. endfor
-.endif
- ${INSTALL_MAN} ${WRKSRC}/${MAN6} ${MAN6PREFIX}/man/man6
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+.for d in images music sounds
+ @(cd ${WRKSRC}/data && ${COPYTREE_SHARE} ${d} ${STAGEDIR}${DATADIR})
+.endfor
+ ${LN} -sf ${DATADIR}/images/icon.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.6 ${STAGEDIR}${MAN6PREFIX}/man/man6/
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/games/vectoroids/pkg-plist b/games/vectoroids/pkg-plist
new file mode 100644
index 000000000000..a1fe7c8d6614
--- /dev/null
+++ b/games/vectoroids/pkg-plist
@@ -0,0 +1,21 @@
+bin/vectoroids
+man/man6/vectoroids.6.gz
+share/pixmaps/vectoroids.png
+%%DATADIR%%/images/icon.png
+%%DATADIR%%/images/redspot-e.bmp
+%%DATADIR%%/images/redspot.jpg
+%%DATADIR%%/music/decision.s3m
+%%DATADIR%%/music/decision.txt
+%%DATADIR%%/sounds/ast1.wav
+%%DATADIR%%/sounds/ast2.wav
+%%DATADIR%%/sounds/ast3.wav
+%%DATADIR%%/sounds/ast4.wav
+%%DATADIR%%/sounds/bullet.wav
+%%DATADIR%%/sounds/explode.wav
+%%DATADIR%%/sounds/extralife.wav
+%%DATADIR%%/sounds/gameover.wav
+%%DATADIR%%/sounds/thrust.wav
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%/music
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%