aboutsummaryrefslogtreecommitdiff
path: root/games/vectoroids
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-09-10 01:34:42 +0000
committerSteve Wills <swills@FreeBSD.org>2012-09-10 01:34:42 +0000
commit6eb0babadf4b6b6fbfe72a2fec7d4e816604b926 (patch)
treebc4de0d7afc27f85af3f9b0afdd63e631421f85d /games/vectoroids
parent4ccfe04bf0414712d34bc76d5a51ae272aa281fa (diff)
downloadports-6eb0babadf4b6b6fbfe72a2fec7d4e816604b926.tar.gz
ports-6eb0babadf4b6b6fbfe72a2fec7d4e816604b926.zip
Notes
Diffstat (limited to 'games/vectoroids')
-rw-r--r--games/vectoroids/Makefile49
-rw-r--r--games/vectoroids/files/patch-Makefile25
-rw-r--r--games/vectoroids/pkg-descr6
-rw-r--r--games/vectoroids/pkg-plist21
4 files changed, 38 insertions, 63 deletions
diff --git a/games/vectoroids/Makefile b/games/vectoroids/Makefile
index 73683d12277a..87a419fecc21 100644
--- a/games/vectoroids/Makefile
+++ b/games/vectoroids/Makefile
@@ -7,27 +7,46 @@
PORTNAME= vectoroids
PORTVERSION= 1.1.0
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= games
-MASTER_SITES= ftp://ftp.billsgames.com/unix/x/vectoroids/src/
+MASTER_SITES= ftp://ftp.tuxpaint.org/unix/x/vectoroids/src/ \
+ ftp://ftp.billsgames.com/unix/x/vectoroids/src/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A vector-based, pretty, Asteroids clone
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Vector-based rock-shooting game similar to Asteroids
+
+LICENSE= GPLv2
-USE_SDL= image mixer sdl
USE_GMAKE= yes
+USE_SDL= image mixer sdl
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/pixmaps/${PORTNAME}.png
+
+MAN6= ${PORTNAME}.6
+
+PORTDATA= *
+PORTDOCS= CHANGES.txt README.txt
+
+.include <bsd.port.options.mk>
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/vectoroids ${PREFIX}/bin
- @${MKDIR} ${DATADIR}/images
- ${INSTALL_DATA} ${WRKSRC}/data/images/* ${DATADIR}/images
- @${MKDIR} ${DATADIR}/music
- ${INSTALL_DATA} ${WRKSRC}/data/music/* ${DATADIR}/music
- @${MKDIR} ${DATADIR}/sounds
- ${INSTALL_DATA} ${WRKSRC}/data/sounds/* ${DATADIR}/sounds
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}/README
+# Executable
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+# Data
+ (cd ${WRKSRC}/data && ${COPYTREE_SHARE} "images music sounds" ${DATADIR})
+
+# Pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/data/images/icon.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
+
+# Documentation
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
.endif
+ ${INSTALL_MAN} ${WRKSRC}/${MAN6} ${MAN6PREFIX}/man/man6
.include <bsd.port.mk>
diff --git a/games/vectoroids/files/patch-Makefile b/games/vectoroids/files/patch-Makefile
index bf03fa628b3d..e69de29bb2d1 100644
--- a/games/vectoroids/files/patch-Makefile
+++ b/games/vectoroids/files/patch-Makefile
@@ -1,25 +0,0 @@
---- Makefile.orig Sun Apr 14 09:51:14 2002
-+++ Makefile Wed Aug 27 22:16:03 2003
-@@ -9,19 +9,18 @@
- # November 30, 2001 - April 13, 2002
-
-
--PREFIX=/usr/local
- MAN_PREFIX=$(PREFIX)
- BIN_PREFIX=$(PREFIX)/bin
- DATA_PREFIX=$(PREFIX)/share/vectoroids/
- JOY=YES
- TARGET_DEF=LINUX
--SDL_LIB=$(shell sdl-config --libs) $(MIXER) -lSDL_image
-+SDL_LIB=$(shell $(SDL_CONFIG) --libs) $(MIXER) -lSDL_image
-
- NOSOUNDFLAG=__SOUND
- MIXER=-lSDL_mixer
-
--CFLAGS=-Wall -Wno-long-long -pedantic -ansi -O2 \
-- $(shell sdl-config --cflags) -D$(NOSOUNDFLAG) \
-+CFLAGS+= \
-+ $(shell $(SDL_CONFIG) --cflags) -D$(NOSOUNDFLAG) \
- -DDATA_PREFIX=\"$(DATA_PREFIX)\" -DJOY_$(JOY) -D$(TARGET_DEF)
-
-
diff --git a/games/vectoroids/pkg-descr b/games/vectoroids/pkg-descr
index 4e9fbfcdd174..21d58595ce72 100644
--- a/games/vectoroids/pkg-descr
+++ b/games/vectoroids/pkg-descr
@@ -1,4 +1,6 @@
-Vectoroids is an SDL Asteroids clone, with quick game-play and pretty
-good graphics.
+Vectoroids is a vector-based rock-shooting game similar to the
+arcade classic "Asteroids". It is an SDL game based on the source for
+"Agendaroids", an X-Window game written for the Agenda VR3 Linux-based PDA
+written by the same author.
WWW: http://www.newbreedsoftware.com/vectoroids/
diff --git a/games/vectoroids/pkg-plist b/games/vectoroids/pkg-plist
deleted file mode 100644
index 8e236080f4da..000000000000
--- a/games/vectoroids/pkg-plist
+++ /dev/null
@@ -1,21 +0,0 @@
-bin/vectoroids
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%DATADIR%%/images/icon.png
-%%DATADIR%%/images/redspot-e.bmp
-%%DATADIR%%/images/redspot.jpg
-%%DATADIR%%/music/decision.s3m
-%%DATADIR%%/music/decision.txt
-%%DATADIR%%/sounds/ast1.wav
-%%DATADIR%%/sounds/ast2.wav
-%%DATADIR%%/sounds/ast3.wav
-%%DATADIR%%/sounds/ast4.wav
-%%DATADIR%%/sounds/bullet.wav
-%%DATADIR%%/sounds/explode.wav
-%%DATADIR%%/sounds/extralife.wav
-%%DATADIR%%/sounds/gameover.wav
-%%DATADIR%%/sounds/thrust.wav
-@dirrm %%DATADIR%%/sounds
-@dirrm %%DATADIR%%/music
-@dirrm %%DATADIR%%/images
-@dirrm %%DATADIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%