aboutsummaryrefslogtreecommitdiff
path: root/games/vegastrike
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-06-23 14:56:15 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-06-23 14:56:15 +0000
commit3e4a131b3ba43ff2b8daffdb94730ef9802362b3 (patch)
treeaff573f4e6d0a19c5b0a9e3215ffd9168da3bb2e /games/vegastrike
parent0da397f61ba439e9dd6ef320b59f808ad6f3b9fa (diff)
downloadports-3e4a131b3ba43ff2b8daffdb94730ef9802362b3.tar.gz
ports-3e4a131b3ba43ff2b8daffdb94730ef9802362b3.zip
Notes
Diffstat (limited to 'games/vegastrike')
-rw-r--r--games/vegastrike/Makefile26
-rw-r--r--games/vegastrike/files/patch-c++11
-rw-r--r--games/vegastrike/pkg-descr23
3 files changed, 34 insertions, 26 deletions
diff --git a/games/vegastrike/Makefile b/games/vegastrike/Makefile
index 765d1a2c3d1d..a23a94f2ae2e 100644
--- a/games/vegastrike/Makefile
+++ b/games/vegastrike/Makefile
@@ -5,13 +5,13 @@ PORTNAME= vegastrike
PORTVERSION= 0.5.1.r1
PORTREVISION= 2
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/0.5.1/
-DISTNAME= vegastrike-src-${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}/
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Opensource 3D space simulator
+MAINTAINER= games@FreeBSD.org
+COMMENT= Open source 3D space simulator
-BROKEN= Does not build with any modern compiler
+LICENSE= GPLv2
RUN_DEPENDS= ${DATADIR}/vegastrike.ico:${PORTSDIR}/games/vegastrike-data
LIB_DEPENDS= libboost_python.so:${PORTSDIR}/devel/boost-python-libs \
@@ -19,18 +19,19 @@ LIB_DEPENDS= libboost_python.so:${PORTSDIR}/devel/boost-python-libs \
libvorbis.so:${PORTSDIR}/audio/libvorbis \
libogg.so:${PORTSDIR}/audio/libogg
+USES= dos2unix gmake openal:al pkgconfig tar:bzip2
GNU_CONFIGURE= yes
-USES= dos2unix gmake openal:al tar:bzip2
USE_PYTHON= yes
USE_SDL= sdl
+USE_GL= glut
USE_XORG= sm ice xi x11 xext xrender xinerama xi xrandr xcursor \
xcomposite xdamage xfixes
-USE_GL= gl glu glut
USE_GNOME= gtk20
+DOS2UNIX_GLOB= *.cpp *.h
+EXTRACT_AFTER_ARGS= --exclude boost
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-DOS2UNIX_GLOB= *.cpp *.h
-EXTRACT_AFTER_ARGS+=--exclude boost
# cegui and ffmpeg are not used yet
CONFIGURE_ARGS= --disable-cegui --disable-ffmpeg \
@@ -39,7 +40,6 @@ CONFIGURE_ARGS= --disable-cegui --disable-ffmpeg \
--enable-flags="${CXXFLAGS}"
PLIST_FILES= bin/vegastrike bin/vssetup bin/vegaserver
-
PORTDOCS= README
OPTIONS_DEFINE= MESHER
@@ -50,13 +50,13 @@ MESHER_LIB_DEPENDS= libOgreMain.so:${PORTSDIR}/graphics/ogre3d
MESHER_CONFIGURE_ENABLE= ogre
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g; \
- s|/usr/X11R6|${LOCALBASE}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -E 's,/usr/(local|X11R6),${LOCALBASE},' \
+ ${WRKSRC}/configure
do-install:
${INSTALL_PROGRAM} ${PLIST_FILES:S|bin|${WRKSRC}|} \
${STAGEDIR}${PREFIX}/bin
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/games/vegastrike/files/patch-c++ b/games/vegastrike/files/patch-c++
index e826f119b35f..631203e46c87 100644
--- a/games/vegastrike/files/patch-c++
+++ b/games/vegastrike/files/patch-c++
@@ -31,3 +31,14 @@
+ static int hash_int( const double aye )
{
return ( (int) ( ( (aye < 0) ? (aye
+--- src/networking/lowlevel/packetmem.cpp.orig 2014-06-23 21:30:46 +0800
++++ src/networking/lowlevel/packetmem.cpp 2014-06-23 21:31:01 +0800
+@@ -102,7 +102,7 @@ void PacketMem::inner_set( void* buffer,
+ }
+ else
+ {
+- _buffer.reset( 0 );
++ _buffer.reset();
+ _len = 0;
+ }
+ }
diff --git a/games/vegastrike/pkg-descr b/games/vegastrike/pkg-descr
index 134b31956117..eb8107c71df9 100644
--- a/games/vegastrike/pkg-descr
+++ b/games/vegastrike/pkg-descr
@@ -1,15 +1,12 @@
-Vega Strike is an OpenSource 3d Space Simulator. Work is proceeding
-on both the Vega Strike game engine and a Vega Strike Universe game
-data set. Both engine and data are in a playable state, but still
-under development. Each release serves as a beta for both engine
-and data.
+Vega Strike is an open source, 3D space simulator. Work is proceeding on
+both the Vega Strike game engine and a Vega Strike Universe game data set.
+Both engine and data are in a playable state, but still under development.
+Each release serves as a beta for both engine and data. Current features
+include:
-The project goal is, at version 1.0, is to be a generic space
-simulator. Currently developed features include:
+ * Trading
+ * Exploration
+ * Plenty of shoot 'em up action
+ * Preliminary multiplayer deathmatch (testing server only)
-* Trading
-* Exploration
-* Plenty of shoot 'em up action
-* Preliminary multiplayer Deathmatch (testing server only)
-
-WWW: http://vegastrike.sourceforge.net
+WWW: http://vegastrike.sourceforge.net/