aboutsummaryrefslogtreecommitdiff
path: root/games/violetland/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2012-12-04 12:40:23 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2012-12-04 12:40:23 +0000
commitc63c9e562f968450bd464eba0d696917059947b9 (patch)
tree86d669e34285cfe51e47c9f728bfb34bce23b287 /games/violetland/Makefile
parent3bc660551fd548306ef27a1f751578d0c442780a (diff)
downloadports-c63c9e562f968450bd464eba0d696917059947b9.tar.gz
ports-c63c9e562f968450bd464eba0d696917059947b9.zip
Notes
Diffstat (limited to 'games/violetland/Makefile')
-rw-r--r--games/violetland/Makefile29
1 files changed, 16 insertions, 13 deletions
diff --git a/games/violetland/Makefile b/games/violetland/Makefile
index 03f44fca06c8..bf5020a0cf29 100644
--- a/games/violetland/Makefile
+++ b/games/violetland/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: violetland
-# Date created: 25 Oct 2009
-# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
-#
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= violetland
-PORTVERSION= 0.4.1
-PORTREVISION= 2
+PORTVERSION= 0.4.3
CATEGORIES= games
MASTER_SITES= GOOGLE_CODE \
http://mirror.amdmi3.ru/distfiles/
@@ -28,15 +23,23 @@ CMAKE_ARGS= -DDATA_INSTALL_DIR="${DATADIR}"
WRKSRC= ${WRKDIR}/${PORTNAME}-v${PORTVERSION}
-DESKTOP_ENTRIES="Violetland" \
- "Top-down survival shoot 'em up" \
- "${DATADIR}/icon-light.png" \
- "violetland" \
- "Game;ArcadeGame;" \
- false
+PORTDOCS= CHANGELOG README_EN.TXT README_RU.TXT
+
+
+.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e '/set.libList/ s|)| ${LOCALBASE}/lib/libintl.so&|' \
${WRKSRC}/CMakeLists.txt
+post-install:
+ ${MKDIR} ${DESKTOPDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${DESKTOPDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
.include <bsd.port.mk>