aboutsummaryrefslogtreecommitdiff
path: root/games/vor
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-06-15 23:49:22 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-06-15 23:49:22 +0000
commit6169a4f8c808d34471e9ef30dc5c28b7697e0961 (patch)
treed4ef6565e8a56f20fe2414975ac7dfc650ff1592 /games/vor
parent99213c253b529662ea070a44cd6dfc9af6221faf (diff)
downloadports-6169a4f8c808d34471e9ef30dc5c28b7697e0961.tar.gz
ports-6169a4f8c808d34471e9ef30dc5c28b7697e0961.zip
Notes
Diffstat (limited to 'games/vor')
-rw-r--r--games/vor/Makefile1
-rw-r--r--games/vor/files/patch-Makefile25
2 files changed, 26 insertions, 0 deletions
diff --git a/games/vor/Makefile b/games/vor/Makefile
index 9724f8e29f8d..338d6d7ab81c 100644
--- a/games/vor/Makefile
+++ b/games/vor/Makefile
@@ -7,6 +7,7 @@
PORTNAME= vor
PORTVERSION= 0.5.4
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://qualdan.com/vor/ \
http://mirror.amdmi3.ru/
diff --git a/games/vor/files/patch-Makefile b/games/vor/files/patch-Makefile
new file mode 100644
index 000000000000..cf9a579bce57
--- /dev/null
+++ b/games/vor/files/patch-Makefile
@@ -0,0 +1,25 @@
+--- Makefile.orig 2009-05-29 07:45:20.000000000 +0400
++++ Makefile 2009-05-29 17:39:12.000000000 +0400
+@@ -15,19 +15,18 @@
+ # along with this program; if not, write to the Free Software
+ # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+-prefix = /usr/local
++prefix = ${PREFIX}
+ exec_prefix = $(prefix)
+
+ datarootdir = $(prefix)/share
+ pkgdatadir = $(datarootdir)/vor
+ bindir = $(exec_prefix)/bin
+
+-CFLAGS := -Wall -O3
+ LDFLAGS :=
+
+ paths := -DDATA_PREFIX=\"$(pkgdatadir)\"
+-sdl-cflags := $(shell sdl-config --cflags)
+-sdl-ldflags := $(shell sdl-config --libs)
++sdl-cflags := $(shell $(SDL_CONFIG) --cflags)
++sdl-ldflags := $(shell $(SDL_CONFIG) --libs)
+
+ ldflags := $(sdl-ldflags) -lSDL_image -lSDL_mixer $(LDFLAGS)
+ cflags := $(sdl-cflags) $(paths) $(CFLAGS)