aboutsummaryrefslogtreecommitdiff
path: root/games/vor
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2010-02-04 10:42:11 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2010-02-04 10:42:11 +0000
commit6d716216e64b8ed9599fbe9b02d9408320a92d64 (patch)
treef3a9647bf898b62313c8aff1c78a3c43b5f73cc0 /games/vor
parentfed180a6b50936f3ce35bcc57b4a162a9b8a5b7f (diff)
downloadports-6d716216e64b8ed9599fbe9b02d9408320a92d64.tar.gz
ports-6d716216e64b8ed9599fbe9b02d9408320a92d64.zip
Notes
Diffstat (limited to 'games/vor')
-rw-r--r--games/vor/Makefile6
-rw-r--r--games/vor/distinfo6
-rw-r--r--games/vor/files/patch-Makefile25
-rw-r--r--games/vor/files/patch-file.c13
4 files changed, 11 insertions, 39 deletions
diff --git a/games/vor/Makefile b/games/vor/Makefile
index f12b1409cf85..1eebf36131ee 100644
--- a/games/vor/Makefile
+++ b/games/vor/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= vor
-PORTVERSION= 0.5.4
-PORTREVISION= 3
+PORTVERSION= 0.5.5
CATEGORIES= games
MASTER_SITES= http://qualdan.com/vor/ \
http://mirror.amdmi3.ru/distfiles/
@@ -17,6 +16,7 @@ COMMENT= Dodge the rocks until you die
USE_SDL= mixer image sdl
USE_BZIP2= yes
+GNU_CONFIGURE= yes
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
@@ -26,7 +26,7 @@ DESKTOP_ENTRIES="Variations on Rockdodger" \
"Dodge the rocks until you die" \
"${DATADIR}/icon.png" \
"vor" \
- "Application;Game;" \
+ "Application;Game;ArcadeGame;" \
false
.if !defined(NOPORTDOCS)
diff --git a/games/vor/distinfo b/games/vor/distinfo
index 8934be09c509..67d4e84f7be2 100644
--- a/games/vor/distinfo
+++ b/games/vor/distinfo
@@ -1,3 +1,3 @@
-MD5 (vor-0.5.4.tar.bz2) = 9a4aebdeb4f14d337fe6af40d965d798
-SHA256 (vor-0.5.4.tar.bz2) = 33b56e5c65b1926a0f093c6512fa5949ae9336d928b8d8a805f760c9025bc2aa
-SIZE (vor-0.5.4.tar.bz2) = 196413
+MD5 (vor-0.5.5.tar.bz2) = a4eb90351dc19413e82ac0bc5269bc42
+SHA256 (vor-0.5.5.tar.bz2) = ead1b9786741e26d37ff7c5185b7fe1e91f90f76ebed3785225312e323b7c7da
+SIZE (vor-0.5.5.tar.bz2) = 239291
diff --git a/games/vor/files/patch-Makefile b/games/vor/files/patch-Makefile
deleted file mode 100644
index cf9a579bce57..000000000000
--- a/games/vor/files/patch-Makefile
+++ /dev/null
@@ -1,25 +0,0 @@
---- Makefile.orig 2009-05-29 07:45:20.000000000 +0400
-+++ Makefile 2009-05-29 17:39:12.000000000 +0400
-@@ -15,19 +15,18 @@
- # along with this program; if not, write to the Free Software
- # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-
--prefix = /usr/local
-+prefix = ${PREFIX}
- exec_prefix = $(prefix)
-
- datarootdir = $(prefix)/share
- pkgdatadir = $(datarootdir)/vor
- bindir = $(exec_prefix)/bin
-
--CFLAGS := -Wall -O3
- LDFLAGS :=
-
- paths := -DDATA_PREFIX=\"$(pkgdatadir)\"
--sdl-cflags := $(shell sdl-config --cflags)
--sdl-ldflags := $(shell sdl-config --libs)
-+sdl-cflags := $(shell $(SDL_CONFIG) --cflags)
-+sdl-ldflags := $(shell $(SDL_CONFIG) --libs)
-
- ldflags := $(sdl-ldflags) -lSDL_image -lSDL_mixer $(LDFLAGS)
- cflags := $(sdl-cflags) $(paths) $(CFLAGS)
diff --git a/games/vor/files/patch-file.c b/games/vor/files/patch-file.c
index e11e4d531a88..4f07bb2a58c2 100644
--- a/games/vor/files/patch-file.c
+++ b/games/vor/files/patch-file.c
@@ -1,13 +1,10 @@
---- file.c.orig Sun Mar 26 06:52:35 2006
-+++ file.c Mon Mar 27 02:30:51 2006
-@@ -101,9 +101,9 @@
- {
+--- file.c.orig 2009-12-10 00:28:59.000000000 +0300
++++ file.c 2010-02-04 05:50:54.000000000 +0300
+@@ -101,7 +101,6 @@
int i;
char *data_options[3] = {
-+ DATA_PREFIX,
getenv("VOR_DATA"),
- "data",
-- DATA_PREFIX
+- "data",
+ DATA_PREFIX
};
- for(i=0; i<3; i++) {