aboutsummaryrefslogtreecommitdiff
path: root/games/vultures-eye
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /games/vultures-eye
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'games/vultures-eye')
-rw-r--r--games/vultures-eye/Makefile12
-rw-r--r--games/vultures-eye/files/patch-win-vultures-GNUmakefile13
-rw-r--r--games/vultures-eye/files/patch-win-vultures-util-tiletrans.c37
-rw-r--r--games/vultures-eye/files/patch-win-vultures-vultures_gfl.c18
4 files changed, 67 insertions, 13 deletions
diff --git a/games/vultures-eye/Makefile b/games/vultures-eye/Makefile
index 7d5e5cfdfaab..592382ac358b 100644
--- a/games/vultures-eye/Makefile
+++ b/games/vultures-eye/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vultures
PORTVERSION= 2.1.0
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= games
MASTER_SITES= http://www.darkarts.co.za/projects/vultures/attachment/wiki/downloads/${PORTVERSION}/
PKGNAMESUFFIX= -eye
@@ -16,7 +16,7 @@ DISTFILES= ${DISTNAME}-full${EXTRACT_SUFX}?format=raw
MAINTAINER= llwang@infor.org
COMMENT= A graphical interface for NetHack 3.4.3 forked from Falcon's Eye
-LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
@@ -28,14 +28,10 @@ HAS_CONFIGURE= yes
CONFIGURE_WRKSRC= ${WRKSRC}/sys/unix
CONFIGURE_SCRIPT= setup.sh
DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
-MAKE_ENV+= DATADIR="${DATADIR}" MAKE="${GMAKE}"
+CFLAGS+= -I${LOCALBASE}/include/libpng15
+MAKE_ENV+= DATADIR="${DATADIR}" MAKE="${GMAKE}" BASECFLAGS="${CFLAGS}"
MAKE_JOBS_UNSAFE= yes
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|png_infopp_NULL|NULL|g' \
- ${WRKSRC}/win/vultures/util/tiletrans.c
-
pre-configure:
@${CHMOD} 755 ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
diff --git a/games/vultures-eye/files/patch-win-vultures-GNUmakefile b/games/vultures-eye/files/patch-win-vultures-GNUmakefile
index 3219b4ebc37f..3cbbee856ce9 100644
--- a/games/vultures-eye/files/patch-win-vultures-GNUmakefile
+++ b/games/vultures-eye/files/patch-win-vultures-GNUmakefile
@@ -1,5 +1,5 @@
---- win/vultures/GNUmakefile.orig Thu May 25 01:17:43 2006
-+++ win/vultures/GNUmakefile Thu May 25 01:28:16 2006
+--- win/vultures/GNUmakefile.orig 2006-06-06 21:23:29.000000000 +0200
++++ win/vultures/GNUmakefile 2012-05-03 21:04:37.000000000 +0200
@@ -12,7 +12,7 @@
ifndef SDL_CONFIG
OS := $(shell uname -s)
@@ -9,3 +9,12 @@
else
SDL_CONFIG := sdl-config
endif
+@@ -48,7 +48,7 @@
+
+ # objects and libs for tiletrans
+ TTOBJ := $(NHSRC)/monst.o $(NHSRC)/objects.o $(BUILDDIR)/util/tiletrans.o $(BUILDDIR)/util/tilespec.o
+-TTCFLAGS = -g -O2 -Wall $(SDL_CFLAGS) # tiletrans uses SDL_endian.h to become endian-safe
++TTCFLAGS = -g -O2 -Wall $(BASECFLAGS) $(SDL_CFLAGS) # tiletrans uses SDL_endian.h to become endian-safe
+ TTLIBS := -L/usr/local/lib -lpng -lm -lz
+ TILESRC := ./gamedata/graphics/tilesrc
+ TTOUTPUT := $(BUILDDIR)/vultures_gametiles.c $(BUILDDIR)/vultures_gametiles.h gamedata/graphics/gametiles.bin
diff --git a/games/vultures-eye/files/patch-win-vultures-util-tiletrans.c b/games/vultures-eye/files/patch-win-vultures-util-tiletrans.c
new file mode 100644
index 000000000000..0304cc186bd6
--- /dev/null
+++ b/games/vultures-eye/files/patch-win-vultures-util-tiletrans.c
@@ -0,0 +1,37 @@
+--- win/vultures/util/tiletrans.c.orig 2006-06-06 21:23:19.000000000 +0200
++++ win/vultures/util/tiletrans.c 2012-05-03 20:12:10.000000000 +0200
+@@ -9,6 +9,7 @@
+ #include "tiletrans.h"
+
+ #include "png.h"
++#include "pngpriv.h"
+ #include "SDL_endian.h"
+
+ #include "config.h"
+@@ -130,7 +131,7 @@
+ if (info_ptr == NULL)
+ {
+ fclose(fp);
+- png_destroy_read_struct(&png_ptr, png_infopp_NULL, png_infopp_NULL);
++ png_destroy_read_struct(&png_ptr, NULL, NULL);
+ return 1;
+ }
+
+@@ -138,7 +139,7 @@
+ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+- png_destroy_read_struct(&png_ptr, &info_ptr, png_infopp_NULL);
++ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
+ fclose(fp);
+ /* If we get here, we had a problem reading the file */
+ return 1;
+@@ -181,7 +182,7 @@
+ /* At this point you have read the entire image */
+
+ /* clean up after the read, and free any memory allocated */
+- png_destroy_read_struct(&png_ptr, &info_ptr, png_infopp_NULL);
++ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
+
+ /* close the file */
+ fclose(fp);
diff --git a/games/vultures-eye/files/patch-win-vultures-vultures_gfl.c b/games/vultures-eye/files/patch-win-vultures-vultures_gfl.c
index 6d10fc13ed8c..53556f084338 100644
--- a/games/vultures-eye/files/patch-win-vultures-vultures_gfl.c
+++ b/games/vultures-eye/files/patch-win-vultures-vultures_gfl.c
@@ -1,6 +1,6 @@
---- win/vultures/vultures_gfl.c.orig Tue Jun 6 21:23:28 2006
-+++ win/vultures/vultures_gfl.c Sat Jun 17 00:12:45 2006
-@@ -11,7 +11,7 @@
+--- win/vultures/vultures_gfl.c.orig 2006-06-06 21:23:28.000000000 +0200
++++ win/vultures/vultures_gfl.c 2012-05-03 22:41:55.000000000 +0200
+@@ -11,9 +11,10 @@
#endif
#include <SDL.h>
@@ -8,4 +8,16 @@
+/* #include <SDL_image.h> */
#include "png.h"
++#include "pngpriv.h"
+ #include "vultures_gfl.h"
+ #include "vultures_gen.h"
+@@ -73,7 +74,7 @@
+ goto out;
+
+ /* Set up error handling */
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ goto out;
+
+ png_set_read_fn(png_ptr, (char *)srcbuf, vultures_png_read_callback);