aboutsummaryrefslogtreecommitdiff
path: root/games/wargus
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /games/wargus
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'games/wargus')
-rw-r--r--games/wargus/Makefile6
-rw-r--r--games/wargus/files/patch-wartool.c20
2 files changed, 23 insertions, 3 deletions
diff --git a/games/wargus/Makefile b/games/wargus/Makefile
index 0a3625e64353..21b0ff117331 100644
--- a/games/wargus/Makefile
+++ b/games/wargus/Makefile
@@ -7,6 +7,7 @@
PORTNAME= wargus
PORTVERSION= 2.2.5.5
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://launchpadlibrarian.net/59493162/
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -15,7 +16,7 @@ EXTRACT_SUFX= .orig.tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= Warcraft 2 mod that allows you to play Warcraft 2 with Stratagus
-LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
RUN_DEPENDS= stratagus:${PORTSDIR}/games/stratagus
LICENSE= GPLv2
@@ -23,10 +24,9 @@ NOT_FOR_ARCHS= sparc64
USE_GMAKE= yes
USE_GNOME= gtk20 gnomehack
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
SUB_FILES= ${PORTNAME} pkg-message
-MAKE_ARGS+= CFLAGS+=-I${LOCALBASE}/include LDFLAGS+=-L${LOCALBASE}/lib
+MAKE_ARGS+= CFLAGS+="-I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15" LDFLAGS+=-L${LOCALBASE}/lib
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
diff --git a/games/wargus/files/patch-wartool.c b/games/wargus/files/patch-wartool.c
new file mode 100644
index 000000000000..7161df10796a
--- /dev/null
+++ b/games/wargus/files/patch-wartool.c
@@ -0,0 +1,20 @@
+--- wartool.c.orig 2010-11-22 22:44:24.000000000 +0100
++++ wartool.c 2012-05-05 12:37:53.000000000 +0200
+@@ -62,6 +62,8 @@
+ #endif
+ #include <ctype.h>
+ #include <png.h>
++#include <zlib.h>
++#include <pngpriv.h>
+
+ #include "endian.h"
+ #include "xmi2mid.h"
+@@ -1876,7 +1878,7 @@
+ return 1;
+ }
+
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ // FIXME: must free buffers!!
+ png_destroy_write_struct(&png_ptr, &info_ptr);
+ fclose(fp);