aboutsummaryrefslogtreecommitdiff
path: root/games/warmux/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-12-23 08:00:53 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-12-23 08:00:53 +0000
commit4982245c32c3e447452394d056f88a9692af1937 (patch)
tree88a65024d4ccd40d4f976deeb67414bf93a9bcf1 /games/warmux/Makefile
parente90f502ee40ed5bdcae822e64623eb80f69273be (diff)
downloadports-4982245c32c3e447452394d056f88a9692af1937.tar.gz
ports-4982245c32c3e447452394d056f88a9692af1937.zip
Notes
Diffstat (limited to 'games/warmux/Makefile')
-rw-r--r--games/warmux/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/games/warmux/Makefile b/games/warmux/Makefile
new file mode 100644
index 000000000000..2813888ccdb5
--- /dev/null
+++ b/games/warmux/Makefile
@@ -0,0 +1,44 @@
+# Ports collection makefile for: wormux
+# Date created: Thu Dec 16 18:46:55 EET 2004
+# Whom: Anton Yudin <toha@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wormux
+PORTVERSION= 0.5.0
+CATEGORIES= games
+MASTER_SITES= http://download.gna.org/wormux/
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}
+
+MAINTAINER= toha@toha.org.ua
+COMMENT= Wormux game
+
+USE_BZIP2= yes
+USE_SDL= sdl
+USE_GETTEXT= yes
+
+LIB_DEPENDS+= clanGUI-0.7:${PORTSDIR}/devel/clanlib-devel
+LIB_DEPENDS+= xml\\+\\+-1.0.1:${PORTSDIR}/textproc/libxml++
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lintl"
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+PLIST_FILES= bin/wormux
+
+CONFIGURE_ARGS+=--prefix=${PREFIX}
+GNU_CONFIGURE=yes
+
+.include <bsd.port.pre.mk>
+
+post-install:
+.for dir in ${PREFIX}/share/${PORTNAME}
+ @${FIND} ${dir} ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${dir} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+.endfor
+
+.include <bsd.port.post.mk>