aboutsummaryrefslogtreecommitdiff
path: root/games/warmux/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-10-23 13:08:41 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-10-23 13:08:41 +0000
commit21646392b027298c4aca08ad5386649a6869ccea (patch)
tree902ae1e48303d70f1045908f9eb477d7722924c8 /games/warmux/Makefile
parent6c8d9e9eb93b758a9136ea26f6d089c61feae712 (diff)
downloadports-21646392b027298c4aca08ad5386649a6869ccea.tar.gz
ports-21646392b027298c4aca08ad5386649a6869ccea.zip
Notes
Diffstat (limited to 'games/warmux/Makefile')
-rw-r--r--games/warmux/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/games/warmux/Makefile b/games/warmux/Makefile
index 6faeff391f3f..666eae647d74 100644
--- a/games/warmux/Makefile
+++ b/games/warmux/Makefile
@@ -11,8 +11,8 @@ MASTER_SITES= http://download.gna.org/${PORTNAME}/ \
MAINTAINER= makc@FreeBSD.org
COMMENT= Turn-based artillery game with free software mascots
-LIB_DEPENDS= xml++-2.6.2:${PORTSDIR}/textproc/libxml++26 \
- curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= libxml++-2.6.so:${PORTSDIR}/textproc/libxml++26 \
+ libcurl.so:${PORTSDIR}/ftp/curl
CONFLICTS_INSTALL= wormux-*
@@ -22,16 +22,12 @@ USES= gmake pkgconfig
USE_SDL= sdl image mixer ttf gfx net
USE_DOS2UNIX= fixed_class.h
-MANCOMPRESSED= no
-MAN6= warmux.6
-
OPTIONS_DEFINE= FRIBIDI SERVER NLS DEBUG
FRIBIDI_DESC= Enable bi-directional unicode support
SERVER_DESC= Enable dedicated server
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:R}
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@@ -63,7 +59,7 @@ PLIST_SUB+= SERVER="@comment "
.endif
.if ${PORT_OPTIONS:MFRIBIDI}
-LIB_DEPENDS+= fribidi:${PORTSDIR}/converters/fribidi
+LIB_DEPENDS+= libfribidi.so:${PORTSDIR}/converters/fribidi
CONFIGURE_ARGS+= --enable-fribidi
.else
CONFIGURE_ARGS+= --disable-fribidi